No announcement yet.

Howto reset to fresh fglrx 8.11 config in Ubuntu 8.10?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Howto reset to fresh fglrx 8.11 config in Ubuntu 8.10?

    So, I have fglrx up and running just dandy on my desktop monitor, so I figure, hey! let's hook up the HDTV (via composite) and see if we can get a second monitor going. (desktop monitor = [email protected] : HDTV = NTSC, 1080i)

    So I shut everything down and plug it in, reboot, and everything is good and works. Weird resolution choices though and some general weirdness with ccc with that setup. After a few restarts and reconfigurations I have a weird resolution of 3200x1200 (my hdtv doesn't support 1600x1200, must be scaled). Anyway, it was nice for a while, doing some video editing and such.

    I then had a brainwave to fire up Blender (windowed), and bam! My main screen's gnome panel loses half it's contents into the void and the hdtv goes black. dragging stuff around in the hdtv redraws everything, but yeah. I try Blender fullscreen, but it does the xinerama thing and it doesn't look so good stretched across these two displays. Ok, call it a night.

    Next day, fire up computer. Oh noes! gdm black screen! Well, my google-fu is crap, so that didn't turn up anything. I try restarting without the tv attached and that goes ok. But I can't plug it back in or I am greeted with the black screen once gdm fires up. Nutz!

    So, I guess I'd like those familiar with fglrx and all it's oddities to relate to me how to get a fresh, clean, like newly installed(tm) fglrx configuration so I can start all over (without reinstalling). I am not at all familiar with the ati/ubuntu way of doing things, so I am fairly newbish here.

    I guess I could try disabling xinerama too. How would I go about trying that?

  • #2
    To reset the basics, use:

    sudo aticonfig -f --initial

    If that doesn't solve your problems, you'll need to delete (or rename) the settings database at /etc/ati/amdpcsdb. It should rebuild itself using defaults on reboot.


    • #3
      This is what I did:

      sudo cp /etc/ati/amdpcsdb.default /etc/ati/amdpcsdb

      and that reset things.

      Now I have two new problems.

      1. When I set up independent displays (as opposed to cloned) with ccc, it is applied right away, but a message comes up and says I must restart for the changes to take effect. Then when I reboot, it's back to cloned and low resolution again, lol. I guess I can live with manually setting it everytime I boot, but it's strange, since it worked ok before I ran blender.

      2. I can't re-enable gdm with gnome's services-admin program, even if I start it with: gksu services-admin. The Unlock button is grayed out and I can't select any checkboxes. There still some bugs somewhere it would seem. Do I have to clean house on gconf or something? How would I do that?

      What's really strange about all this is how and why blender would blow up fglrx.