Announcement

Collapse
No announcement yet.

ati 8.11 on ubuntu intrepid

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ati 8.11 on ubuntu intrepid

    hi, i would like to report 2 errors installing latest ati driver (8.11) on ubuntu intrepid

    - installing driver with --buildpkg Ubuntu/intrepid, i have this error:

    (II) Loading /usr/lib/xorg/modules/extensions//libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    compiled for 7.1.0, module version = 1.0.0
    ABI class: X.Org Server Extension, version 0.3
    (EE) module ABI major version (0) doesn't match the server's version (1)
    (II) UnloadModule: "dri"

    - installing driver with gui mode (default mode), i have this error:

    fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
    [fglrx] Maximum main memory to use for locked dma buffers: 678 MBytes.
    [fglrx:drm_alloc] *ERROR* [driver] Allocating 0 bytes
    [fglrx:firegl_init_device_list] *ERROR* Out of memory when allocating device heads
    [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed


    device card: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] (ati mobility 9700)

  • #2
    The build scripts are wrong. You can not use em until you fix em. Thats what i do in my script:

    http://kanotix.com/files/install-fglrx-debian.sh

    Comment


    • #3
      it's wrong build scripts using first install mode but second error doesn't depend on build script, i think but maybe r300 support dropped.

      Comment


      • #4
        There are 2 error in the build script - results in not working fglrx kernel module and wrongly installed libs for xserver 1.5.

        a) Makefile not updated, you have to replace that by a newer one in

        packages/Ubuntu/dists/intrepid/replacements/Makefile

        b) No XARCH := x740 for intrepid - error in

        packages/Ubuntu/dists/intrepid/rules

        Both errors are fixed in the patch included in my script.

        Comment


        • #5
          can you explain how to fix these errors with your script?
          one question: can i use phorogit Catalyst Packaging Script to fix these errors?

          Comment

          Working...
          X