No announcement yet.

Catalyst 8.11

  • Filter
  • Time
  • Show
Clear All
new posts

  • #71
    I recently switched from ge8800gt to a hd4850, because of low 2d/3d performance. And no, I'm not using kde4.

    In 3dmark03 in wine the 4850 is a little bit faster than the 8800gt, despite the one gpu arch was released 6 month ago and the other 2 years ago. And both are more or less equal fast at 3dmark03 on windows. The nvidia driver is crap.


    • #72
      It doesnt run on HD3300 (RS780a?) aswell, I have an Asus M3A78-T (790GX), newest BIOS 0502, Ditributions Debian/Lenny i686 and Ubuntu/Intrepid AM64. On both distros and architectures the same problem: X freezes when trying to start it, xorg.conf is generated with "aticonfig --initial -f"
      I have just applied the patch to firegl_public.c by hand (also had to correct the last chunk by hand), going to reboot to the i686 kernel (the script doesn't build packages for the AMD64 kernel in i386 userland), rebuild, rip out the NV card and try 8.11.


      • #73
        Did you try raising the VGA memory size in bios?


        • #74
          Kano: are you talking to me? I have 128MB Sideport plus 128MB shared from main memory. Should be enough. I installed the patched driver, X worked now. DRI didn't though, same for XV (VERY poor performance when moving windows plus no chance for video fullscreen). So I forced
          Option "NoDRI" "off"
          #Option "VideoOverlay" "on"
          dont know if I still needed the second option.

          X started, DRI was fine, but XV was badly corrupted. Also, it isn't possible to build an AMD64 kernel module in i386 environment which is no problem with Nvidia binary drivers (for like a year IIRC). I have four gigs of ram so it's all of no use.

          Then I tried an old X300, radeon driver (debian/lenny, the radeonhd driver didn't support the X300). Everything went fine, glxgears were 90% speed of when using FGLRX, XV ran by default, very smoothly.


          For about five minutes :-/

          Then the whole machine froze completely. Rebooted, tried again, when using XV (Xine) the machine froze up again. Never had a problem with that card under windows or earlier fglrx using i686 kernel. Cooling is very good in my machine (many 120 fans).

          Ripped X300 out again, RS780 was disabled anyway, popped in NF8600, purged fglrx-*, installed nvidia-glx, reverted xorg.conf, rebooted, everything is fine now (except the machine (idle) sucking 20W+ more power now) :-(

          ATI GFX still is a nightmare to me. Never had remotely as many problems using Nv (starting with a 5200 when it was spankin new).

          Can't afford to convert my system to AMD64 currently though (time!) and AMD64 kernel + x86 userland went perfectly for me so far.

          Will try radeonhd again when it handles RS780 safely and is available as a debian package. End of story for now :-(

          Edit: funny part is that Ubuntu 8.10 AMD64 + shipped FGLRX driver (8.543) works just fine.
          Last edited by edgar_wibeau; 11-28-2008, 06:27 PM.


          • #75
            yes, thats the point. 128mb shared wasnt enough in my (our) case, I had to raise it to 256mb to get it working. I hope its a bug, because it is 128mb ram wasted...


            • #76
              Of course it's a driver bug as the IGP runs well under Windows with several drivers and Ubuntu 8.10 with their 8.543 driver. I patched FGLRX 8.11's firegl_public.c so that all "#ifdef __SMP__" were replaced with "#if CONFIG_SMP" (found that patch here in Phoronix forums, can't find it now - it was for some Suse flavour), installed, rebuilt the kernel module, installed that one and the driver worked, at least until XV usage froze the machine (first graphics, than sound, than a?verything).

              It (building the driver packages correctly, only a module for the i686 is being built) doesn't work with AMD64 kernel in x86 userland anyway and I don't want to mess with too many work-arounds as I update Lenny regularly and might switch to testing again once lenny is out for some time.

              I might give it another shot with 8.12. And 9.1 .. and 9.2 ..

              Oh my, I'm hoping for radeonhd to mature some day...

              Edit: So I've pulled radeonhd from git, built it, copied to /usr/lib/xorg/modules/drivers/
              It works, no hickups, no hang, no freeze. Yet, neither DRI nor exa nor xaa are supported by now, neither is Xv. I'm back to Nv :-/
              Last edited by edgar_wibeau; 11-28-2008, 11:21 PM.