Announcement

Collapse
No announcement yet.

Catalyst 8.10 / Ubuntu 8.10 - no X display on X1550

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    lspci.txt looks normal

    dmesg is missing these lines at end of fglrx startup:
    [ 52.945097] [fglrx] CMM init INV FB MC:0xf10000000, length:0x30000000
    [ 52.945106] [fglrx] Reserved FB block: Shared offset:0, size:1000000
    [ 52.945109] [fglrx] Reserved FB block: Unshared offset:ff77000, size:88000
    This may or may not be a factor
    -this could be the root problem, but I don't think so at this point
    -it could be because X isn't activating all of the card's features
    -it could be normal for your card

    Xorg.0.log show rejected connection requests.
    I'm guessing this is your display manager failing to connect. Odd because it should be root (user 0) instead of user 1000. This is definitely not right.

    xorg.conf looks a little mangled to me, too. Probably generated by Ubuntu.

    What I would suggest is the following:
    boot the system to runlevel 3
    -just add 3 to kernel options, if your system doesn't offer a "recovery mode" in your boot menu. X should not start.
    log in as root
    [CODE]
    rm /etc/ati/amdpcsdb
    rm /etc/X11/xorg.conf
    dpkg-reconfigure xserver-xorg
    aticonfig --init
    reboot
    [CODE]

    Oh, and it is runlevel 3, not 4, that is console. My bad :P

    Comment


    • #12
      I don't get what you want with different runlevels on Ubuntu or Debian. Runlevel 2 to 5 is usually identical. Suse and RedHat usually use 5 for X, so I adopted this for Kanotix too, but the correct way would be shutting down gdm or kdm directly for your example.

      Comment


      • #13
        If all I'm doing is deleting the fglrx config files and re-running the xorg config and the aticonfig --initial, I don't see why I need to run a special runlevel anyway. Wouldn't it be exactly the same to simply drop to console and do the same thing using sudo?

        Clarification on this would be greatly appreciated... and thanks for the help, both of you.

        Comment


        • #14
          try commenting out the line... (just add an "#" to the beginning of that line and save, as root.)
          Code:
          	Option	    "UseFBDev" "true"

          Comment


          • #15
            Ok, I went through the whole process. Deleted amdpcsdb, deleted xorg.conf, created a new xorg.conf using xfix (the right way to do it in xorg 7.4 by the way), then ran aticonfig --initial. I then doublechecked xorg.conf, no UseFBDev option present. It was a completely standard aticonfig created xorg.conf, no options whatsoever.

            On reboot, blank screen when X tries to start. I had to boot to recovery console to re-run xfix to get back to square one.

            Does anyone have any ideas? Are the ATI developers out there? Is this some general incompatibility with xserver 1.5.2? Where can I file a bug report for this?
            Last edited by Porter; 11-09-2008, 11:43 AM.

            Comment


            • #16
              Booting to runlevel 3 was to prevent X from loading. This is standard across most distros.

              Deleting /etc/ati only works if X is not running because it gets rebuilt when X closes. I think atieventsd is responsible, but I'm not clear on that. Switching VT isn't enough by itself.

              Comment


              • #17
                Originally posted by Porter View Post
                Ok, I went through the whole process. Deleted amdpcsdb, deleted xorg.conf, created a new xorg.conf using xfix (the right way to do it in xorg 7.4 by the way), then ran aticonfig --initial. I then doublechecked xorg.conf, no UseFBDev option present. It was a completely standard aticonfig created xorg.conf, no options whatsoever.

                On reboot, blank screen when X tries to start. I had to boot to recovery console to re-run xfix to get back to square one.

                Does anyone have any ideas? Are the ATI developers out there? Is this some general incompatibility with xserver 1.5.2? Where can I file a bug report for this?
                After installing the restricted drivers on my setup I was able to reboot, but I noticed that the desktop effects were turned on by default.
                Could your issue be related to compiz...maybe in a console remove compiz and see if that works.

                Comment


                • #18
                  Originally posted by lavinog View Post
                  After installing the restricted drivers on my setup I was able to reboot, but I noticed that the desktop effects were turned on by default.
                  Could your issue be related to compiz...maybe in a console remove compiz and see if that works.
                  I did that too... uninstalled all compiz packages prior to reboot. Fglrx just doesn't want to play nicely for some reason. It's odd that the radeon driver comes up immediately with no problems.

                  Comment

                  Working...
                  X