Announcement

Collapse
No announcement yet.

System Freeze on Switch user

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • milanvora
    started a topic System Freeze on Switch user

    System Freeze on Switch user

    I'm running Ubuntu 8.1 64 bits.
    Have 4g of ram. using radeon 3650 card

    whenever i do a switch user, the system freezes.
    If i do a logout and the log in all works.

    This issue has been going on now for approx 6 months. I thought the newest ubuntu & ati drivers would solve it.
    Any ideas if this is specific to myhardware or if other users are also facing it.

    Any ideas on how to solve it ?

  • Odur
    replied
    Update: fglrx 9.04 still has the same problem. The only change to my system is that I have installed Kubuntu Jaunty instead of Intrepid.

    Next time I'll buy an Nvidia...

    Leave a comment:


  • Odur
    replied
    Yes, of course. They are definitely related. I just meant that it was not exactly the same problem as I have, and that is why that solution doesn't work for me.

    If I start another VT and try to unload the fglrx module, I get a fatal error because the module is in use in my other session.

    Leave a comment:


  • alec
    replied
    there are several supgroups to this problem. For some it freezes on logout, for some on starting xinit (which is involved in user switching)

    Leave a comment:


  • Odur
    replied
    Oh, I see. Not exactly the same problem then.

    Leave a comment:


  • alec
    replied
    Originally posted by Odur View Post
    Could you explain that in detail? I have no luck whatsoever, so maybe I'm doing something wrong.
    I don't use gdm or kdm so after I log out of XFCE I am at VC/1
    usually if I try to xtartx or xinit after that, my pc hangs

    but when I tried that command, which basically reloads fglrx module (?), next xinit was normal.

    Leave a comment:


  • Odur
    replied
    Originally posted by alec View Post
    modprobe -r fglrx && modprobe fglrx
    before typing startx does help against black screen on second login
    Could you explain that in detail? I have no luck whatsoever, so maybe I'm doing something wrong.

    Leave a comment:


  • alec
    replied
    Originally posted by Odur View Post
    I tried the suggested solution in message 174 on page 7 in that thread. Didn't do any good at all...
    modprobe -r fglrx && modprobe fglrx
    before typing startx does help against black screen on second login

    Leave a comment:


  • Odur
    replied
    It worked for me with my old X600 card. But that was almost a year ago...

    Leave a comment:


  • RealNC
    replied
    Same here. I don't remember this feature actually ever working for me with any Catalyst release.

    Leave a comment:

Working...
X