Announcement

Collapse
No announcement yet.

Advice on issues with Ryzen and Linux (screen freezes, etc)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Advice on issues with Ryzen and Linux (screen freezes, etc)

    I'm at my wits end, and don't know where else to post for help. I've scoured the web looking for answers, and have found nothing. So first some info:

    I have a Ryzen 1800x CPU and Asrock Taichi x370 board with Samsung 950 SSD, Radeon 480 graphics and 64GB (4x16GB) 2400Mhz RAM. Problem is, I'm experiencing frequent freezes/lockups. There is nothing in the logs, since the freezes happen so fast. I just bought another motherboard (MSI x370 Carbon) and the same thing is happening.

    I can't use a computer like this. I could be browsing a webpage or writing code, and the system will just suddenly lock up. There is no apparent pattern to when this will happen. My previous system was an Intel-based 6700K, and I would leave that running for days at a time, and when taking suspend into account, it would be running for months at a time. Now, I can hardly get through a 2-3 hour session before everything locks up.

    I really hope I haven't been burned by the newest AMD hardware, because if this is the case, it will be a cold day in hell before I try AMD again. At this point, I'm considering going with the new Intel HEDT Skylake-X, but obviously I'd rather get the AMD stuff working, since I already have it and it's past the time to return it.

    Please help me. This is causing much anxiety, and I can't get any work done at all.

  • #2
    You're not entirely alone. I'm getting Ryzen freezes too but only when the system is idle so I suspect this is actually a different problem. Others have reported this too. I've used the netconsole kernel module to capture console output from the kernel that I normally wouldn't see but the results have shown no real pattern. When there is some output, it seems quite different each time, which suggests something very fundamental. You may have better luck with this approach. I hope you've tried the obvious things like disabling XMP if you've enabled it and updating your BIOS to the latest. A beta BIOS may be worth a shot, I'm going to try that myself soon. Luckily this board has dual BIOSes.

    Comment


    • #3
      Which kernel versions are you using ? There were a number of reported freezes on older kernels before all the Ryzen patches hit, but so far they seem to have gone away with 4.11...

      Comment


      • #4
        I've only tried 4.11, currently 4.11.3. I'm on Gentoo so I'm aware that this could easily be a configuration issue but I'm not exactly new at this. I'm using GCC 6.3.0, which should be good enough. The stock kernel doesn't offer an optimal choice of CPU to target for Ryzen so I've thrown in a Gentoo patch that adds -march=native. I gather -march=znver1 isn't a good choice right now. Although the FMA3 issue was reportedly fixed (my BIOS has AGESA 1.0.0.4a), one Gentoo developer said he saw segfaults disappear when he added -mno-fma. I haven't seen any segfaults but I figure this is worth a shot so I'm trying that next via KCFLAGS.

        Comment


        • #5
          So -mno-fma didn't work. Now trying just "Generic-x86-64".

          Comment


          • #6
            That does appear to have fixed it. Will try -march=bdver4 -mno-fma4 -mno-tbm -mno-xop -mno-lwp next.

            Comment

            Working...
            X