Announcement

Collapse
No announcement yet.

P-State Algorithm Change, Schedutil IOWait Boosting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • andre30correia
    replied
    with i7 6500u pstate works much better than cpufreq, with intel i7 4720hq cpufreq works better, depends the cpu, for exemple, with ulv cpu the vcore never come lower with cpufreq, some type of bug in kernel

    Leave a comment:


  • Gusar
    replied
    Originally posted by stqn View Post
    With Xfce panel plugins.
    *facepalm*

    Panel plugins or similar things (like conky) cannot show you what's actually going on with the CPU. They update at most every second, while the CPU state changes in *millisecond* intervals.

    Originally posted by stqn View Post
    How would I know if it’s in "C7"?
    By using proper tools to measure CPU activity, I mentioned the two best ones - powertop and turbostat. Run turbostat with the --debug switch, that way you'll also get C states, PC states (package C states) and in the latest version even the RC state (render C states, this one is the GPU). Powertop will show all of these as well.
    Last edited by Gusar; 01 August 2016, 01:10 PM.

    Leave a comment:


  • stqn
    replied
    Originally posted by Gusar View Post
    How are you measuring CPU usage? powertop? turbostat? Is the CPU at least in C7 most of the time?
    With Xfce panel plugins. How would I know if it’s in "C7"?

    Leave a comment:


  • linuxforall
    replied
    This is probably the reason why Clear OS disables pstate by default.

    Leave a comment:


  • cj.wijtmans
    replied
    Originally posted by Gusar View Post
    How are you measuring CPU usage? powertop? turbostat? Is the CPU at least in C7 most of the time?

    Anyway, it's possible you're one of those with a faulty experience, as the article puts it. I've been there too. Try a newer kernel. If that won't do, disable intel_pstate for now and fall back to acpi_cpufreq ondemand.
    intel_pstate is not working well here either, on kernel 4.6.4

    Leave a comment:


  • Gusar
    replied
    Originally posted by stqn View Post
    Edit: I switched to powersave but it changed nothing, still max turbo speed on all cores most of the time.
    How are you measuring CPU usage? powertop? turbostat? Is the CPU at least in C7 most of the time?

    Anyway, it's possible you're one of those with a faulty experience, as the article puts it. I've been there too. Try a newer kernel. If that won't do, disable intel_pstate for now and fall back to acpi_cpufreq ondemand.

    Leave a comment:


  • stqn
    replied
    Originally posted by Gusar View Post
    Err, performance mode is *supposed to* keep the frequency at maximum.
    Hm you’re right, although it doesn’t do that, which is a bit confusing.
    https://www.kernel.org/doc/Documenta...tel-pstate.txt

    Edit: I switched to powersave but it changed nothing, still max turbo speed on all cores most of the time.
    Last edited by stqn; 01 August 2016, 06:28 AM.

    Leave a comment:


  • Gusar
    replied
    Originally posted by stqn View Post
    on kernel 4.4.6 and below with intel_pstate in performance mode
    Err, performance mode is *supposed to* keep the frequency at maximum. And since at least something will be happening on a running system all the time, it makes sense that the core doing this something will be at max turbo. Of course that doesn't actually mean it's really at that freq all the time, because there's also C states - the freq is actually zero (the clock is gated) in states C3 and deeper.

    Basically, your system is behaving is you've instructed it to. Use powersave mode if you want frequency scaling. intel_pstate powersave is equivalent to acpi_cpufreq ondemand.

    Leave a comment:


  • stqn
    replied
    Indeed my CPU frequency monitor almost always shows that my i5 is running at its maximum turbo frequency (at least one of the cores), even with CPU loads around 1% (on kernel 4.4.6 and below with intel_pstate in performance mode). It will be interesting to see how the new algorithm behaves.

    Leave a comment:


  • phoronix
    started a topic P-State Algorithm Change, Schedutil IOWait Boosting

    P-State Algorithm Change, Schedutil IOWait Boosting

    Phoronix: P-State Algorithm Change, Schedutil IOWait Boosting

    While still in early form and won't be merged for this next kernel cycle (v4.8), a series of patches were published on Sunday to improve CPU frequency selection under Linux, including an algorithm change for the Intel P-State scaling driver...

    http://www.phoronix.com/scan.php?pag...o-IOWait-Boost
Working...
X