Several motherboard manufacturers have recently released BIOS updates for a number of their Z170 motherboards that provide significant scope for base clock (BCLK) adjustments to facilitate overclocking on Intel CPUs without the "K" designation. Here is some background and further information:

http://www.anandtech.com/show/9848/b...rs-coming-soon
http://www.tomshardware.com/news/sky...ios,30763.html
http://www.techspot.com/review/1108-...-overclocking/

The problem (as it relates to Ubuntu specifically anyway, and possibly other distros) is that taking advantage of this new "feature" prevents Ubuntu from booting (here is where it hangs: http://imgur.com/DQudsFe ). The system is at this point completely unresponsive and requires a manual reset/power cycle.

This is Ubuntu 15.10. It boots just fine at stock speeds. And it doesn't seem to be stability-related because even the most conservative of overclocks triggers this problem. In fact there is a boot performance mode in the BIOS called "Max Battery" which locks the CPU multplier to x8 during boot (which essentially results in an underclock) and even that triggers this problem.

Knowing that Skylake support in 15.10 is "hacky" I upgraded to Kernel 4.3. Same problem. I also tried a daily build of 16.04. Again, same problem.

Windows 10 boots just fine no matter what I'm doing with base clock speeds.

Here are the lines along which I am thinking. Certain things change when the base clock is adjusted (this is by design, for now at least). They are:

1) the iGPU is disabled (I'm using a dedicated GPU obviously)
2) Turbo Boost and Intel Speed Step are disabled
3) c-states are disabled ( http://images.anandtech.com/reviews/...ll/ULT/c10.png )

In other words: no more onboard graphics, and no more frequency scaling or idle states. So is Ubuntu somehow freaking out about the absence of hardware features that it expects to see? If so, how do we work around it?

Of course I could be way off base too. I've tried every kernel argument I could find that sounded like it might be remotely related to the problem I am experiencing without success (I should have kept track so I could detail my efforts more comprehensively here but unfortunately I didn't). And yes, I tried disabling the motherboards serial port because of where things hang during boot (although I can't imaging how that could be related anyway).

I'm flailing around in the dark a little bit here and would love some help.

I have observed this problem on two different Z170 motherboards with the same CPU (i5-6400).

Thanks