Announcement

Collapse
No announcement yet.

Trying To Run The Intel Core i7 5775C On Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    The info that i have is...brace yourselves...

    Skylake for Desktops will NOT have IrisPro...ONLY with Skylake Refresh (YEAH) there will be IrisPro for Desktops.

    Now...with DDR4 prices,etc. and this delay for Skylake IrisPro for Desktops in socketed version this chip (and AMD Zen w/ HBM *when* it arrives) seems much more interesting...
    However, the sweet spot of Broadwell for desktop is NOT the i7-5775C but the i5-5675C....all tests point to it.
    Last edited by AJSB; 04 July 2015, 08:04 AM.

    Comment


    • #22
      Did you try downclocking / downvolting it agressively? This might rule out any hardware-related issues...

      Comment


      • #23
        Wonder where other kernel and distro projects get connection with hardware manufacturers, to test hardware before release, to get it supported?

        Comment


        • #24
          At the moment it sounds like a faulty chip, this mostly due to the motherboard running other Intel chips fine. Kinda of a shame as I would have loved to see reports on how well the GPUs in these run. In my laptop Broadwell has been amazing though it will eat the battery if heavily loaded.

          Comment


          • #25
            I have a similar issue with this CPU (Core i7-5775c), on a MSI H97m-g43 and a Asrock Z97m WS mainboard, with the respective latest bioses. The later does not fully support this CPU, only the broadwell-xeons, and won't show the bios screens, but would boot a linux with kernel 4.1.1. But as soon as I try to compile stuff (Kernel), both setups would lockup. I could run this CPU with the MSI mainboard for several minutes, without any load, but as soon as there is load, the lockup would happen. I also saw mce-errors, but nothing too specific that I can recall. The CPU-temperatures I saw were normal, about 30-40 ?C.
            Another issue I had is the corruption of the console, with the X-Server running (KDE login). The screen would flicker and tear up, and stabilize for a few seconds, before tearing up again. Adding any load would lead to lockup and reboot.

            I had these issues with kernel v4.0.x and v4.1.1. Did not test Windows.

            I tried to disable HT, C-States and various CPU-specific options on the MSI board, and tried to lower the EDRam frequency to values lower than 1800, but nothing helped. Memtest, booted from a stick, on the other hand would run for hours with no issues.

            Right now I am running a core i3 from haswell refresh, and I do not have any issues with that.

            The MSI-support said the board series passed all tests with this CPU, and they could not help. I was told to test the CPU in another system. I read in an article that it ran fine on the MSI board with the latest bios, probably under Windows (??).

            One thing I wonder about is the microcode support for these CPUs under linux. The latest microcode for linux is from january, but the bioses of most h97/z97 mainboards were updated around may/june. Maybe there is some microcode issue.

            I also ran the IPDT from a UEFI boot stick, and they reported no issues.

            I got to thinking the CPU may be faulty, but maybe there is some kernel bug.
            Last edited by mtthsme; 04 July 2015, 03:19 PM.

            Comment


            • #26
              You can add a GFX card to check if it is related to the VGA part.

              Comment


              • #27
                Originally posted by Kano View Post
                You can add a GFX card to check if it is related to the VGA part.
                Yes, but unfortunately I don't have one lying around.

                Today I tested a bit, booted a System Rescue CD on that CPU, with a 3.18.14-alt453-amd64 Kernel. There was a bug as well, although the system did not freeze or crash or anything. I could start the X-server as well, with intel drm support. Then I also ran systester with 8 threads, and had no issues. So the CPU-part of the linux support seems okay, but the GPU not so much.

                Here is the log:
                Code:
                [    2.327246] [drm] Initialized drm 1.1.0 20060810
                [    2.328736] r8169 0000:02:00.0: irq 28 for MSI/MSI-X
                [    2.329131] r8169 0000:02:00.0 eth0: RTL8168g/8111g at 0xffffc90000658000, 44:8a:5b:99:7f:26, XID 0c000800 IRQ 28
                [    2.329133] r8169 0000:02:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
                [    2.337291] ------------[ cut here ]------------
                [    2.337302] WARNING: CPU: 6 PID: 332 at drivers/gpu/drm/i915/i915_drv.c:451 intel_detect_pch+0x18b/0x300 [i915]()
                [    2.337303] Modules linked in: i915(+) drm_kms_helper drm r8169 mii i2c_algo_bit wmi video
                [    2.337308] CPU: 6 PID: 332 Comm: modprobe Not tainted 3.18.14-alt453-amd64 #2
                [    2.337309] Hardware name: MSI MS-7924/H97M-G43(MS-7924), BIOS V2.9 05/22/2015
                [    2.337310]  0000000000000009 ffff8800d10b38c8 ffffffff8179488f 000000000000117c
                [    2.337312]  0000000000000000 ffff8800d10b3908 ffffffff8107613f ffff8800d1280000
                [    2.337313]  ffffffffa00874f1 ffff8800d1280000 ffff8800d11d9800 ffff880118b0b000
                [    2.337315] Call Trace:
                [    2.337319]  [<ffffffff8179488f>] dump_stack+0x46/0x58
                [    2.337321]  [<ffffffff8107613f>] warn_slowpath_common+0x7c/0x96
                [    2.337329]  [<ffffffffa00874f1>] ? intel_detect_pch+0x18b/0x300 [i915]
                [    2.337331]  [<ffffffff810761ed>] warn_slowpath_null+0x15/0x17
                [    2.337336]  [<ffffffffa00874f1>] intel_detect_pch+0x18b/0x300 [i915]
                [    2.337346]  [<ffffffffa0100919>] i915_driver_load+0x501/0xd65 [i915]
                [    2.337349]  [<ffffffff816cd87e>] ? netlink_broadcast_filtered+0x24e/0x27f
                [    2.337351]  [<ffffffff814939c0>] ? cleanup_uevent_env+0xf/0xf
                [    2.337354]  [<ffffffff8115240f>] ? kfree+0x35/0xe8
                [    2.337356]  [<ffffffff81494112>] ? kobject_uevent_env+0x593/0x5c9
                [    2.337358]  [<ffffffff8156ab5b>] ? get_device+0x12/0x1b
                [    2.337361]  [<ffffffff8156f198>] ? klist_class_dev_get+0x10/0x12
                [    2.337362]  [<ffffffff8156ab85>] ? put_device+0x12/0x14
                [    2.337364]  [<ffffffff8156c1c3>] ? device_add+0x524/0x536
                [    2.337369]  [<ffffffffa003440d>] drm_dev_register+0x79/0xef [drm]
                [    2.337374]  [<ffffffffa0036b30>] drm_get_pci_dev+0xfa/0x1b8 [drm]
                [    2.337376]  [<ffffffff81799bae>] ? _raw_spin_unlock_irqrestore+0x10/0x12
                [    2.337382]  [<ffffffffa00871fb>] 0xffffffffa00871fb
                [    2.337384]  [<ffffffff814c7002>] local_pci_probe+0x38/0x7d
                [    2.337386]  [<ffffffff814c710d>] pci_device_probe+0xc6/0xec
                [    2.337389]  [<ffffffff8156e752>] driver_probe_device+0x12c/0x2fb
                [    2.337391]  [<ffffffff8156e9b2>] __driver_attach+0x59/0x7c
                [    2.337392]  [<ffffffff8156e959>] ? __device_attach+0x38/0x38
                [    2.337394]  [<ffffffff8156cc76>] bus_for_each_dev+0x78/0x82
                [    2.337396]  [<ffffffff8156e1d0>] driver_attach+0x19/0x1b
                [    2.337398]  [<ffffffff8156de60>] bus_add_driver+0x12a/0x1f4
                [    2.337399]  [<ffffffff8156efaf>] driver_register+0x8a/0xc7
                [    2.337401]  [<ffffffffa0139000>] ? 0xffffffffa0139000
                [    2.337403]  [<ffffffff814c6186>] __pci_register_driver+0x47/0x49
                [    2.337407]  [<ffffffffa0036c40>] drm_pci_init+0x52/0xd2 [drm]
                [    2.337408]  [<ffffffffa0139000>] ? 0xffffffffa0139000
                [    2.337418]  [<ffffffffa013908a>] init_module+0x8a/0x2000 [i915]
                [    2.337419]  [<ffffffffa0139000>] ? 0xffffffffa0139000
                [    2.337421]  [<ffffffff81002170>] do_one_initcall+0xfa/0x187
                [    2.337423]  [<ffffffff8113d957>] ? __vunmap+0xa7/0xae
                [    2.337425]  [<ffffffff810cb31e>] load_module+0x189e/0x1f16
                [    2.337428]  [<ffffffff810c7faf>] ? store_uevent+0x39/0x39
                [    2.337430]  [<ffffffff8113bfce>] ? map_vm_area+0x25/0x30
                [    2.337432]  [<ffffffff8113dcb1>] ? __vmalloc_node_range+0x195/0x1f8
                [    2.337433]  [<ffffffff810cba0b>] ? SyS_init_module+0x75/0xca
                [    2.337435]  [<ffffffff810cba53>] SyS_init_module+0xbd/0xca
                [    2.337437]  [<ffffffff8179cb89>] ia32_do_call+0x13/0x13
                [    2.337438] ---[ end trace 083fe78ed81844cc ]---
                [    2.337440] [drm] Found 128MB of eLLC
                [    2.337538] [drm] Memory usable by graphics device = 4096M
                [    2.337540] [drm] Replacing VGA console driver
                intel_idle did not load, the CPU is not supported in that kernel version.
                Code:
                intel_idle: does not run on family 6 model 71
                I could not install Windows, although I wanted to try. Maybe I get to it soon.

                I have not heard a success story running this CPU or it's i5-brother under linux, maybe someone else heard of one, or had success him/herself. i would be glad to hear about it.

                Comment


                • #28
                  Hope to have some more findings out later today.
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #29
                    Got her running stable!! Workaround: http://www.phoronix.com/scan.php?pag...-OC-Fixed-Mode
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #30
                      Originally posted by Michael View Post
                      Got her running stable!! Workaround: http://www.phoronix.com/scan.php?pag...-OC-Fixed-Mode
                      Interesting. So there is an incompatibility, which only affects linux, as it seems. At least there seems to be no hardware bug.

                      Unfortunately I might not bo able to test this myself, since the MSI board probably does not have this specific option (H97) , and while the asrock board has this option in the firmware, the cpu is not fully supported, and I cannot change any firmware setting while running the i7.

                      Comment

                      Working...
                      X