Announcement

Collapse
No announcement yet.

The New AMD Energy Driver Is Working Out Well On Linux For Per-Socket/Core Reporting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The New AMD Energy Driver Is Working Out Well On Linux For Per-Socket/Core Reporting

    Phoronix: The New AMD Energy Driver Is Working Out Well On Linux For Per-Socket/Core Reporting

    Of the many features coming for Linux 5.8 one of the new drivers we are very much looking forward to is the AMD energy driver for finally exposing per-core and per-socket/package energy reporting of Zen/Zen2 CPUs under Linux. It's working out well so far in my evaluation...

    http://www.phoronix.com/scan.php?pag...r-Working-Well

  • #2
    Great news. 5.8 is looking to be very useful.

    Comment


    • #3
      I hope that this will be backported. Looking forward to getting accurate temperature measurements (lm-sensors' CPUTIN is not working on my motherboard. ASRock X470 Taichi Ultimate).

      Comment


      • #4
        Nice to see better amd processor support

        Comment


        • #5
          Originally posted by Jabberwocky View Post
          I hope that this will be backported. Looking forward to getting accurate temperature measurements (lm-sensors' CPUTIN is not working on my motherboard. ASRock X470 Taichi Ultimate).
          Do you mean by CPUTIN not working, as not being displayed at all ?
          On kernel 5.6 I cannot see it at all.

          Comment


          • #6
            Originally posted by Danny3 View Post
            Do you mean by CPUTIN not working, as not being displayed at all? On kernel 5.6 I cannot see it at all.
            What mobo and sensor chip do you have?

            Comment


            • #7
              I for one am looking forward to seeing some more Perf/Watt, CPU Speed and power comparison graphs out of PTS in future CPU comparisons

              Comment


              • #8
                Originally posted by Danny3 View Post

                Do you mean by CPUTIN not working, as not being displayed at all ?
                On kernel 5.6 I cannot see it at all.
                I have no problem seeing it on an ASRock X570 Pro4, on Fedora 32 with kernel 5.6.14:

                Code:
                [[email protected] ~]$ sensors
                nct6798-isa-0290
                Adapter: ISA adapter
                in0: 136.00 mV (min = +0.00 V, max = +1.74 V)
                in1: 1.67 V (min = +0.00 V, max = +0.00 V) ALARM
                in2: 3.39 V (min = +0.00 V, max = +0.00 V) ALARM
                in3: 3.42 V (min = +0.00 V, max = +0.00 V) ALARM
                in4: 1.86 V (min = +0.00 V, max = +0.00 V) ALARM
                in5: 1.20 V (min = +0.00 V, max = +0.00 V) ALARM
                in6: 1.34 V (min = +0.00 V, max = +0.00 V) ALARM
                in7: 3.39 V (min = +0.00 V, max = +0.00 V) ALARM
                in8: 3.23 V (min = +0.00 V, max = +0.00 V) ALARM
                in9: 1.71 V (min = +0.00 V, max = +0.00 V) ALARM
                in10: 1.02 V (min = +0.00 V, max = +0.00 V) ALARM
                in11: 632.00 mV (min = +0.00 V, max = +0.00 V) ALARM
                in12: 1.03 V (min = +0.00 V, max = +0.00 V) ALARM
                in13: 920.00 mV (min = +0.00 V, max = +0.00 V) ALARM
                in14: 896.00 mV (min = +0.00 V, max = +0.00 V) ALARM
                fan1: 909 RPM (min = 0 RPM)
                fan2: 4231 RPM (min = 0 RPM)
                fan3: 847 RPM (min = 0 RPM)
                fan4: 783 RPM (min = 0 RPM)
                fan5: 775 RPM (min = 0 RPM)
                fan6: 2641 RPM (min = 0 RPM)
                fan7: 0 RPM (min = 0 RPM)
                SYSTIN: +31.0°C sensor = thermistor
                CPUTIN: +33.0°C (high = +80.0°C, hyst = +75.0°C) sensor = thermistor
                AUXTIN0: +8.0°C sensor = thermistor
                AUXTIN1: -62.0°C sensor = thermistor
                AUXTIN2: +12.0°C sensor = thermistor
                AUXTIN3: +31.0°C sensor = thermistor
                SMBUSMASTER 1: +51.0°C (high = +105.0°C, hyst = +95.0°C)
                SMBUSMASTER 0: +41.5°C
                PCH_CHIP_CPU_MAX_TEMP: +0.0°C
                PCH_CHIP_TEMP: +0.0°C
                intrusion0: ALARM
                intrusion1: ALARM
                beep_enable: disabled
                
                amdgpu-pci-0700
                Adapter: PCI adapter
                vddgfx: 725.00 mV
                fan1: 875 RPM (min = 0 RPM, max = 3200 RPM)
                edge: +29.0°C (crit = +94.0°C, hyst = -273.1°C)
                power1: 31.19 W (cap = 160.00 W)
                
                k10temp-pci-00c3
                Adapter: PCI adapter
                Vcore: 938.00 mV
                Vsoc: 1.21 V
                Tdie: +40.9°C
                Tctl: +40.9°C
                Tccd1: +35.0°C
                Icore: 2.00 A
                Isoc: 6.00 A



                Comment


                • #9
                  Originally posted by Danny3 View Post

                  Do you mean by CPUTIN not working, as not being displayed at all ?
                  On kernel 5.6 I cannot see it at all.
                  CPUTIN displays on kernel 5.6, it has a static value of -62.5 regardless of my ambient temperature or system load. I know Noctua is good, but not that good. xD

                  I have the same problem as this person: https://github.com/rigred/sensor_config/issues/3 but I'm too lazy to debug it. The chip is reported as nct6779-isa-0290 (Nuvoton)

                  Comment


                  • #10
                    Originally posted by Jabberwocky View Post

                    CPUTIN displays on kernel 5.6, it has a static value of -62.5 regardless of my ambient temperature or system load. I know Noctua is good, but not that good. xD

                    I have the same problem as this person: https://github.com/rigred/sensor_config/issues/3 but I'm too lazy to debug it. The chip is reported as nct6779-isa-0290 (Nuvoton)
                    Weird, I have kernel 5.6 too, but I'm not seeing this option and its value at all, I don't know what I did, because I think I saw it in the past like last year.

                    I just used the 'sensors' command.

                    Comment

                    Working...
                    X