Announcement

Collapse
No announcement yet.

Intel P-State Driver Shifting To "Schedutil" Governor Default With Linux 5.7

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intel P-State Driver Shifting To "Schedutil" Governor Default With Linux 5.7

    Phoronix: Intel P-State Driver Shifting To "Schedutil" Governor Default With Linux 5.7

    On top of all the other changes in Linux 5.7 so far, a secondary set of power management updates were sent in today for this next version of the kernel and includes now using the Schedutil governor by default for Intel P-State and Arm big.LITTLE systems...

    http://www.phoronix.com/scan.php?pag...edutil-P-State

  • #2
    ah finally something sensible. pstate with powersave or performance weren't a good combo. Powersave is just not rsponsive enough and performance generates too much heat. I want intel's' cppu states management with a sensible cpu governor that doesn't hide away from bumping up the clocks when needed to ensure a very responsive system. I could disable pstate and just use schedutil but i think this will be a much much better deal

    Comment


    • #3
      Someone should check if www.vsynctester.com works without stutter in Firefox with Webrender while all C-states are set to auto in bios, it never did for me with anything but performance/no governor (not even Windows balanced).

      Comment


      • #4
        acpi-cpufreq performance > all the others

        Comment


        • #5
          Michael
          Thanks for the heads-up with regard to AMD's Zen CPU driver situation!

          Also, İ really hope it wouldn't be too much to ask if You could do a second round of schedutil benchmarking with the Android default of:
          Code:
          echo 0 > /sys/devices/system/cpu/cpufreq/schedutil/rate_limit_us
          You know, just for curiosities sake...

          Comment


          • #6
            Originally posted by perpetually high View Post
            acpi-cpufreq performance > all the others
            Could you tell us how you came to that?

            Comment


            • #7
              Originally posted by aufkrawall View Post
              Someone should check if www.vsynctester.com works without stutter in Firefox with Webrender while all C-states are set to auto in bios, it never did for me with anything but performance/no governor (not even Windows balanced).
              I am on clear linux, 1065g7, 5.6.2, firefox 40fps and stutter, brave(chromium) around 60 fps and all grey,
              Code:
              scaling_driver intel_cpufreq
              scaling_governor schedutil

              Update:
              I updated firefox to 75 and changed layers.acceleration.force-enabled to true and now get 60fps and all grey
              Last edited by Shtirlic; 07 April 2020, 10:30 AM.

              Comment


              • #8
                Originally posted by kcrudup View Post
                Could you tell us how you came to that?
                Just anecdotal, but I have no stock in acpi-cpufreq. You'll have to just try it for yourself. I believe Linuxxx gave a detailed breakdown of why in a previous post.

                To enable it, you will need to add "intel_pstate=disable" to GRUB first.

                Comment

                Working...
                X