No announcement yet.

Problems with Phenom II X4 940 and Biostar 790GXA2+

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with Phenom II X4 940 and Biostar 790GXA2+

    I've always been a huge AMD advocate. I always buy all AMD, but honestly I think I may done with AMD at this point.

    I drop $1,200 on parts for a new rig. I open the parts, and I don't get any case badges from AMD/ATI. This is a small thing, but as an AMD fan I always loved showing off my case badges with pride. NewEgg told me to contact AMD, which I did two weeks ago with no response. Are they cutting back on case badges to save money? Secretly I had even dared to hope that people who bought all three components in a Dragon platform setup at once would even get a Dragon platform case badge. I got none at all. This is the first time in my life that a retail proc didn't come with one. It is one of the reasons I don't order the OEM version.

    I ordered an 1GB ATI HD Radeon 4850, except it was DOA. Fans didn't spin, didn't power on, no video. I tried another PCI-X card in the slot to make sure it got power from the power supply with the connector, and to make sure I got video. It was fine.

    However, I have onboard video, so I RMA the video card and move forward. Next, I had my Biostar 790GX A2+ Mobo, and my Phenom II X4 proc. BIOS recognizes the proc. It is running cool and it makes it through post. I throw in the Windows 7 DVD I've used on two other computers. It loads EXTREMELY slow, and then BSOD. I repeat about 15 times, each time with a BSOD. I run memtest for four hours, and no problems. I'm on stock BIOS settings.

    I upgrade the BIOS, and still BSOD. I burn a new Windows 7 DVD, and again BSOD.

    Okay, well let's try Windows x64. BSOD after BSOD. I can't even get to selecting m HDD.

    I try Windows XP, and BSOD after BSOD. I try Vista (shudder) and I get BSOD after BSOD.

    I try openSUSE 11.1, 11.0 and 10.3, and all immediately lock up even before I can try to look at verbose kernel output.

    I try every live CD or diagnostic CD I can find. Most don't come anywhere near close to booting. I did actually manage to boot into an old Hirem Boot CD, and all the ancient diagnostics I can run say all my hardware passes, but it can only test 1 core of my CPU, which makes me wonder if the problem is another core. Post is probably only requiring the first core.

    I did get a Bart PE CD to load all the way into a Windows shell, but there are no chipset drivers so I really can't do much to diagnose the PC from there.

    I've yanked memory and run one stick at a time. I've run memtest over and over again. I have no PCI cards loaded at all, and no extra components. The problem is either mobo or CPU. Except I don't know how to diagnose which it is at this point. I've been fighting with the box for over a week and at this point I think I may just return the mobo and proc, and build an Intel rig.

    However, I decided I would make a last ditch effort and call tech support, except AMD has no tech support on the weekends. As a lifetime IT guy, I hate calling tech support and trying to explain yourself to someone who doesn't understand what you're talking about, yet refuses to pass you on to a level 2 guy for the first hour.

    I'm wondering if anyone has any suggestions at all, or knows of a diagnostic utility I can run to test the CPU.

  • #2
    I don't see how it matters that it's AMD. No matter what the brand is, if it doesn't work, you send it back. I did that with Intel.


    • #3
      Sounds like a buggy mobo or CPU...better RMA the mobo first


      • #4
        What gets me is that of the three major components (CPU, GPU and mobo) all three have their silicon made by AMD. At least two were bad.


        • #5
          Except for the CPU, I have the same set up and mine is blazing.