Announcement

Collapse
No announcement yet.

Linux 5.6 KVM Expands AMD APIC Virtualization Support With Dynamic APICv

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux 5.6 KVM Expands AMD APIC Virtualization Support With Dynamic APICv

    Phoronix: Linux 5.6 KVM Expands AMD APIC Virtualization Support With Dynamic APICv

    A second round of KVM virtualization updates were sent out today for the Linux 5.6 merge window that is still open through the weekend...

    http://www.phoronix.com/scan.php?pag...nded-AMD-APICv

  • #2
    Okay, now I'm confused.

    And anyone who says anything along the lines of "Oh gosh, how surprising" will be banned by Michael. Because Michael promised me that anyone who is mean to Mitch will be immediately evicted

    Seriously though, I thought I'd discovered a new way to speed up my W10 VM even more, which I didn't think possible, by creating a modprobe conf file with "kvm_amd avic=1."

    However dmesg reports "AVIC enabled" whether I set the option or not. It does seem to list it more with the option set, but as far as I can tell it's been enabled all along. But according to the way I understand this article, it isn't normally enabled by default.

    I'm running an R7 3700x on an x570 board, and recently switched from Manjaro to Arch because of difficulties creating Nvidia drivers for custom kernels (with Arch I just use nvidia-dkms). So I'm as close to the bone of pure Linux as I can get without compiling everything from scratch myself. And that doesn't mean I don't love my Gentoo et al. comrades, just that I'm too freakin' old and can barely endure the extra intricacies of Arch, much less a full scratch compile

    I am using a custom compiled 5.4.18 kernel though, but that's only because my keyboard arbitrarily disconnects with 5.5.x. I think it has something to to with resuming from suspend, but it's difficult to say because it doesn't happen right away. It just seems that 5 or 10 minutes after resuming I suddenly lose my keyboard. My mouse and all other USB devices are fine, and disconnecting/reconnecting, reloading modules, etc. doesn't fix it. So I just have to reboot.

    Comment


    • #3
      Michael, there is a typo.
      Originally posted by phoronix View Post
      APril

      Comment

      Working...
      X