Announcement

Collapse
No announcement yet.

AMD Ryzen 7 3700X + Ryzen 9 3900X Offer Incredible Linux Performance But With A Big Caveat

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by edmondztt View Post
    I actually tried with a newly made bootable USB stick, with version 16.04,18.04 and 20.04. what happened: it always goes into checking mode, whether i skip it or not, it will then enter the ubuntu icon screen and just freeze for a while before eventually goes into black screen.
    I don't wish to step on any toes by offering some suggestions myself, but if I may?

    A few questions:

    - You should see a GRUB screen first (listing OS, memtest etc) does it list something like "Compatibility Mode"? If so, would you try that?
    - Similarly, on the GRUB screen, you can hit "e" to edit the boot parameters (eg: acpi=off)... did you (or could you) try?
    - Have you tried any other distros? (CentOS, Manjaro, whatever...)
    - What GPU?

    ...

    Ryzen in general has been an odd experience for me in both Linux and Windows, although Linux by far has the most quirks depending on what CPU, board, GPU and kernel are being used. I've always managed to get everything working, but some setups need more gentle treatment. Sometimes it's as bad as one BIOS version will work, the next is messed up and the one after that is OK again. Occasional kernel regressions crop up as well.

    I've also had boards in the past have weirdly specific issues with a particular distro (*glares at Supermicro quad-socket G34 boards and RHEL/CentOS*) while working fine with other distros. I've also had systems which flat out refused to work with Ubuntu, but were OK with Mint (which is based on Ubuntu - no, I don't understand that either...)

    I'd really suggest the first thing is try a different USB stick, redownload the image and check it's OK via sha256.

    Also try a different USB port (not the second of a pair). If it has any USB2 ports, try one of them (if case has USB2 ports). I had strange issues years ago using a USB3 port to install Mint on a laptop...

    If that still throws a fit, try a different distro - something with a newer kernel if possible. An Intel box I am responsible for refused to boot with Ubuntu 18.04-19.10, but was OK with 20.04, each non-working distro threw a different collection of errors ending with blank screens or freezes, so you might find a distro using 5.6 or 5.7 lets you get to a desktop.

    If a newer kernel will get you to a desktop, but you absolutely must have Ubuntu, you could install the system on a different box, update to a newer kernel and swap the drive over - Linux doesn't usually mind that as much as Windows does, provided you don't have any exotic differences like RAID arrays etc.

    Comment

    Working...
    X