No announcement yet.

DFI LanParty UT NF590 SLI-M2R/G

  • Filter
  • Time
  • Show
Clear All
new posts

  • DFI LanParty UT NF590 SLI-M2R/G

    Has anyone bought this motherboard yet? I've read some good reviews, and one of them talked about how Linux worked well for his setup. Has anyone tried a Linux version other than SLED 10 (more specifically Ubuntu Edgy)? I'm wondering how Native Command Queueing (NCQ) is enabled as well... I know the libata package provides support for this feature, but what if your distribution doesn't come with this library by default? I was under the impression that you need to have this support in the OS at install time, but that may not be the case.

  • #2
    The board should work fine with recent Linux distributions and kernels -- or at least the nForce 590 Chipset should based upon my experience. Rob (Techgage) is on these forums so he may be able to comment more specifically with that motherboard.
    Michael Larabel


    • #3
      The one thing I've run into so far is using FakeRAID, AKA SATA RAID on the Nvidia controller. This isn't traditional RAID (just like on any other board with this chipset) because it requires some related software within the OS to work. dmraid is not included in the default Ubuntu Edgy install, but it is needed to support this type of RAID. Steps on getting this to work for an Ubuntu install (or any other Linux distribution without dmraid) are here:

      This is another good guide on the subject:


      • #4
        I didn't notice this thread until now.

        joshua, how is the board performing for you in general with Linux? I am not familiar with RAID in general, so I have no experience there. Regarding NCQ... I thought that was a default part of the drive, not something that had to be triggered by software?

        Regardless, I cannot speak highly of Linux on this board right now, but I haven't touched many distros on it since that review. I am using the latest Sabayon beta, and have run into -many- bugs with this system. I tested the same distro on other PC's and had no problems at all.

        So... I am wondering if this board has deeper Linux problems that I didn't catch earlier.


        • #5
          Well... it's a long story . I hate to admit it but I have really wanted to see what Neverwinter Nights 2 was all about over this holiday weekend, so one of the first things I did when getting my PC up and working is install that game (and WinXP underneath). I wanted to take advantage of the RAID 0 capability on the Nvidia RAID controller, so I set that up in the BIOS, dusted off my old floppy disk drive (to load the drivers the only way Windows installation allows), installed everything and then sat down for the rest of the night in NWN2.

          The next morning (two days ago) I decided I would install my Linux OS, and I soon found out the fakeRAID configuration that the Nvidia controller provides is not supported by default in Ubuntu Edgy (there is a package called dmraid that "supposed" to provide support for this feature), so I downloaded Gentoo 2006.1 LiveCD and preceded to install. Turns out that for some reason the dmraid package (that I enabled with a kernel option of dodmraid) didn't recognize my array, and all the things I have found related to this problem don't say anything on how to correct it... just that I can't use dmraid for my purposes.

          So at this point my plan is to try the other RAID controller on the motherboard, although I really don't know for sure if that controller uses fakeRAID or real RAID... I'll read about it before going through the reinstall. I could bypass all this by just not using the RAID capability of the board (and using software RAID), but then 1)I'd feel like I'm cutting myself short on the capabilities of the board I just threw down the money for, and 2)I would not be able to play Neverwinter Nights 2 over this holiday weekend .

          For what it's worth, the Gentoo LiveCD environment seems to work well with the hardware I have (in the sig), but I could not get Ubuntu Edgy LiveCD to work at all. I was getting some error with "Huh?" in it... and looking that up on Ubuntu forums showed that I'm not the only one with the same problem. The Ubuntu alternate CD is an option that would work for me, but not if I'm planning on using my current RAID setup (since the alternate CD doesn't come up in an environment that is capable of enabling the dmraid package before installation of the OS).

          I'll post with information on which route I take and how it goes.


          • #6
            After making the above post, I decided to focus on getting Linux up and working. I soon decided to drop the hardware RAID (otherwise known as FakeRAID in my situation) and go with Windows on a regular 50GB partition (using part of one disk) and Linux with 590GB (using softwareRAID/LVM over two disks). The setup of both environments went smoothly and I was ready to start installing extras, when I decided to get rid of the annoying bug in this board's shipping BIOS that hangs the system when you move down the list too far on the Basic Settings BIOS page. I downloaded the most recent BIOS (I believe it is 08/29/06) from DFI's website and followed their instructions to update the BIOS using a bootable floppy disk (thinking that would be more stable than the WinFlash route).

            Everything supposedly went fine during the update. The application asked me to press F1 to restart my comptuer, and then I received error codes 8A or 88 on the LED depending on if I performed a CMOS clear or not. Everything I found on the internet indicated that I had a bad BIOS update and would have to either RMA my board or send my BIOS chip back to DFI for a new one. Right now I'm waiting on a replacement board from Newegg, and this next time I'll use the WinFlash BIOS update route to get to the newest BIOS.


            • #7
              Wow that is retarded! I swear DFI should include a backup BIOS with their boards, meaning the literal chips. Since it's an "enthusiast" board, it's obvious that people will kill their BIOS eventually ;-)

              I do find that odd though... I had thought that I had a corrupt BIOS once and the DFI board just restored it... like a BIOS backup. That could have been my ASUS M2N32... I'm unsure.

              Sorry to hear about that though... hopefully NewEgg will get you a replacement quick!


              • #8
                Originally posted by Rob Williams View Post
                Sorry to hear about that though... hopefully NewEgg will get you a replacement quick!
                Actually Newegg is faster than what I thought... they received the board on Friday afternoon and by the end of the day they had already approved the RMA and it says I'll receive the replacement within 3-4 business days if I remember correctly.

                I was hoping a long 24-hour CMOS clear would have restored some functionality to the board after the initial problem, but all it did was change the error code from 8A to 88. It would be nice for DFI to include some type of a backup BIOS on the board... either that or just make it more user-friendly (read Linux-compatible) to upgrade the BIOS. I didn't have Windows installed on this box, and the only way you are able to update the BIOS is from within Windows one way or another: You can either do Winflash (obviously Windows-based), or use their extracting EXE file to create a boot disk. I tried to run the extracting EXE file from within wine, but it failed. So then I just unzipped the EXE and it gave me an IMA. I used mount -t msdos -o loop n5cd829.ima /mnt/image to view and copy those files to a bootable floppy disk. From all I can tell that should have been the way to do the job from within Linux, and I can find no reason why this method would have created a different boot disk than if I were to have run the self-extracting EXE from within Windows. The program even ran fine from the created bootable floppy disk and gave no errors during the BIOS upgrade. Who knows... either way a new board is coming soon. It's just annoying that you even need Windows to upgrade your damn BIOS. This isn't the 90's anymore.


                • #9
                  Has anyone messed around with lm-sensors on this board? Everything is installed and working great, but I would like to make an attempt at monitoring temperatures while in Linux. This is what I get after running sensors-detect:
                   Now follows a summary of the probes I have just done.
                   Just press ENTER to continue: 
                  Driver `pca9540' (should be inserted):
                    Detects correctly:
                    * Bus `NVIDIA i2c adapter 3 at 1:00.0'
                      Busdriver `UNKNOWN', I2C address 0x70
                      Chip `Philips Semiconductors PCA9540' (confidence: 1)
                  Driver `eeprom' (should be inserted):
                    Detects correctly:
                    * Bus `NVIDIA i2c adapter 2 at 1:00.0'
                      Busdriver `UNKNOWN', I2C address 0x50 (and 0x51 0x52 0x53 0x54 0x55 0x56 0x57)
                      Chip `DDC monitor' (confidence: 8)
                  I will now generate the commands needed to load the I2C modules.
                  To make the sensors modules behave correctly, add these lines to
                  #----cut here----
                  # I2C adapter drivers
                  # modprobe unknown adapter NVIDIA i2c adapter 0 at 1:00.0
                  # modprobe unknown adapter NVIDIA i2c adapter 1 at 1:00.0
                  # modprobe unknown adapter NVIDIA i2c adapter 2 at 1:00.0
                  # modprobe unknown adapter NVIDIA i2c adapter 3 at 1:00.0
                  # I2C chip drivers
                  # Warning: the required module pca9540 is not currently installed on your system.
                  # For status of 2.6 kernel ports see
                  # If driver is built-in to the kernel, or unavailable, comment out the following line.
                  #----cut here----
                  I can load the eeprom module without any problems, but but loading the other module doesn't work since it's not on my system, and the script doesn't have too much confidence in that module being the correct one to load anyway.


                  • #10
                    What version of LM_Sensors are you using?
                    Michael Larabel