No announcement yet.

Overclocking, and Linux install on ECS Z77H2-A2X question

  • Filter
  • Time
  • Show
Clear All
new posts

  • Overclocking, and Linux install on ECS Z77H2-A2X question

    Hi all,

    After reading Michael Larabel's article, "ECS Z77H2-A2X Ultimate Golden Edition Extreme" I built a system based on that board.
    Newegg had a deal, bundling with G.SKILL Trident X Series memory, DDR3 SDRAM 2400.

    I've tried running Mint 13 and Ubuntu 12.10 in Live CD mode; both hang just past declaring the language set. I was successful in loading Puppy 5.2 into RAM; he barked and wagged excitedly ;-)

    Then I noticed Michael's comment: "the stock [memory] frequency supported is up to 1600MHz. However, this motherboard does support DDR3-2800/2600/2400/2133/1800 memory in an overclocked mode."

    I've never overclocked anything, and have no idea if that's the problem with the other distros.

    Can someone help me learn what to do to make sure the memory frequency is accounted for?

    Any thoughts or tips on getting past the hang?



  • ddaupert
    [ Solved ] Overclocking, and Linux install on ECS Z77H2-A2X question

    Originally posted by ddaupert View Post
    Any thoughts or tips on getting past the hang?
    Installation attempt using arch provided the clue. I took a digital photo of error messages, and typed them out:

    Loading boot/x86_64/vmlinuz......
    Loading boot/x86_64/archiso.img..... ready
    Probing EDD (edd=off to disable)... ok
    early console in decompress_kernel

    Decompressing Linux... Parsing ELF... done.
    Booting the kernel.
    :: running early hook [udev]
    :: running hook [udev]
    :: triggering uevents
    [ 35.407911] ata5.00: exception Emask 0x52 SAct 0x0 SErr 0xffffffff action 0xe frozen
    [ 35.407941] ata5: SError: { RecovData RecovComm UnrecovData Persist Proto HostInt PHYRdyChg PHYInt CommWake 10B8B Dispar BadCRC Handshk LinkSeq TrStaTrns UnrecFIS DevExch }
    [ 35.407989] ata5.00: failed command: IDENTIFY PACKET DEVICE
    [ 35.408009] ata5.00: cmd a1/00:01:00:00:00/00:00:00:00:00/00 tag 0 pio 512 in
    [ 35.408009] res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x56 (ATA bus error)
    [ 35.408055] ata5.00: status: { DRDY }
    hangs here...

    The ata references led me to look at drive settings, connections, cables, then the manual. I realized either the manual instructions
    were (to me) incorrect, or I interpreted them incorrectly -- the graphic motherboard illustration IS correct, but I was following text
    instructions. I had swapped the SATA 2 optical disk drive and the SATA 3 harddrive connections. After sorting that, the box runs.


    Leave a comment:

  • ddaupert
    Found it

    Originally posted by Kano View Post
    Why don't you use the XMP profile?
    Lack of education. I build a machine maybe every other year or so. Meanwhile, everything changes.

    Thanks for that tip. I did learn how to enable the profile, and the numbers look good.


    Leave a comment:

  • Kano
    Why don't you use the XMP profile?

    Leave a comment:

  • ddaupert
    Settings so far, still looking for others

    I've been doing research on various memory timing settings in the bios.
    I've found info on some settings, but so far haven't found info on others.
    I've found definitions, but little info on how to calculate remaining settings.
    Contacted ECS support, learned they do not supply any info on memory
    Checked G.SKILL Trident DDR3-2400 manufacturer web, no joy.

    I'd appreciate any info, or links to read, especially how to know or how to
    calculate settings for the settings I am uncertain about.

    These are settings I am sure of:

    CAS# Latency(tCL) 10
    RAS# to CAS# Delay(tRCD) 12
    Row Precharge Time(tRP) 12
    Row Active Time(tRAS) 31

    These settings I *think* are correct:

    Memory Clock Multiplier 1.00
    Memory Multiplier 24

    I am looking for info on these:

    Command Mode(tCMD) 1 or 2?
    Write Recovery Time(tWR) ?
    Row Refresh Cycle Time(tRFC) ?
    Active to Active Delay(tRRO) ?
    Write to Read Delay(tWTR) ?
    Read CAS# Precharge(tRTP) ?
    Four Active Window Delay(tFAW)?
    Refresh Interval(tREFI) ?
    CAS# Write Latency(tCWL) ?
    CKE minimum pulse width(tCKE) ?


    Leave a comment: