No announcement yet.

ASRock 939Dual-SATA2 Network Problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • ASRock 939Dual-SATA2 Network Problems

    Originally posted by Michael View Post
    Yes, it had functioned appropriately with Fedora Core 4/5. I don't believe we had to do anything special for the onboard LAN support.
    I have a problem with the onboard lan also. I'm a Linux newbie, having never used it before, but my friend helped through a gentoo install, only to find it didn't finish installing. So I tried Mandriva, and it installed fine, with no problems, but could not connect to the internet. I have now tried fedora core 4, with the cd's I got from my dad, and it also installed fine, and I did a complete install, with ALL options checked off, using all 4 disks. The internet is still not working. I am really interested in getting linux working, as I am not fond of windows, and am really not looking forward to vista coming out, so I want to use linux. But for some reason, it's not working.

    Any idea's on how to make it work?

    asrock dual sata 2 939 with onboard Lan/sound
    X-2 3800+ overclocked to 2.3ghz
    ATI 9600XT with 256 mb ram
    4 ram chips, all non-name brands, 2x 256, x1 512, x1 1024 for a total of 2gb ram.
    One IDE hard drive, one scsi drive, one sata2 drive.
    DVD drive
    CD burner.

    And that's my system. THe internet doesn't work, and without internet, I see no reason to have a computer, but that's just me. So, I'll most likely be going back to windows. :-/

  • #2

    Welcome to the forums.

    For a new installation, may I ask why you chose FC4 over FC5 or FC6?

    Did you update the kernel after installing FC4? If not, download an updated kernel (and kernel-devel) and then transfer it to the machine followed by installing the packages. After that, reboot and see if the device is then able to show up in system-config-networking.
    Michael Larabel


    • #3
      Hey, dragon, did you disable IPV6? Worked for me when we couldn't go online. You can turn off IPV6 within the OS, or turn it off in side the browser. Just google "Firefox disable IPV6" Easy


      • #4
        I chose fedora 4 becuase I had the disk's already for it, no other reason. I didn't know there was a 6, but I was downloading the version 5 on windows, to upgrade to if it seemed to work.

        As for IPV 6 I have no idea what it is, and didn't disable it. Is it a browser thing? As it would seem to be something to do with browsers, since you mention firefox. I can't connect to the internet at all. Not even ping my router. I'll try that though. :-(


        • #5

          Fedora Core 6 is being released next week, though the Fedora Core 6 FC6-pre is available, and then update to Rawhide. You may just want to wait for the official release if you are new to the GNU/Linux world.

          IPv6 is Internet Protocol Version 6. I never had default problems with IPv6 on any Fedora release, as it is disabled by default in system-config-networking.

          When you enter system-config-networking do you see your NIC in there setup as an interface or not?
          Michael Larabel


          • #6
            Well, as my version 5 is done downloading, I decided to upgrade stright to it, rather then fiddling around in version 4 some more. I'm doing that as I type this out, on my laptop. If that fixs the problem, great. If not, I'll try disabling IPV 6.


            • #7
              So, I finished upgrading to fedora 5, and it still couldn't ping the router, so I tried disabling the IPv6 and that didn't help. Don't really know what else to try.


              • #8
                Originally posted by Dragon View Post
                So, I finished upgrading to fedora 5, and it still couldn't ping the router, so I tried disabling the IPv6 and that didn't help. Don't really know what else to try.
                Did you check system-config-networking to see if the network interface is even there and activated?
                Michael Larabel


                • #9
                  Ok, just booted into linux, and checked it out, tried to type out the information on a floppy, thinking a .txt would be read by both windows and linux, but it didn't work. :-(

                  Anyway, going from memory, the network config looked like this:

                  Devices tab: Totaly empty

                  Hardware tab:
                  ALi Corporation M5263 Ethernet Controller eth0 Status: ok

                  IPsec tab: Totaly empty

                  DNS tab:
                  hostname: localhost.localdomain
                  Rest of the fields were empty

                  Host Tab: Totaly empty

                  Going to boot back into linux, and write down the stuff, rather then making a txt of it, and edit in the stuff I missed, so I'll edit in a few minutes.

                  Ok, fixed the few things I had forgotten. Oh, and if it matters, I'm not really dual booting, as I have linux and windows on their own hard drives, and I only plug one in at a time, so now I have the windows hard drive pluged in, to boot into linux, I unplug windows, and plug in linux.
                  Last edited by Dragon; 10-09-2006, 04:44 PM.


                  • #10
                    Okay, so it's detected under hardware section but isn't setup yet as a device.,,

                    When you go into system-config-networking hit the "New" button and follow the setup process for an Ethernet connection... it should be relatively straightforward, but if you get stuck just ask. After that, activate the network connection and it should be all set to go

                    (Splitting this topic to make it easier for other users to search for)
                    Michael Larabel