No announcement yet.

ASUS Sabertooth X79 and Linux (Ubuntu or Linux Mint/Debian) - any experience?

  • Filter
  • Time
  • Show
Clear All
new posts

  • ASUS Sabertooth X79 and Linux (Ubuntu or Linux Mint/Debian) - any experience?

    I'm building a new rig and want to order the Asus Sabertooth X79 MB with a i7 3930K (VT-d enabled) processor.

    Does anyone here have experience with this board and Linux?

    I probably install either Linux Mint (perhaps the new Debian version), or Ubuntu. I've been using Linux Mint for some years now and am very happy with it as a desktop OS.

    I also need to use VT-d to enable PCI passthrough for a Windows 7 VM (not sure if the hypervisor is going to be KVM, Xen, or whatever). The latest Bios releases are mentioned with VT-d support.

    What is your experience with Asus and specifically this board?

    Has anybody experience with other X79 board(s)? Or recommendations?

    Need to decide quickly.


  • #2
    No experience with Asus Sabertooth X79 board?

    Have I posted in the wrong place, or is there really nobody who can attest that the Asus Sabertooth X79 board works with Linux (preferably Debian or Ubuntu)?

    Hope to get a some input. Thanks in advance.


    • #3
      I personally would go for Z77+i7-3770 (without K!) if you don't want to run Gentoo/Arch or compile lots of things. But basically any board should do. vt-d is however often problematic especially when you want to run nvidia drivers. There was a time where U enabled intel_iommu by default in the kernel (because it got renamed) and then this caused much trouble as only nouveau worked and not nvidia binary. I think fglrx worked as well and Intel of couse. The default is now


      Using intel onboard (on Z77) you have got at least one working vga "card", if you paththru nvidia it might work, did not test that. (I don't own X79, just H55, Q67, Z68.) Don't forget to use intel_iommu=on as option (it is not called vt-d, but thats exactly what you want). Also if you want to use i7-3930K you definitely have to look that you get C2 stepping.


      • #4
        Got it all working with Xen

        Thanks kano !!!

        I got it all working now - and it works GREAT !!!

        I'm running Linux Mint 13 64bit with Xen hypervisor 4.1.2 (from packages) with a Windows 7 Pro 64bit as guest domU (VM) using VGA passthrough on a secondary Nvidia Quadro 2000 ("multi-OS") graphics adapter. Both Windows and Linux run concurrently and I can switch between them at the press of a button (KVM switch). Both my graphics adapters are connected via DVI to a NEC 26" screen which automatically switches to the other port when it receives and input signal.

        Windows performance (mind you - as guest system) is stellar, with a Windows Experience Index of 7.0 (lowest value is graphics, RAM is 7.9, CPU 7.8, disk 7.8).

        Here the hardware:

        Asus Sabertooth X79 with 1203 BIOS
        i7 3930K (C2 stepping)
        PNY Quadro 2000 (Nvidia) as secondary graphics adapter for Windows only (passed through) using latest Nvidia driver under Windows
        AMD 6450 as primary graphics adapter - this is the only part I will replace - it sucks performance-wise, even with AMD proprietary driver!
        32GB Kingston quad-channel RAM (8 DIMMs)
        120GB SSD for Linux and Windows OS, formatted to LVM
        Several 2TB hard drives using LVM, a 1TB drive, and a 500GB drive for data
        External USB drive for backup.

        I initially tried to pass through a PNY Quadro 600 card but that didn't work. It's not "multi-OS" specified (Nvidia terminology for passthrough enabled).


        • #5
          Re Asus Sabertooth X79 motherboard

          In my last post I gave a hardware list for my current system running a Xen hypervisor with Linux Mint 13 Mate as dom0 and Windows 7 Pro as domU with VGA passthrough. It was quite a challenge to get everything working, but now it works fine.

          However, while it works for me, I do NOT want to endorse the Asus motherboard, for the following reasons:

          1. Someone on the Asus forum reported that the newer BIOS releases break VT-d, which is essential for VGA passthrough under Xen. In that case BIOS release 1203 (the one I use) is the last release that works. Asus denies that VT-d isn't working, but at the same time acknowledges (or states as a matter of fact) that they don't support Linux. Unfortunately the new BIOS releases cannot be reverted, according to Asus. I can neither confirm nor deny this report, as I don't want to brick my system.

          2. The Marvell SATA controller doesn't work under Xen, and also gives problems under a regular kernel. I reported a bug at and got the following response from kernel development:
          This bug affects vanilla kernels up to and including 3.6.3.

          The problem seems to be a design issue with the Marvell controller. With
          VT-d enabled, each device gets its own "view" of memory it can get
          access to. The Marvell chip only registers one device per SATA port, but
          actually uses more than one device. It's this second phantom device that
          is not allowed memory access when VT-d is enabled.

          It may eventually be worked around in the kernel, but it's not an easy
          fix. AFAIK the current thinking is to register the phantom device
          automatically when the first one is found.
          In other words, I can't use the Marvell SATA controller and have to disable it. I really could have used the additional SATA ports! This leaves me with "only" 5 internal disks plus a DVD drive (6 drives altogether).

          3. I wrote to Asus about the issues above and Linux support in general, actually I asked them if they support anything but Windows. The reply from technical support was short and clear: no Linux support, only Microsoft Windows.

          Given the risk involved when running an OS that is not supported, it means that Asus motherboards are NOT suitable for anything but Microsoft Windows, at least as of now.

          I should have paid more attention to that when I bought my hardware.


          • #6
            ASUS even lists Sabertooth X79 on their Linux compatibility list but they only seem to try to install a couple of distributions as a test.


            I wonder if they care more about BIOS bugs on their workstation series motherboards.


            • #7
              Originally posted by _pLu_ View Post
              ASUS even lists Sabertooth X79 on their Linux compatibility list but they only seem to try to install a couple of distributions as a test.


              I wonder if they care more about BIOS bugs on their workstation series motherboards.
              Thanks for this list. Strangely enough searching for Linux on their website turns up 1 item: a WiFi USB stick. There is no mention of Linux support under the product itself. Last not least, I asked Asus just to be sure. Here the answer:

              Thank you for contacting ASUS Technical Service.

              1. We don't officially support Linux on desktop motherboard. So, we don't have drivers to provide.

              2. Maybe you haven't loaded Marvell controller driver.

              3. We don't broke vt-d in new bios. As long as cpu could support vt-d, you could use vt-d.

              Sorry for the trouble. Wish you a good day.

              If you continue to experience issues in the future, please do not hesitate to contact us again.
              Best Regards,
              ASUS Global Technical Support Center
              So, no Linux support. If I update my BIOS and it breaks VT-d under Linux, it will be my problem. Since there is no way back to install an older driver (.ROM file), the board would become useless to me.

              The fact that Asus doesn't support Linux officially means that even if it works now, there is no guarantee that a BIOS update won't break things, and they have no obligation whatsoever to fix the problem.

              VT-d is reportedly broken in BIOS 200x, but I can't verify it because if I did there wouldn't be a way to return to the old BIOS.