No announcement yet.

Nemo's experience of the Abit AN-M2HD motherboard with Kubuntu Feisty Fawn

  • Filter
  • Time
  • Show
Clear All
new posts

  • Nemo's experience of the Abit AN-M2HD motherboard with Kubuntu Feisty Fawn


    I posted here previously about getting a abit AN-M2HD motherboard for a new system I was building (my first one, I might add). It arrived over a week ago, but I only got the rest of the stuff I needed this Thursday. What follows is an account of building my machine, and installing and setting up Kubuntu on it. It also sort of functions as a review of the AN-M2HD for Linux users, and includes some tips for first time builders and Linux users. BTW, this is the first time I have used (K)ubuntu – previously I used Fedora Core 6.

    My build is as follows:
    • Coolermaster Cavalier 3 CAV-T03 Silver midi tower case NO PSU
    • ThermalTake TR2 470W Black Silent +ATX 12V 2.0 PSU, 20pin +4pin SATA ready
    • Abit motherboard AN-M2HD socket AM2 nVidia 7050PV PCI-E x16 Integrated VGA + digital HDTV support SATA 3G RAID 8ch Audio GB LAN micro ATX
    • AMD Athlon 64 X2 4600+ (2.4GHz) Socket AM2 L2 1MB 2x512KB Cache Retail Boxed Processor
    • Corsair 2GB Kit (2x1GB) DDR2 675MHz/PC2-5400 XMS Memory Non-ECC Unbuffered CL4(4-4-4-12) Heat Spreader
    • 500GB Seagate Barracuda SATA II 300 7200rpm 16MB cache
    • Liteon LH-20A1H-487C 20xDVD?RW/DL LightScribe Beige, Black & Silver Bezels
    I also bought a 2GB USB stick for backing up my files (Corsair 2GB USB Flash Drive Flash Voyager), a cheap USB to serial adapter (this motherboard has no serial port), and the Kubuntu Feisty Fawn 7.04 Live/Install DVD.

    I had most of the system put together by Thursday, and finished by installing the CPU/fan and DVD on Thursday afternoon. All in all it didn't take long to put together (though I did it in several stages). It took two people to install the power supply (a very tight fit in the case). The only problem I had was when screwing the motherboard into the case one screw cross-threaded and jammed (would neither tighten or lossen). When I tried to undo the screw the brass standoff unscrewed, and then the real fun began! So I had to remove the motherboard, and tried gripping the brass standoff with pliers, and unscrewing the screw, but it wouldn't budge, and I ended up stripping the cross from the top of the screw with the screwdriver! After a brief panic, and then a longer panic, I got someone to clamp the standoff with some chunky molegrips (not easy when you are millimeters from delicate electrical components) while I managed to loosen the screw with a pair of pliers. I had serious problems with many screws cross threading, though none jammed as badly as that one. It seems that some screws fit nicely in some standoffs but others would crosssthread easily – I managed to pair up each of the screws with a matching standoff before reinstalling the board. In future I would check this beforehand, and I would also have bought a nutdriver to tighten the standoffs so they don't undo when loosening a screw. You live and learn.

    Despite advice to the contrary I fitted the memory and CPU after installing the motherboard. I had no problem with this, though inserting the memory took some effort, and the board creaked a little. I'm far too impatient, and when I got the board and case a week before the memory and CPU decided to go ahead anyway. I guess this can be risky, and the motherboard could crack – so be warned!

    The manual with the Coolermaster case is next to useless (too simplistic for an expert, not detailed enough for a beginner), but connecting the cables was easy enough. The only awkward connection was the front panel audio, which had separate sockets for each wire. Luckily the sockets are labelled clearly enough. The only other thing to note is that the front panel firewire connector on the board is at the back, and the wire in the case is only just long enough to reach, and is pulled tight across the bottom PCI connector. Also, the case has a mysterious molex cable that comes from the font of the case (not the front fan) – this appears to be for a VU meter which comes with another version of the case. I'm not sure what the other ends of the wires are connected to, and left it unplugged.

    I initially left the DVD and HDD (and monitor and keyboard) unplugged, just in case anything went badly wrong, and switched on the PSU (with the side of the case still open). A red LED lights on the motherboard to let you know the power is connected. Powered on from the front of the case (I've had serious problems with dodgy on/off buttons on store bought PCs – this one has a nice sturdy switch) and a green LED lights on the motherboard, the fans start up, and a few moments later there is a beep from the case's speaker. It POSTed perfectly first time! (This is my first build, so you'll have to forgive my over excitement.) I powered off, and finished connecting everything up. Then I had a go at booting Knoppix from a DVD – and it worked fine first time (though only using a basic graphics driver). Before installing Kubuntu I reset the CMOS and had a fiddle with the BIOS settings, and set the clock etc. It is worth noting that the manual for the motherboard incorrectly states the jumper settings for clearing the CMOS (left two pins for normal, right two to reset CMOS). It is actually the other way around (I knew this beforehand, incidentally), but is correctly labelled on the sticker Abit supply for sticking inside the case.

    I then set about installing Kubuntu, which was easy enough – though I had to use the safe graphics mode to install (the X server failed to start from the DVD when I initially tried the default boot settings). Installation went well, and within about 15 minutes I had Kubuntu booting from my hard disk. I was able to connect to the Internet via my router fine from Kubuntu (though I couldn't get a connection from Knoppix), the on-board sound worked, and the graphics were reasonable given they were using a generic driver by default. Now I had to set about installing the nvidia driver (if only to get a higher screen resolution). Once you know how to do it, it is easy enough. I may have been able to install from the Kubuntu repositories, but my initial tests were met with failure, so I downloaded the latest drivers from nvidia's website (the GPU is very new, and so are the drivers). In hindsight, I may have been able to use the pre-packaged ones from Kubuntu, but I'll tell you how I did it. I followed Method 2 from this website – which seemed to work fine. I ran startx from the console, and (after editing xorg.conf) I got a nice 1280x1024 display on my LCD monitor. I ran glxgears, and 3D worked fine. So I rebooted, and then X refused to start – though it didn't crash, and I was able to get to a console using Alt+F1. startx refused to work from the console, with some error message about an API mismatch. I eventually managed to get X to start by running “modprobe -r nvidia” – but it would always fail on reboot. Googling found no solution. However after several hours of messing about I solved the problem. Despite having supposedly uninstalled the nvidia drivers supplied with Kubuntu I found they were still there. Running “modprobe -l | grep "nvidia"” showed four different versions of the nvidia driver running. I checked the date of the files and one of them was dated that day, the rest were older. So I modified the last line of /etc/default/linux-restricted-modules-common to read: DISABLED_MODULES="nv nvidiafb nvidia_new nvidia_legacy" – which would disable all the other versions of the driver but the one I wanted. At least that was the theory – and I turned out to be right! I rebooted and everything worked fine. I downloaded OpenArena, and had it running smoothly at 1024x768 without having to disable any features.

    Continued in next post...
    Last edited by nemo; 07-14-2007, 09:22 AM.

  • #2
    ... Continued from previous post.

    Some other things to watch out for: I am using the amd64 version of Kubuntu, and discovered that I couldn't view flash/Java in FireFox. To fix this I had to install a 32bit version of FireFox and some 32bit libraries. Details can be found here (NB: I don't think that is the actual page I followed the instructions from, but it looks close enough). I managed to get mp3 support (done via Add/Remove Programs) and playing encrypted DVDs working (downloaded using apt-get via here). So far I've been unable to get GoogleEarth or Wine working. Incidentally, the USB to serial adapter worked fine first time (I tested it with an terminal emulator on an old PDA and typing "cat /dev/ttyUSB0" on the PC).

    I decided to transfer my files from my old computer by hooking up the IDE hard disk. This proved to be a little awkward, as the motherboard only comes with one IDE interface (so I temporarily unplugged the DVD), and I had previously used Fedora Core 6, which uses a special disk format (LVM rather than ext3). You can find out how to do this here, but it is relatively painless (though the first time I tried it some files went missing, don't know why, but it worked in the end).

    I've been using it for a couple of days now, and everything seems to work fine. The only real problem occurred when I tried to burn a DVD, and my system locked up (does it every time, or produces corrupt disks). This turned out to be a faulty DVD drive (I tried it on a Windows XP machine, and it won't write on that either). So I replaced it with my old Sony DVD+RW, and will be sending the LiteOn back for a replacement/refund. It's a shame, as I wanted to try out the LightScribe feature (burns labels onto special disks).

    All in all I think I've got a pretty good system, which seems to be working well with Linux, and I'm very happy with it. I had had some reservations about building my own machine, and quite expected it to never get past POST – but I've had less problems getting Kubuntu working on this machine that I had getting Red Hat working on my old one, many years ago. I'm also very pleased with Kubuntu, which seems to work much better than Fedora Core 6 did on my old machine (I could never get all the bundled media software working), and with a lot less effort. Finally, I never bothered updating the BIOS on the motherboard (it may or may not have the latest, I'm not sure how to check, but there have been several updates on Abit's website), but it seems to work fine, so I have left it alone.
    Last edited by nemo; 07-14-2007, 08:51 AM.


    • #3

      I am glad that the Abit AN-M2HD is working out well for you and that it sounds like everything is churning along nicely, well, except for the DVD drive.

      Michael Larabel


      • #4
        Thanks Michael. I thought I'd post that here because I might never have got it all set up if it hadn't been for people solving problems in forums like this one (the Ubuntu forums proved very helpful) . Hopefully this will help out someone out who stumbles across it via Google.


        • #5
          Hi again,

          There is also a review of the AN-M2HD here. The reviewer reports that the GPU overheats and causes the system to crash (when using what I suppose is some sort of benchmarking software?). I played OpenArena for several hours last night with no problems, and checked the temperature readings in the BIOS after a reboot. I'm not sure it monitors the GPU -- but the CPU temp was about 48C (which was the highest temp recorded). I opened the case and touched the GPUs heatsink. It was hot but cool enough to touch. It seemed fine to me.

          EDIT: Actually the picture of the motherboard in the review is not the same as mine. The heatsink that gets hot is next to the CMOS battery (the GPU?) -- on my board the heatsink looks different and has a large Abit logo printed on it in white. Maybe they have changed something?
          Last edited by nemo; 07-14-2007, 10:05 AM.


          • #6
            OpenArena can function as a benchmark to stress the IGP's thermal envelope.

            It may just have been an issue that XS Reviews had where perhaps they had a faulty heatsink or the thermal paste wasn't properly applied.

            When installing LM_Sensors you may be able to read the thermal sensors as well.
            Michael Larabel


            • #7
              Well I tried LM_sensors, and it only seems to give two readings (Core0 and Core1 Temp). It could well be I didn't set it up right (I just followed the default settings). I think I'll leave it at that for now, as it seems fine to me.

              Incidentally, I updated the BIOS to the latest -- not sure what I had to start with. I had already made a self booting CDROM using an MSDOS boot disk with the latest BIOS on it. (My machine has no floppy drive.) Worked well. Some people have used FreeDOS for this, but I wasn't brave enough to try it, and used a Windows XP machine to produce a vanilla boot floppy.


              • #8
                Hi Nemo,
                Do you know if the "Dual Monitors Support" work in Linux? and if it supports a dual video output?


                • #9
                  Originally posted by bola View Post
                  Hi Nemo,
                  Do you know if the "Dual Monitors Support" work in Linux? and if it supports a dual video output?
                  Sorry, I've no idea about that. I was kind of wondering myself whether the HDMI output worked (and whether I had to do anything to enable it), as I was thinking of upgrading my monitor.

                  Also, from what I gather, this motherboard only duplicates the same image from both the VGA and HDMI sockets (or at least the AN-M2 does this with the VGA and DVI, so I'd assume it'd be the same here) -- so if you wanted two different displays, then I am afraid you are out of luck.


                  • #10
                    A duplicate would be fine with me. I what to connect 1 LCD(HDMI) and 1 Beamer(VGA), both showing the same thing (video most importantly) so that I dont have to change the primary display all the time.