No announcement yet.

Red Hat Linux installer does not work

  • Filter
  • Time
  • Show
Clear All
new posts

  • Red Hat Linux installer does not work

    I've had serious problems trying to get Linux installed on an ASRock H61 motherboard with an Intel Sandy Bridge i3-2100 CPU. I've gotten some rather unfortunate bad advice from Red Hat but the motherboard I have is UEFI. Red Hat says they only support UEFI on 64 bit Red hat Linux but that is what I'm trying to install without any luck.

    When I boot from the installer DVD, I can select install or install with basic video driver and then the installer tries to boot. It gets to "waiting for hardware to initialize" and hangs. I've tried some boot options like acip=off and noapic but they do not help.

    has anyone had any problems or success installing linux on Sandy Bridge systems? Is the UEFI a problem?

  • #2
    Possibly your distro's version is too old for Sandy Bridge.

    Kernel 2.6.38 is needed for it to work at least a bit, 2.6.39 and Intel X driver 2.15 are necessary for good performance on the card.

    For RH the requirements may be different due to backported drivers.


    • #3
      Follow up

      I purchased the Intel i3 2100 based on reviews on Phoronix such as this one in March.

      "Ubuntu 10.10 x86_64 was used as the Linux distribution for testing but we upgraded to using the Linux 2.6.38 kernel. GCC 4.4.5 was the compiler in use with the EXT4 file-system. The Core i3 2100 Linux support situation remains the same as any other Sandy Bridge CPUs: it will work fine assuming you're running a relatively modern (Fedora 14, Ubuntu 10.10, openSUSE 11.4, etc) distribution. The big caveat though is if using the Sandy Bridge graphics where you need to be using the unreleased Ubuntu 11.04 or Fedora 15 for "out of the box" support or otherwise be building the Linux 2.6.37/2.6.38 kernel, Mesa 7.11-devel, and xf86-video-intel 2.14 from source or be using a third-party package repository for these key components."

      I can't get any of the fedoras 14, 15, or 15 x64 to work. Same with Red Hat Linux 6.1 32 or 64 bit. Same with Ubuntu. Could I have a bad CPU? Windows 7 installed without any glitches. Should I return the motherboard for another mATX board? Which one?


      • #4
        I build an i5-2400 system over the weekend and I can't even boot from the Ubuntu 11.04 live CD; the screen goes to crap when it tries to start the GUI and the system hangs. I installed 10.04 instead and it's working OK but presumably using some VESA driver; I don't care because it's a MythTV server, not a desktop system.

        I'm surprised there are so many problems because Intel are usually good at supporting their GPUs out of the box.

        Edit: Oh yeah, that's an EFI motherboard too (Asrock Z68). I didn't try booting Redhat.


        • #5
          Ubuntu 11.04

          Right, I had the same issues with Ubuntu.

          My original motherboard was a Gigabyte H67-based unit but I sent it back based on the (bad) recommendation of red hat support. My real problem originally was a Western Digital advanced format drive (I didn't know I had selected one) that sort of worked - hideously slow but then would not boot. Red Hat said it was the H67. Wrong. Then, as you say, the H61 model I got as a replacement was UEFI and did not work with Linux at all.

          All-and-all, my first experience building with Intel was a complete bust. And, because of Newegg's return policy for CPUs, I'm stuck with a Sandy Bridge i3-2100 I can't use.

          I guess the lesson I learned was avoid new CPUs with Linux. I had been waiting for the new Llano CPUs but decided they were too far away.


          • #6
            Well, I'm running with three WD 'advanced format' drives on a UEFI motherboard, so there doesn't seem to be a fundamental incompatibility there (and they were getting >100MB/s when building the RAID array so it appears to be creating aligned partitions). Though I have a cheap SSD as the boot drive.

            But the graphics are basically screwed and Redhat does tend to take longer to support new hardware than Ubuntu does. The only other things I know don't work with Ubuntu 10.04 are USB3 and the temperature sensors.


            • #7
              Red Hat

              I need to run Red Hat on this system so I'm going to go back to an AMD Phenom II CPU. There is no real need for speed so the economics win out.

              I chose the i3-2100 because it was lower power than the Phenom II X2 555 I was originally planning to choose. This machine will be up all the time but not heavily used and almost never from the console so poor graphics performance initially was not an issue.

              WD told me (and ASRock lists in one of their FAQs) exactly the problems I had with the WD AFDs. You probably avoided the issue because you are booting from SSD.

              Thanks for your insights though. I helps me feel a bit less inadequate. I've never had a Linux CD not boot and install on any machine I've tried it on (before this) so I was not well-prepared for a lot of issues.


              • #8
                Yeah, I think Intel have kind of screwed the launch of this generation of CPUs on Linux. Hopefully they'll do better next time, because I'm used to Intel-everything systems 'just working' in most cases.


                • #9
                  Running Intel when the distro is newer than the hardware, has always worked fine. Except for Sandy Bridge. But now the initial support for yet-to-be-released Ivy Bridge is already merged so that next generation of Intel hardware will presumably work just fine on the Linux distros that will be released later this year (Ubuntu 11.10, Linux Mint 12, Fedora 16, etc.).