Announcement

Collapse
No announcement yet.

Linux Finally Has A Fix For Crackling Audio Input On Recent AMD Systems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux Finally Has A Fix For Crackling Audio Input On Recent AMD Systems

    Phoronix: Linux Finally Has A Fix For Crackling Audio Input On Recent AMD Systems

    Queued now for Linux 5.3 and also marked for back-porting to existing kernel stable series is a fix to address distorted and crackling analog audio input that has affected AMD systems for at least the past two years with certain Realtek audio codecs...

    http://www.phoronix.com/scan.php?pag...Input-Audio-WA

  • #2
    For so long I thought my audio issues when streaming was something to do with incorrect bit depth and sample rate, and it's been the chipset and Realtek audio all along. So glad to see a workaround for this!

    Comment


    • #3
      oh this is good news! there have been many times I have had to reboot into windows for clean mic audio... soon to be no more!

      Comment


      • #4
        I just see playback problem for first 5 minutes of audio, but i need to run

        both
        akonadictl --verbose fsck
        or
        akonadictl --verbose vacuum

        and

        sudo nice --10 rpm -Va

        paralelly to play audio and problem last only for first 5 minutes, than all become OK.

        Comment


        • #5
          The patch also applies on 4.19... I'm tempted to give it a try.

          Edit: Yep, seems to work fine. I'm no longer sounding like Darth Vader in Discord.
          Last edited by soulsource; 08-13-2019, 03:13 AM.

          Comment


          • #6
            I have regression on AMD and hda_intel with older 1022 9840 . High pitched noice continue after boot, so it does not set it up correctly it seems with default power_save=1

            They break it last year somewhere between 4.9 where it was OK and 4.19 where it is not OK... didn't inspected it, as power_save=0 works as an workaround

            Recently i also have to use nospectre_v1 since regardless of AMD is not affected by swapgs and excludion patch is there, it actually does not seem to disable it here on AMD

            Beauty of Linux defaults, where nothing actually works correctly as default

            Summa summarum, i could recommend to users to just FUCK DEFAULTS, now when they cant fuck an actual developer by the CoC
            Last edited by dungeon; 08-13-2019, 04:16 AM.

            Comment


            • #7
              Yay, this is great news! Audio input on my X370-board hasn't been working on either Windows or GNU/Linux, and I had pretty much lost hope of it ever working. This makes me so happy

              Comment


              • #8
                I'll give it a shot, maybe finally I can use my mic on Linux.

                Comment


                • #9
                  This issue also affect, AMD APUs?
                  I was searching to buy a AMD laptop, now I don't know what to do..

                  Comment


                  • #10
                    Thanks for your time. Did many people complained-about/investigated it? I wanted to, but it wasn't a big priority for me and is still on my TODO list.

                    I don't usually capture audio on my AMD systems (desktop 1022:1457 / laptop 1002:15de), but when I do I had the same problem on both systems crackling and pinging sounds that got louder as captured audio got louder. I only "captured audio" for meetings, i don't have meetings very often and just used my USB-DAC for that. I have not noticed any problem with playback.

                    I ran various versions of Ubuntu and Fedora where the problem was present on 3 different microphones and 2 AMD systems. I did not experience any problems with those microphones/cables when using it with my USB-DAC on Linux. The onboard sound capture worked in Windows 10 (although don't know if Windows is using voodoo hax to remove noise, I've seen Windows audio do some odd things).

                    PS: Over a year ago I tried some pulse-audio modules just out of curiosity, but never got it to work they way i wanted.

                    pactl load-module module-echo-cancel
                    pactl load-module module-echo-cancel aec_args="analog_gain_control=0 digital_gain_control=0"

                    Comment

                    Working...
                    X