No announcement yet.

Asus M2N32 Ubuntu Dapper Drake Kernel Panic upon boot

  • Filter
  • Time
  • Show
Clear All
new posts

  • Asus M2N32 Ubuntu Dapper Drake Kernel Panic upon boot

    I am trying to set up a nice little dual-boot configuration on my computer between Windows XP and Ubuntu 6.06 LTS (Dapper Drake), but I keep running into headaches. The system configuration is as follows:

    Asus M2N32 SLI-Deluxe Wireless Edition
    Athlon X2 4600+
    2gb Corsair XMS2
    GeForce 7900GTX
    SoundBlaster Live 5.1 (I love the emu10k1 compatibility in Linux)

    Immediately upon bootup of the Ubuntu Dapper Drake LiveCD, I am faced with a kernel panic and the error message:

    MP-BIOS bug: 8254 timer not connected to IO APIC

    I looked for the error on Google, and it appears that a lot of older SMP motherboards had the same problem years ago. I can make the system boot by supplying the kernel arguments "noapic" and "nolapic," but the system only sees one of the two cores that way. Also, when running the closed-source NVidia drivers, the system has about a 50% chance of hard-freezing when you switch from X to a system console (using Ctrl-Alt-Fkey). I don't know if those freezes have anything to do with the APIC issue, but my intuition tells me it probably does.

    I flashed the bios to 0903 (latest version as of the time of this writing) in an attempt to fix it, but I get the exact same error as when I was running 0603.

    Does anyone have any suggestions on things I could try to fix it?

  • #2
    I have used the ASUS M2N32 SLI Deluxe motherboard fine with Fedora Core 6 -- though I hadn't tried it against the newer motherboards. Though I have successfully used the noapic and noacpi arguments previously on other motherboards with similar problems.

    Have you tried updating your kernel?

    I take it you see only one of the cores by cat /proc/cpuinfo If you are only seeing one core, an SMP kernel needs to be installed or compiled from source. I thought Edgy Eft had used an SMP kernel by default (are you using the 32-bit or 64-bit version?).

    Do you have Composite enabled or any other information as to your NVIDIA configuration?
    Michael Larabel


    • #3
      I'm using the latest stock 32-bit Ubuntu 6.06 kernel (2.6.15-28). I currently don't have my NVidia driver installed so the machine won't crash all the time, but when I had it installed I was just using a very basic setup with no frills.

      I'll give the 64-bit LiveCD a try, and look around changelogs and such to see if there's any record of a fix for problems like these since the release of 2.6.15. Thanks!


      • #4
        Looks like the 64-bit Edgy Eft LiveCD doesn't crash immediately upon boot, and it sees both cores in /proc/cpuinfo. So I guess I'll just install this instead. Thanks!


        • #5
          Yeah that's a common problem with older kernels (I have the same board and problem). 2.6.19 was supposed to add better support for AM2 boards, but I am not exactly sure what module needs to be compiled for that to happen.


          • #6
            I've had luck getting past similar problems by adding acpi=off as a kernel parameter on the grub menu. If that doesn't work, then try noapic and see what happens.


            • #7
              The problem with using "noapic" is it makes it impossible for the two cores to communicate, since the APIC sends interrupts between the two cores. So you only get one of your two cores in that mode.

              Thankfully, Edgy fixed my problems. Thanks again!