No announcement yet.

does usb work on amd south bridge ?

  • Filter
  • Time
  • Show
Clear All
new posts

  • does usb work on amd south bridge ?

    i have a new computer, gigabyte GA-MA78GPM-DS2H, usb sometimes quits working. just now i tried to unload the module and reload it, but it hangs when i try to rmmod ehci_hcd. does anyone else have an amd southbridge that works or does not work with usb ?

    this board is also randomly locking up. i am about to RMA the board and not sure if the amd south bridge just doesnt work, bad board, or kernel issues. if it seems that i just have a bad board ill get a new one of the same model. if this doesnt work for anyone, then perhaps amd was a bad choice ?

    btw, i am cross posting on gentoo to get a larger audience to quicky resolve my hardware issue.


  • #2
    Originally posted by mattmatteh View Post
    i have a new computer, gigabyte GA-MA78GPM-DS2H, usb sometimes quits working. just now i tried to unload the module and reload it, but it hangs when i try to rmmod ehci_hcd. does anyone else have an amd southbridge that works or does not work with usb ?
    I have a Gigabyte GA-MA78G-DS3H, after I first installed the board none of the attached USB devices worked. I powered down, cleared the cmos data, loaded optimized defaults and further tweaked the bios to my likings and now the board runs stable as a rock with everything working.

    The only issue I have with this board is that it doesn't want to boot from a USB stick.


    • #3
      there is a known bug in the sb700 southbridge. There are three ways to deal with this:
      bios update
      look for the patch on lkml
      use which has the patch.

      the patch:
      diff -ruN a/drivers/usb/host/ehci-pci.c b/drivers/usb/host/ehci-pci.c
      --- a/drivers/usb/host/ehci-pci.c 2008-09-25 17:31:21.000000000 +0800
      +++ b/drivers/usb/host/ehci-pci.c 2008-09-25 17:31:24.000000000 +0800
      @@ -70,6 +70,8 @@
      struct ehci_hcd *ehci = hcd_to_ehci(hcd);
      struct pci_dev *pdev = to_pci_dev(hcd->self.controller);
      + struct pci_dev *p_smbus;
      + u8 rev;
      u32 temp;
      int retval;

      @@ -170,6 +172,25 @@
      pci_write_config_byte(pdev, 0x4b, tmp | 0x20);
      + case PCI_VENDOR_ID_ATI:
      + /* SB700 old version has one bug in EHCI controller,
      + * cause usb device fail in hub.
      + */
      + if (pdev->device == 0x4396) {
      + p_smbus = pci_get_device(PCI_VENDOR_ID_ATI,
      + NULL);
      + if (!p_smbus)
      + break;
      + rev = p_smbus->revision;
      + if ((rev == 0x3a) || (rev == 0x3b)) {
      + u8 tmp;
      + pci_read_config_byte(pdev, 0x53, &tmp);
      + pci_write_config_byte(pdev, 0x53, tmp | (1<<3));
      + }
      + pci_dev_put(p_smbus);
      + }
      + break;



      • #4
        i have 780g, hd3200, will fglrx work with kernel ?

        using gentoo. and have xorg-server-



        • #5
          it does work with

          [ 41.522897] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
          [ 41.577311] [fglrx] Maximum main memory to use for locked dma buffers: 3787 MBytes.
          [ 41.577987] [fglrx] vendor: 1002 device: 9501 count: 1
          [ 41.579471] [fglrx] ioport: bar 4, base 0xc000, size: 0x100
          [ 41.579498] pci 0000:02:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
          [ 41.579506] pci 0000:02:00.0: setting latency timer to 64
          [ 41.580087] [fglrx] Kernel supports PAT but it has been disabled
          [ 41.580091] [fglrx] Using driver built-in PAT support instead
          [ 41.580912] [fglrx] Driver built-in PAT support is enabled successfully
          [ 41.581577] [fglrx] module loaded - fglrx 8.56.4 [Dec 1 2008] with 1 minors
          [ 45.531632] [fglrx] Gart USWC size:192 M.
          [ 45.531637] [fglrx] Gart cacheable size:60 M.
          [ 45.531642] [fglrx] Reserved FB block: Shared offset:0, size:1000000
          [ 45.531643] [fglrx] Reserved FB block: Unshared offset:ff76000, size:8a000
          [ 45.531645] [fglrx] Reserved FB block: Unshared offset:1fffc000, size:4000


          • #6
            thanks for the info. i did some more testing. i was starting to think that i had a bad ram stick. started to test the pair that i thought was bad. both pairs locked up the computer during bios boot. and i noticed the '1/4' as the first digit where it says how much ram is present. so i thought maybe that is the problem. then i went on to test more with that pair, it will boot sometimes. when it did finally boot, the led on the mouse went off while the kernel was loading, and it would sometimes flicker. i thought it was related to the ram, but then tested the ram that i thought was good and the exact same thing happened. still stumped at my new lemon.

            then i was googling about the amd sb700 bug as the kernel patch fixes. it seems its related to an external storage or hub. in my case i have a dell lcd 24 inch with smart card media on the side, i had the mouse connected to it. this was about 2 days ago after energyman posted that patch. i removed the lcd and just plugged in the mouse directly. thought that was the problem, now i loose the mouse during boot.

            also, why is dmesg filled with:
            [ 72.579649] DEV: registering device: ID = 'vcsa4'
            [ 72.579656] PM: Adding info for No Bus:vcsa4
            [ 72.580499] DEV: registering device: ID = 'vcs2'
            [ 72.580524] PM: Adding info for No Bus:vcs2
            [ 72.580539] DEV: registering device: ID = 'vcsa2'
            [ 72.580546] PM: Adding info for No Bus:vcsa2
            [ 72.580977] DEV: registering device: ID = 'vcs5'
            [ 72.581242] PM: Adding info for No Bus:vcs5
            [ 72.581359] DEV: registering device: ID = 'vcs6'
            [ 72.581424] PM: Adding info for No Bus:vcs6
            [ 72.581498] DEV: registering device: ID = 'vcsa6'
            [ 72.581560] PM: Adding info for No Bus:vcsa6
            [ 72.581658] DEV: registering device: ID = 'vcsa5'
            [ 72.581722] PM: Adding info for No Bus:vcsa5

            .... completely littered with that.
            i am still using kernel 2.6.24. i am going to test kernel >= soon. i wanted the testing constant, thats why i am now just trying a new kernel.

            i thought the kernel patch only fixed a problem with a hub or external storage, not a simple mouse.

            i am kinda thinking the board is just big fat lemon. kinda hard to narrow the problem down. the lock up does seem to be limited to 1 pair of ram though.

            i have been really patient for a month, not sure which is bad.

            could anyone offer any more test or thoughts ?
            /me pokes AMD ?!




            • #7
              since i was having problems with the usb, i recompiled the kernel a while ago and put usb as modules. some how the modules kinda quit loading.... errors. so i just wasted more time recompiling kernels, and ati drivers..... could only get kernel 2.6.24, ati-drivers-8.471.3 to compile.

              so now the usb is compiled in, kernel 2.6.24-gentoo-r8, but still the usb didnt work while the kernel was loadking. i had to get up, go to the back of the computer and unplug it, and plug it back in, then it worked :|

              today was supposed to be testing ram, instead i am wasting my time with this.

              usb 1.1 is over 10 years old, usb 2 is several years old depending on the feature, i dont understand why this is not working.

              perhaps bad ram is causing this....

              anyway... perhaps when i have more time to waste i can attempt to test the ram again.



              • #8
                or perhaps your board is just a POS and you need to replace it ASAP?


                • #9
                  ok.... i give up. i am going to return the POS gigabyte board. but should i get another one and see how that goes? i still have the amd cpu 4850e. not sure i want to get a replacement or try something different. seems that the board is a POS, and the northbridge is too buggy to be used. kinda having thoughts of going with an nvidia northbridge and using the amd cpu.

                  seems that there is more than one problem with this board. random lock ups, and usb doenst seem to work. not sure how these are related.



                  • #10
                    it is not AMDs fault when gigabyte screws up.
                    I am very happy with my 770 based Asrock board. It is very robust. No problems (after the kernel patch). The AMD devs were very fast to create the patch after the problem was reported (and there was a workaround - use ohci for usb 1.1 devices).