No announcement yet.


  • Filter
  • Time
  • Show
Clear All
new posts

  • glxgears

    I'm very aware that glxgears is not a graphical benchmark in any way you look at it, its just a took to verify that your 3d hardware accelleration is working properly.

    Previously I had installed slackware, and in glxgears i was getting 15,000+ fps in the default window size, and now i just installed slackware once again, and updated to -current. After doing that, i ran glxgears and got a whopping 728fps at the default window size. Is this because a newer version of glxgears is more demanding? Or is my graphics card not properly setup? in my xorg.conf i have the driver set to "nvidia" and its pci express, so I don't have to setup fastwrites or agpgart or any of that annoying stuff. If you've got an idea of whats up, lemme know.


  • #2
    Well, as you said... glxgears is really no indication of anything.

    For example, back at my redhat 9 box, I had only mesa GL and my glxgears gave me like 4k to 6k fps. After installing fglrx, glxgears hovered somewhere in the 700+ fps. But, unlike mesa, I could run quake 3 at a stable 60-70 fps.

    So, if anything... I don't think the drop of fps is as alarming as you think. I don't know why the frame rate drops though. Perhaps because glxgears is optimized to use Mesa GL, instead of Open GL.


    • #3
      You should still be getting approx. 15,000 FPS. If you upgraded the X11 packages, the nVidia driver files were most likely removed and your system probably defaults to MESA. Try re-installing the driver package, make sure your xorg.conf is setup correctly, etc.

      Also, try this:

      glxinfo | grep "OpenGL vendor string"
      That should output: OpenGL vendor string: NVIDIA Corporation. If not, it using another GL implementation (probably MESA) which is software-implemented and uses the CPU only.


      • #4
        Yea, you're right, i'm getting the Mesa project as output. What should I do to fix that? i'm pasting my following xorg.conf.

        I don't understand why this is happening, my last time I installed Slackware, I did everything the same way, and it worked fine.

        If it helps, i'm on the kernel with KDE 3.5.3


        EDIT: I downloaded and compiled the 2.6.17 kernel, then reinstalled the nvidia drivers and used nvidia-config, everything seems to be working fine now, so there's no need to spam the forum with my xorg.conf. thanks for your help
        Last edited by Scott; 06-21-2006, 12:45 PM.