Announcement

Collapse
No announcement yet.

modeline confusion.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • modeline confusion.

    Hey guys, I just bought my first widescreen LCD. It is a BenQ FP202W.



    You can see it in the link above. The problem that I'm having is that the native resolution is 1680x1050, which is way too small for me to read comfortably. Mind you that resolution works out of the box with no configuration., but I would like to lower the resolution and keep the proper aspect ratio. That would be round about 1280x800. The problem is that when I set that resolution the monitor just pops up a box that says "Non Preset Mode" I've tried every refresh rate that the monitor supports, and it gives the same message every time. I'm totally stumped. I have no idea what I'm doing wrong.

    I have a GeForce 7600 GT using the newest stable drivers. The xorg.conf was created by nvidia-settings, and I added the modelines for the resolution that I want. As I said I tried every refresh rate the monitor supports....

    Heres my xorg.conf in case you need to see it.
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (root@livecd)  Thu Jan 31 19:02:55 Local time zone must be set--see zic manual page 2008
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 640 0
        Screen      1  "Screen1" LeftOf "Screen0"
        Screen      2  "Screen2" RightOf "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
        RgbPath         "/usr/lib64/X11/rgb"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
        # generated from data in "/etc/conf.d/gpm"
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "IMPS/2"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
    #    VendorName     "Unknown"
        ModelName      "BenQ FP202W"
    #    HorizSync       30.0 - 84.0
    #    VertRefresh     56.0 - 76.0
        Option         "DPMS"
        Modeline "1280x800_50.00"  68.56  1280 1336 1472 1664  800 801 804 824  -HSync +Vsync
        Modeline "1280x800_51.00"  69.93  1280 1336 1472 1664  800 801 804 824  -HSync +Vsync
        Modeline "1280x800_51.00"  69.93  1280 1336 1472 1664  800 801 804 824  -HSync +Vsync
        Modeline "1280x800_53.00"  72.76  1280 1336 1472 1664  800 801 804 825  -HSync +Vsync
        Modeline "1280x800_54.00"  74.22  1280 1336 1472 1664  800 801 804 826  -HSync +Vsync
        Modeline "1280x800_55.00"  75.60  1280 1336 1472 1664  800 801 804 826  -HSync +Vsync
        Modeline "1280x800_56.00"  77.71  1280 1344 1480 1680  800 801 804 826  -HSync +Vsync
        Modeline "1280x800_57.00"  79.19  1280 1344 1480 1680  800 801 804 827  -HSync +Vsync
        Modeline "1280x800_58.00"  80.58  1280 1344 1480 1680  800 801 804 827  -HSync +Vsync
        Modeline "1280x800_59.00"  82.07  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync
        Modeline "1280x800_60.00"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync
        Modeline "1280x800_61.00"  84.96  1280 1344 1480 1680  800 801 804 829  -HSync +Vsync    
        Modeline "1280x800_62.00"  86.35  1280 1344 1480 1680  800 801 804 829  -HSync +Vsync
        Modeline "1280x800_63.00"  88.68  1280 1352 1488 1696  800 801 804 830  -HSync +Vsync   
        Modeline "1280x800_64.00"  90.09  1280 1352 1488 1696  800 801 804 830  -HSync +Vsync
        Modeline "1280x800_65.00"  91.61  1280 1352 1488 1696  800 801 804 831  -HSync +Vsync
        Modeline "1280x800_66.00"  93.02  1280 1352 1488 1696  800 801 804 831  -HSync +Vsync
        Modeline "1280x800_67.00"  94.54  1280 1352 1488 1696  800 801 804 832  -HSync +Vsync
        Modeline "1280x800_68.00"  95.95  1280 1352 1488 1696  800 801 804 832  -HSync +Vsync
        Modeline "1280x800_69.00"  97.48  1280 1352 1488 1696  800 801 804 833  -HSync +Vsync
        Modeline "1280x800_70.00"  98.89  1280 1352 1488 1696  800 801 804 833  -HSync +Vsync
    EndSection
    
    Section "Monitor"
        # HorizSync source: unknown, VertRefresh source: unknown
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "TV-0"
        HorizSync       0.0 - 0.0
        VertRefresh     0.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
        # HorizSync source: unknown, VertRefresh source: unknown
        Identifier     "Monitor2"
        VendorName     "Unknown"
        ModelName      "Chuntex"
        HorizSync       0.0 - 0.0
        VertRefresh     0.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 7600 GT"
        BusID          "PCI:2:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Videocard1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 7600 GT"
        BusID          "PCI:2:0:0"
        Screen          1
    EndSection
    
    Section "Device"
        Identifier     "Videocard2"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 6100"
        BusID          "PCI:0:5:0"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "CRT: 1280x800 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen1"
        Device         "Videocard1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "TV: 640x480 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen2"
        Device         "Videocard2"
        Monitor        "Monitor2"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "1024x768_85 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Anyhow I'd love to here what you guys think about this problem. And thanks in advance.

  • #2
    Have you tried just changing your resolution from nvidia-settings? That should be the easy way for both changing the display in real-time or saving to the xorg.conf for permanent use.
    Michael Larabel
    https://www.michaellarabel.com/

    Comment


    • #3
      Originally posted by Michael View Post
      Have you tried just changing your resolution from nvidia-settings? That should be the easy way for both changing the display in real-time or saving to the xorg.conf for permanent use.
      Well, the problem is that all of the resolutions that nvidia-settings make available are all 4x3, the only widescreen resolution that it has is 1680x1050....

      I'm not sure what that means really, but the monitor should work with 1280x800, but for some reason nvidia-settings isnt making it available and if I try to use it manually it just pops up that error message.

      Comment


      • #4
        Have you tried: xrandr -s 1280x800 ?
        Michael Larabel
        https://www.michaellarabel.com/

        Comment


        • #5
          xrandr just uses the modelines that I set in the xorg.conf, and those dont work. If I remove those modelines then xrandr just says that it isnt found in available modes.

          Comment


          • #6
            well, you can try to adjust the DPI setting and leave the native resolution or try:

            Option "ModeValidation" "NoDFPNativeResolutionCheck"
            Option "ExactModeTimingsDVI" "True"

            but these two lines can eat your dog

            Comment


            • #7
              Originally posted by .CME. View Post
              well, you can try to adjust the DPI setting and leave the native resolution or try:

              Option "ModeValidation" "NoDFPNativeResolutionCheck"
              Option "ExactModeTimingsDVI" "True"

              but these two lines can eat your dog
              Well, I do like my dog, and I wasnt able to find much documentation on those option lines, so I'm not gonna mess with them.

              Instead, I have been messing around with font sizes, though I'm a bit disappointed because I cant seem to maintain the same proportions as I'm used to. Font size is ok now, but icons are tiny, and certain web sites that were designed for 1024x768 that use gifs or jpegs are tiny.

              I guess there is nothing else for me to do except get used to it. Change is a hard thing, and apparently not always for the better.

              Comment


              • #8
                You can keep that resolution, DPI is for changing the relative size.

                First try using the monitor's native dpi by entering it's size in mm into xorg.conf. Here's mine:
                Section "Monitor"
                Identifier "Monitor0"
                VendorName "HP"
                ModelName "Omnibook lappy lcd"
                DisplaySize 285 213
                HorizSync 43.89-48.51
                VertRefresh 60
                EndSection
                This means my screen's native DPI is 91 both horizontally and vertically. Using it makes everything a little bigger than default.

                If your monitor's native DPI makes still too small text, try increasing it by removing the DisplaySize line and starting X with
                X -dpi number

                Comment

                Working...
                X