No announcement yet.

HD3870 weird behaviour!

  • Filter
  • Time
  • Show
Clear All
new posts

  • HD3870 weird behaviour!

    Got my new system based upon the AMD Phenom X4.

    Everything works OK but it seems like the graphiccard isn't working so good.

    First issue is seen when powering up the computer,
    the POST screen got some annoying "lines" all over the place.

    A pic on the POST screen:

    Second issue is (When using Windows, both XP and Vista) that the computer halts/crashes before the login page,
    and that's after installing Catalyst drivers.

    Windows is able to start before graphic drivers is installed, but then the resolution is limited and the same annoying "lines" as in the POST is present!

    Third issue is when starting X, got the
    (EE)fglrx(0): PreInitDAL failed

    I have disabled all frambuffer support in kernel but with no progress.
    Have the 7.12 driver installed, could it be because I
    use 64bit Gentoo?

    Fourth issue is mobo BIOS, have the latest F3 bios
    and it seems like I can't downgrade to F1 or F2.
    Everything seems OK when flashing the bios, but after reboot them the F3 is still there!
    The backup bios kicked in the last time I tried to flash to F1.

    The mystical "lines" was also present all through the Windows type of installations(Both XP & Vista) but
    not at all in Linux(Gentoo)!!
    And there's no graphic corruption in BIOS setup or at
    BIOS boot.

    Seems like I got a "buggy" graphiccard, maybe RMA!?

    I don't know if there is any setting I must activate/deactivate in BIOS to get the graphics up...

    Please help me troubleshoot this!

  • #2
    Looks like a bad graphics card to me. When I had similar issues I just had to return the card and the problem went away with the replacement.


    • #3
      One issue solved!

      Tried with one of my friends x1950 card and it worked flawless, it appeared that I got one of those "bugged" cards...

      But that's not the case, guess what!
      I removed the Zalman GPU Waterblock and cleaned the surrounding area around the chipset with acetone, the thermalpaste had squeezed out from the chip and onto the
      SMD (resistor/ diodes?)... and to my surprise the card worked perfectly after this tretment.

      Information on this issue should be available(sticky?) so other people don't need to do RMA on a fully functional card.

      The only issue left is the PREInitDAL..


      • #4
        Nice tip...perhaps people should check their cards to make sure no thermal goop has leaked out onto the PCB and to carefully clean any paste that did leak. Also a good tip is to make sure cards are seated properly and making sure the power connector is connected (some cards require additional power, thus a molex connector on the card)


        • #5

          With the newest(8.1) drivers, X fires up normally!

          Yet it seems that my Gentoo installation is a "little" unstable, going to search Gentoo forums.

          If there's someone who know something about the Phenom X4 and how to get it working in Linux enviroment then please help me.

          Everything works normally, but the whole system hangs while compiling packages. Not all packages, but things as Qt, gcc, glibc and big applications fails during compile. Sometimes the segmentation fault appear, but disappear with the "-j" (CPU optimization) flag set to "-j2" instead of "-j3" or "-j4". Have tried with the "TLB bug" disabled & enabled, but no difference!

          I have done some observation with the "htop" while compiling things, it seems like the Core(s) hangs (TLB bug?) when loaded 100% at a longer duration.
          The "%"(loadmeter) in htop shows only "nan%" when one or more of the Cores hangs, system is working even after this single or multiple Core lockup.
          Rebooting isn't possible while a Core is locked up,
          and a whole system frezze happens if I try to start anything...

          The most wierdo thing is that Wirus Vista 64bit have no problem at all, have tried with both Vanguard SOH and Unreal Tournament 3 running at the same time and there's no lockup!!

          Could be the whole Stage (Stage3) that have failed(Phenom maybe not supported in official Stage3!?), I'll try a Stage1 if I not find or get any info how to get my system functional.


          • #6
            What are your C(XX)FLAGS? What version of GCC are you running? What version of the Linux kernel are you running? Would you mind trying with a LiveCD to see if you can reproduce the problem in another environment?


            • #7
              Run a memtest86. If there is something wired going on I always check the memory first. Try the new kernel. Is there any suspicious kernel message?