No announcement yet.

AMD A8-3850 With Radeon HD 6550D

  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    chithanh - works fine, thanks!

    $ ls /sys/class/drm/card0/
    card0-DVI-D-1  card0-VGA-1  dev  device  power  subsystem  uevent
    Kernel parameters: "video=DVI-D-1:e video=VGA-1:d"

    dmesg | grep drm:
    [    1.650398] [drm] Connector 0:
    [    1.650399] [drm]   VGA
    [    1.650400] [drm]   HPD2
    [    1.650402] [drm]   DDC: 0x6440 0x6440 0x6444 0x6444 0x6448 0x6448 0x644c 0x644c
    [    1.650403] [drm]   Encoders:
    [    1.650404] [drm]     CRT1: INTERNAL_UNIPHY2
    [    1.650405] [drm]     CRT1: NUTMEG
    [    1.650406] [drm] Connector 1:
    [    1.650407] [drm]   DVI-D
    [    1.650408] [drm]   HPD1
    [    1.650409] [drm]   DDC: 0x6430 0x6430 0x6434 0x6434 0x6438 0x6438 0x643c 0x643c
    [    1.650410] [drm]   Encoders:
    [    1.650411] [drm]     DFP1: INTERNAL_UNIPHY2
    [    2.532824] [drm] Internal thermal controller without fan control
    [    2.532850] [drm] radeon: power management initialized
    [    2.548875] [drm] forcing VGA-1 connector OFF
    [    2.548877] [drm] forcing DVI-D-1 connector ON
    Now the monitor switches off for some seconds after loading the kernel, but comes back with the boot splash animation at full monitor res and - more importantly - shows the KDM greeter! So I removed the xrandr stuff from ~/.kde/share/config/krandrrc.

    Very happy


    • #22
      Nice to hear that it works now!
      If you have the time, please report a bug on so it can be fixed properly.


      • #23
        Gotta make a correction: I haven't removed the edgers stuff (seems that was another test installation), so I have the git stuff installed. What I tested were edgers/natty packages, I updated them to edgers/oneiric an hour ago, still everything's ok. I disabled edgers now, so I'll hopefully pull stable packages before release. Or maybe I'll re-enable xorg-edgers? Dunno, tough decisions to make all day

        But I did a test with Ubuntu Oneiric standard packages some days ago with my old TFT (1280x1024) with similar results.

        chithanh: Filing a bug is what I was thinking about as well. I already did some searches, but didn't seem to find something related to Llano and the radeon driver. D'oh!


        • #24
          So I did a downgrade to oneiric's current xorg-packages: they work, I don't recognize a difference in quality. But they are slower; benchmark results for warsow, 1920x1280 are:

          xorg oneiric: 18 fps
          xorg edgers: 23 fps

          Most worrysome to me currently is that googleearth ( and 5.1.3533) is too slow to work with. Version 6 offers to switch to DirectX mode (guess it's a winelib application) which results in a crash. The OpenGL mode is very slow, way below 10 fps for both versions of GE. I do remember that 5.1 worked with my old installation, Kubuntu 10.04 stock with radeon driver, Phenom 4x2GHz, Radeon HD 3300 IGP. It also was too slow (I think it was even a little faster than my current setup), but that was a 40 SP IGP vs the 400 SP one offered by Llano, plus doubled ram bandwidth.