Announcement

Collapse
No announcement yet.

NVIDIA GeForce GT 520

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    There is something wrong with your picture

    Originally posted by kaczu View Post
    I would stay away from the 520 and go with the 430 instead. At least in Linux, the performance of the 430 was far better for video playback. I was building another extender and saw a 520 in Microcenter and picked it up since it was a good deal. But when I installed it, it could barely play back HD content, while the 430 had no trouble with it at all. Maybe it's different in Windows, however for Linux use only the most boring HD content could be run without issue.
    I can play HD with a 32MB MX400 which is the lowest of the $9.95 low, but you're saying a GT 520 can't? I'd sooner believe you don't know what you're doing setting the hardware up. I'm sorry! Granted rebuilding mplayer locally helped a lot, but still. What I mean to say is it takes a bit more than just dropping these things into machines in order to get out of them what they can do.

    Comment


    • #62
      I don't think you example card has got vdpau But he did not use a current nvidia driver so the card did not work for him. That's the simple reason why his older card worked and the new one did not.

      Comment


      • #63
        When you're right you're right

        Originally posted by Kano View Post
        I don't think you example card has got vdpau But he did not use a current nvidia driver so the card did not work for him. That's the simple reason why his older card worked and the new one did not.
        No VDPAU here but after I built mplayer with some target arch optimizations it ran a lot better. There are other places I could tune for better performance if I wasn't so busy in silly forums all the time.

        Using the correct driver would be part of setting the hardware up correctly to me.

        lspci
        01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev a1)

        [email protected]:~$ ls -l "ElephantsDream[DivX7].mkv"
        -rw-r--r-- 1 pfred1 pfred1 570930953 2011-08-10 09:34 ElephantsDream[DivX7].mkv

        [email protected]:~$ mplayer -benchmark -vo null -nosound "ElephantsDream[DivX7].mkv"
        MPlayer SVN-r34780-snapshot-4.3.2 (C) 2000-2012 MPlayer Team

        Playing ElephantsDream[DivX7].mkv.
        libavformat version 54.2.100 (internal)
        libavformat file format detected.
        [lavf] stream 0: video (h264), -vid 0, Main title
        [lavf] stream 1: audio (aac), -aid 0, -alang eng, English 5.1 Surround
        [lavf] stream 2: audio (aac), -aid 1, -alang eng, English Stereo
        [lavf] stream 3: subtitle (text), -sid 0, -slang eng, English
        [lavf] stream 4: subtitle (text), -sid 1, -slang fre, French
        [lavf] stream 5: subtitle (text), -sid 2, -slang ger, German
        [lavf] stream 6: subtitle (text), -sid 3, -slang ita, Italian
        [lavf] stream 7: subtitle (text), -sid 4, -slang pol, Polish
        [lavf] stream 8: subtitle (text), -sid 5, -slang rus, Russian
        [lavf] stream 9: subtitle (text), -sid 6, -slang spa, Spanish
        VIDEO: [H264] 1920x1080 0bpp 24.000 fps 0.0 kbps ( 0.0 kbyte/s)
        Clip info:
        TITLE: Elephants Dream
        TITLE/URL: http://www.elephantsdream.org
        ARTIST: Orange Open Movie Team
        PRODUCER: Ton Roosendaal
        COPYRIGHT: Copyright 2006, Blender Foundation / Netherlands Media Art Institute / www.elephantsdream.org
        TERMS_OF_USE: Creative Commons Attribution 2.5 Generic License
        TERMS_OF_USE/URL: http://creativecommons.org/licenses/by/2.5/
        COMMENT: Encoded in DivX 7
        Load subtitles in ./
        ================================================== ========================
        Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
        libavcodec version 54.6.100 (internal)
        Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
        ================================================== ========================
        Audio: no sound
        Starting playback...
        Unsupported PixelFormat 61
        Unsupported PixelFormat 53
        Unsupported PixelFormat 81
        Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
        VO: [null] 1920x1080 => 1920x1080 Planar YV12
        V: 653.7 0/ 0 145% 0% 0.0% 0 0


        BENCHMARKs: VC: 947.839s VO: 0.079s A: 0.000s Sys: 20.668s = 968.586s
        BENCHMARK%: VC: 97.8580% VO: 0.0082% A: 0.0000% Sys: 2.1339% = 100.0000%

        Exiting... (End of file)
        [email protected]:~$

        The system this card is in is not doing it any favors either:

        [email protected]:~$ cat /proc/cpuinfo
        processor : 0
        vendor_id : GenuineIntel
        cpu family : 15
        model : 1
        model name : Intel(R) Pentium(R) 4 CPU 2.00GHz
        stepping : 2
        cpu MHz : 1995.177
        cache size : 256 KB
        fdiv_bug : no
        hlt_bug : no
        f00f_bug : no
        coma_bug : no
        fpu : yes
        fpu_exception : yes
        cpuid level : 2
        wp : yes
        flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm up pebs bts
        bogomips : 3995.57
        clflush size : 64
        power management:


        Linux, keeping old rust alive waaaaaay past its time ....

        Comment


        • #64
          Originally posted by Paul Frederick View Post
          No VDPAU here but after I built mplayer with some target arch optimizations it ran a lot better. There are other places I could tune for better performance if I wasn't so busy in silly forums all the time.

          Using the correct driver would be part of setting the hardware up correctly to me.

          It actually WASN'T a driver problem. The driver I used did in fact have support for the card. Hell if it wasn't I would have been stuck at VESA modes and I doubt the HDMI audio would have been there. BTW the card was used AGAIN this time with Ubuntu 11.10. Still the same problem.

          I actually ended up finding what was causing this, largely because even after using the card with the latest version of Ubuntu I still had problems. Remember the benchmarks not too long ago regarding compiz? Well compiz was killing the performance (again the 430 doesn't have this problem) so even though I thought compiz was off, it wasn't. I had to completely remove it actually I uninstalled the ubuntu-desktop package entirely and went with Xfce. Bingo bango there was enough performance for decent video playback. Not unbelievable, but much better than it was. It was in fact usable. It's safe to say that it could be used for HD playback. However, it's just enough ...no more. There are still some very very rare cases where there's a dropped frame but it's largely not noticeable.

          I would still keep my recommendation that since the price of the 520 is pretty damn close to a 430 I would take the 430 over it any day of the week. The 430 is an older card, but it is in fact more powerful.

          Comment


          • #65
            If you dont want do decode 1080p50/60 (possible with some hd cams, but usually 1080i is default there, ) then a simple geforce 210 would be enough as well, but the price difference is getting smaller. The gt 520 is no gaming card, those are gts 550/gtx 560 and up. I dont get the point with compiz, i only use kde but never saw those performance issues even with a simple geforce 405 (rebranded 210). Maybe u does somethig wrong The mplayer example must be a joke as the test file is encoded at a very low bitrate. This can not be compared to max 40 mbit full hd which are within bd spec (8 mbit are reserved for audio). The best player currently is xbmc for those formats. vlc could use vdpau via a wrapper but this works very inefficiently. mplayer is ok with vc vdpau overrides, but with simple iso image support xbmc is my favorite.

            Comment


            • #66
              Originally posted by Kano View Post
              The mplayer example must be a joke as the test file is encoded at a very low bitrate. This can not be compared to max 40 mbit full hd which are within bd spec (8 mbit are reserved for audio). The best player currently is xbmc for those formats. vlc could use vdpau via a wrapper but this works very inefficiently. mplayer is ok with vc vdpau overrides, but with simple iso image support xbmc is my favorite.
              Considering a Geforce 2 can't accelerate H264/MPEG4 it would have been best if nothing was said at all. Maybe it was a joke though. Either way, there it is. Yes XBMC is my favorite as well.

              Comment


              • #67
                A Joke?

                Originally posted by Kano View Post
                If you dont want do decode 1080p50/60 (possible with some hd cams, but usually 1080i is default there, ) then a simple geforce 210 would be enough as well, but the price difference is getting smaller. The gt 520 is no gaming card, those are gts 550/gtx 560 and up. I dont get the point with compiz, i only use kde but never saw those performance issues even with a simple geforce 405 (rebranded 210). Maybe u does somethig wrong The mplayer example must be a joke as the test file is encoded at a very low bitrate. This can not be compared to max 40 mbit full hd which are within bd spec (8 mbit are reserved for audio). The best player currently is xbmc for those formats. vlc could use vdpau via a wrapper but this works very inefficiently. mplayer is ok with vc vdpau overrides, but with simple iso image support xbmc is my favorite.
                Before you go calling it a joke you could try to download the file and play it yourself. I gave enough information so you can even get the correct one. Just in case I didn't:

                $ md5sum "ElephantsDream[DivX7].mkv"
                f11eb0df02f2af8ea06db2cccfae1d28 ElephantsDream[DivX7].mkv

                Comment


                • #68
                  Care to let me in on the joke?

                  Originally posted by kaczu View Post
                  Considering a Geforce 2 can't accelerate H264/MPEG4 it would have been best if nothing was said at all. Maybe it was a joke though. Either way, there it is. Yes XBMC is my favorite as well.
                  I am failing to see the humor in it.

                  Comment


                  • #69
                    Your assumptions are baseless

                    Originally posted by kaczu View Post
                    It actually WASN'T a driver problem. The driver I used did in fact have support for the card. Hell if it wasn't I would have been stuck at VESA modes and I doubt the HDMI audio would have been there. BTW the card was used AGAIN this time with Ubuntu 11.10. Still the same problem.

                    I actually ended up finding what was causing this, largely because even after using the card with the latest version of Ubuntu I still had problems. Remember the benchmarks not too long ago regarding compiz? Well compiz was killing the performance (again the 430 doesn't have this problem) so even though I thought compiz was off, it wasn't. I had to completely remove it actually I uninstalled the ubuntu-desktop package entirely and went with Xfce. Bingo bango there was enough performance for decent video playback. Not unbelievable, but much better than it was. It was in fact usable. It's safe to say that it could be used for HD playback. However, it's just enough ...no more. There are still some very very rare cases where there's a dropped frame but it's largely not noticeable.

                    I would still keep my recommendation that since the price of the 520 is pretty damn close to a 430 I would take the 430 over it any day of the week. The 430 is an older card, but it is in fact more powerful.
                    There are at least 3 different drivers that work with Nvidia cards in Linux. So far your logic that just because you were getting sound with your hdmi hasn't told me anything about which driver you are using. That it outside my experience as I never use sound over hdmi.

                    [email protected]:~$ glxinfo


                    server glx vendor string: NVIDIA Corporation


                    That is what the Nvidia binary driver looks like. The 520 is in all likelihood a POS and I have heard plenty of bad things about Compiz too. Still, I think you've a better chance with it than what I am using.

                    Comment


                    • #70
                      In comparing the 520 with the 430 card, does it matter which version of the 430 it is? It looks like there's 3 different versions of the 430 or are the claims that the 430 is better applicable for all?

                      Which would you choose for a HTPC? All the 430 cards are 60W and the 520 is 30W, though. The 430 has either 64-bit or 128-bit memory bus but then most of them seem to be 1GB varieties and shop places list them as 128-bit but I thought they were 64.

                      Comment

                      Working...
                      X