No announcement yet.

Suspend/Hibernate not working with ATI HD4650/fglrx

  • Filter
  • Time
  • Show
Clear All
new posts

  • Suspend/Hibernate not working with ATI HD4650/fglrx

    Anybody had luck with suspend working properly with ATI Mobility Radeon HD 4650 in Ubuntu 9.10 (64-bit) ?

    I installed ATI Catalyst 10.1 from ATI website. But, as of now, machine suspends but cannot wake up..

    I end up with blank screen. Mouse is responsive. I can change to virtual terminal and I see the following error printing in an endless loop:

    EXT4-fs error (device sda5): ext4_find_entry: reading directory #81922 offset 0
    (/dev/sda5 is root partition, /dev/sda6 is home partition)

    I posted this problem at Ubuntu forums (link)

    I'm willing to troubleshoot, but I don't know where to start and I don't know if this is a fixable problem..

  • #2

    I have a hd4650 with fglx. I tried suspend with 10.1 last month and it worked like a charm.
    I had lots of problems with older versions (last try was with ~ 9.6 ).
    I upgraded fglrx to 10.2, and since I had only once the pc locked while it tried to suspend.


    • #3
      Hi Jery,

      what distribution are you using?


      • #4
        the same as you Ubuntu 9.10 64bits


        • #5
          That's odd.. suspend/resume is working out of box? did you do any modifications? By the way, what is your laptop brand/model? Mine is HP Pavilion DV7 2180us, Intel Core 2 Quad Q9000(2.00GHz) 17.3" 6GB Memory 500GB HDD ATI Mobility Radeon HD 4650

          In this case, is it possible that another hardware in my laptop is interfering with suspend/resume?

          Ok, so I know that suspend/resume can work in my computer, but i don't know where to start, what to tweak..


          • #6
            sorry, my mistake ... I don't hav a laptop, but a desktop machine
            so the two hd4650 are not the same at all !