Announcement

Collapse
No announcement yet.

Riva tnt2 m64

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Riva tnt2 m64

    Hello, I am having a few issues with a graphics accelerator. I have ordered a few others to try the R128, G400 and GeForce2 MX. But as for the TNT2 I'm having some issues with rendering speed. I am installing Loki games SOF, Myth II, Heavy Gear II, Heretic II from retail boxes. I also installed Eric's Ultimate solitaire with zero issues haha. But it doesn't need all the fancy 3D acceleration.

    I am running a network disabled install of Mandrake 7.2 installed from Linux-Mandrake 7.2 Complete retail box set.

    The hardware that I am using other than the graphics accelerator are as follows, none of the hardware has any issue with Mandrake 7.2 install other than graphics accelerator (TNT2 M64).


    Original full retail system Dell Dimension 8100 limited edition

    P4 1.4Ghz
    RDRAM 512MB (upgraded from 128MB)
    M991 Display (CRT)
    SB64 Sound Card
    I have removed the 56K modem from the system as it is not being used.
    I also have two DVD burner PATA drives installed in the system.
    2X 120GB 5400rpm PATA drives. (HDB = home HDA =/root, swap)


    I am running XFree86 3.3.6 at 1024x768 16 @75hz

    I have followed this guide for installing XFree86 4.0.1 and graphics drivers

    http://www.thehaus.net/AltOS/Linux/h...ia-mdk72.shtml

    Drivers were acquired here,

    https://www.driverguide.com/driver/d...riverid=702113

    This solution was no good in the resulting gaming performance.


    Following a fresh install, I also followed this guide and used the drivers provided by Loki.

    http://www.lokigames.com/support/gldrivers/download/

    http://www.lokigames.com/support/gld...riva-x-glx.faq

    This solution was no good as well. The game play is unplayable at best, though it looks very nice at .5 fps.


    Is there anyone who would be able to provide any other guides who may have used the Nvidia RIVA TNT2 M64 on an install of Mandrake 7.2 in 2000 that could assist? If not, that is ok. I would like to get this card working well before I move on to trying a new card. But my end goal is to do some Loki gaming on a proper and time appropriate hardware setup. I want that optimal gaming configuration for a Loki port given all the hard work and effort that Loki put into their work.

    Thanks,
    Matt


  • #2
    I somehow failed to notice an agpgart error in regard to my agp port. Apparently an issue on the motherboard later resolved with newer kernels. I was unable to get any sort of playable fps on the GeForce 2 MX. Anywho, I'm going to see what I can do on the agpgart issue and also test some other cards when they arrive. If I can resolve the agpgart issue I'll try that TNT2 again, although it's a meh graphics card.

    Comment


    • #3
      I guess I should post an update here. I've moved on from the TNT2 card and am determined to get a card that will work with with XFree86 3.x.x Will post when successful though. I've had no issues with Nvidia cards on XFree86 4.2.x and newer using nvidia provided .run builds but I'm determined to get the card going with Mandrake 7.2. I will be gaming like it's 2001 eventually. But I must say the GeForce 2 MX is an absolutely blazing fast card for Loki games. It runs like a champ with Mandrake 10 using the 5336 driver. Just make sure you install kernel-sources, the installer will remind you but it goes faster if you install it first. I believe it's on install disk 1 under Mandrake/RPMS. Just do an ls for *kernel-sources* and then rpm -i packagename.rpm. Also, I did notice that the Nvidia drivers are included on disk 3, I believe, for Mandrake 7.2 so that should make installing easier. If anyone should stumble upon this post in the future attempting this task as well. Anyway, I now am waiting on a second Matrox card to arrive in the mail for testing on Mandrake 7.2 and that reminds me, Matrox do still provide their older Linux drivers on their website for XFree86 3.x.x versions so you can grab them from here. https://www.matrox.com/en/video/apps...evious/display

      And the 2004 nvidia drivers are here,

      https://download.nvidia.com/XFree86/Linux-x86/1.0-5336/
      Last edited by LibreQuest; 06 January 2021, 05:01 AM.

      Comment


      • #4
        Cool project.

        I had TNT2 in the past, like in 1999. And had it working well in Linux, but only 2d acceleration, and xv for smoother video playback. Didn't try any 3D at the time, at least not on Linux, it was nice card for some Windows games, like Quake 3, Counter Strike, Unreal Tournament, etc. I didn't even knew Nvidia had a drivers for Riva.

        Shame we don't have access to the source of these drivers, that would help quite a bit.

        The best option is to find some old supported distro. RedHat 5.2 should work fine.

        Comment


        • #5
          I've almost installed Red Hat knowing that Matrox has provided their support specifically for Red Hat. But, I'm not giving up on Mandrake just yet. It's Red Hat based, or was, so I am not giving up just yet on it. I know there was a version of 7.2 that supported many of the cards that I am trying out of the box. But it's nearly impossible to get ahold of. I've not been able to as of yet. But I have had some success on the G450. I'm not really sure what the issue is on most of the cards. I think it may be that I've just settled on the worst possible release of Mandrake for gaming. I used 7.2 in 2001 when it was available in Wal-Mart. But I never considered gaming on it until I tried Corel and they shipped with Loki demos. But I played the heck out of those demos, they worked very well on Corel.

          Also, René Rebe has recently been working on reverse engineering some Matrox drivers. I'm not sure what success he has had but he is a true master of getting things to work properly in Linux.
          Last edited by LibreQuest; 08 January 2021, 12:38 PM.

          Comment


          • #6
            Mandrake 7.2 with Matrox G400 16MB AGP is the winner!

            It has 3D acceleration in XFree86 3.3.6 out of the box. However, I did have some issues on setup. And the details are as follows.

            On last part of install it will auto detect hardware and launch X with a rainbow background and a dialog asking "is this correct". It's best to answer "no" so that you can select the proper card. I am using an OEM G4+ rather than a G400 and I am guessing this is why it's not detected properly? But, it's always best to check as the auto detect doesn't always work.

            I did have to edit my XF86config-4 and comment out the font path before X would start, not sure why. Anyway it's soon to be replaced by XF86Config in the following steps.

            For whatever reason Mandrake installs XFree86 4.0.1 with 2D only support by default. Going into DrakConf (K menu - Configuration - Other) and selecting "Graphics Configuration" it will prompt you to use 3.3.6 XFree86 for 3D acceleration. After following a few more prompts it will save your new selection. Just log out of X and log back into a new session. It's working nicely. About to test more games than just Tux Racer. But Tux was really racing!

            Finally I can actually game on Mandrake 7.2! It's like it's 2001 again over here and it's fantastic.

            I remember back when I purchased Corel Linux at Staples and I played those Loki demos over and over and over. Now I can actually play the rest of the games on a proper setup!

            And I gave up on trying to get any Nvidia cards going on this box, but they all worked without issue on newer kernels with this hardware (Dell Diminsion 8100 LE).

            All cards tested,
            Nvidia GeForce 2 MX, ATI Rage 128 Ultra, Matrox G450/G45+, Matrox G400, Nvidia Riva TNT2 M64. I also have a GeForce 2 MX 400 on the way but that will have to go to another machine. I've also got another machine ready to go for lan gaming, not internet connected. But it's a Dell Dimension 1100 with the Matrox G450 running Mandriva 2007.1 Free. Works like a boss as well.

            Comment


            • #7
              Mandrake 7.2 Matrox G400 default drivers XF86 V3.3.6



              Wow wow wow, Games installed from box Heavy Gear II weather effects and textures had no issues all opengl effects are fantastic, Eric Ultimate Solitaire plays like a dream. haha And Myth 2 is stunning with all the opengl effects and the colors are amaaaazing. Going to try some other titles from archive.org and abandonware that I wasn't able to find for purchase. This is my last post on the topic unless anyone has a question about the setup. Thanks!

              Update: I need to make a correction on my post. Though Myth2 does look absolutely fantastic it is being rendered without 3D acceleration. The only cards that support 3D acceleration are the 3DFX Banshee, Voodoo 1k,2k and 3k.

              Update Note: The agpgart error has been fixed, and game performance is much better. vi /etc/modprobe.conf add line options agpgart apg_try_unsupported=1 save :w and exit :q
              Last edited by LibreQuest; 22 January 2021, 09:03 PM.

              Comment

              Working...
              X