No announcement yet.

Running Linux On The Intel Compute Stick

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by AndyChow View Post
    Michael, please write the article on how you installed Linux on the stick. I can't figure it out, I have a similar device (same specs, different brand). UEFI external dvd-drive is seen, but can't boot.
    Well, I have a Beelink Pocket P2 and I also had trouble. From what I've seen on the net, Windows 8.1 w/Bing devices (as in some tablets) use only 32-bit UEFI for booting. Windowses don't come with that. I've installed 64-bit debian 8.0 on my device this weekend, but I've had to go through some hoops.
    32-bit debian install .isos (and I suppose ubuntu) have 32-bit EFI loader (check for EFI/BOOT/BOOTIA32.EFI on the disc). That should be bootable, but it's a 32-bit OS.
    64-bit linuxes and Windows have EFI/BOOT/BOOTx64.EFI, which my stick refuses to load. Also the old 1st sector booting is not supported.

    My solution was to create a new ISO based on the 64-bit .iso with BOOT and EFI folders from the 32-bit ISO (well, except for boot/grub.cfg, which you need the 64-bit version). 32-bit EFI can boot 64-bit kernels (I suppose that could be true with windows, but I have not tried yet...would love 64-bit win on it). I've still had trouble with the image, until I found the mkisofs parameters in the .disk folder and used it's content to create the .iso . Of course, I removed jigdo and hybrid MBR parameters.
    I've managed to install 64-bit debian that way, but I've had trouble booting the installed setup. It seemed to hang after initrd loading. I managed to see a pattern: when booting by choice (hint: override boot device), it would boot OK, but booting by default left me hanging (windows through GRUB has no problems). There was an option of "Quiet" booting (don't remember exactly) which I disabled and now it seems to boot ok.

    PS: from what I've seen on the net, MacOS seems to also use 32-bit UEFI exclusively. So maybe the MacOS ubuntu ISOs may already have everything (just a thought, did not check).

    Update: I checked some (x/l)ubuntu .iso file listings and none seem to have bootia32.efi.
    Last edited by mathew7; 03 June 2015, 03:26 PM. Reason: Added ubuntu missing 32-bit efi


    • #12
      I am very interested in your tests of running linux on the windows version of the Intel Compute Stick published by Phoronix. I tried replying to the thread attached to the article but even though I joined Phoronix it still does not seem to allow me to post, so I am writing to you directly.

      I have an windows compute stick and tried installing linux on it. Rather than Ubuntu I wanted to install CentOS, but I have been unable to get the BIOS to let me boot from a DVD drive. I have never installed Ubuntu so perhaps it offers other methods, but installing CentOS/RHEL requires booting linux from some bootable device. I attached both a dvd drive using USB and a USB stick but the BIOS still offers me only the internal drive. If I get to the BIOS menu and try to select boot drive order it still offers me only the one selection. Even installing an SD card as drive D: still does not show booting from that as an option.

      How did you get around this?

      update: it appears that my problem was not installing the OS in the USB stick using ISO format. I had to change the OS in the BIOS to Ubuntu (this apparently changes to a 64-bit boot loader) and then the USB stick was recognized and I was able to boot CentOS but it did not recognize either a USB keyboard or a wireless keyboard that uses a USB dongle. So I tried Ubuntu 14.10 and this appears to be working.
      Last edited by TerryAnderson; 21 July 2015, 05:07 PM.