No announcement yet.

Promise SATA300 TX4 SATA 2.0

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Hardware fault or heat problems?

    Hi. Just found this review now, and realized I bought the card the same month/year that this review was being done. Funny coincidence..

    I've been experienced some difficulties with this card in my server. That is, after I upgraded the server about a month ago in to a bigger chassis with a "new" MB, and upgraded OS (old one was Ubuntu Server 7.04 I guess).. I think I narrowed it down to either hardware-conflict or heat problem..

    First i tried setting up raid5 with mdadm in Xubuntu 8.10 with two WD RE2 320 GB and one Seagate 7200.10 320 GB. (also have a 160 GB WD RE2 sata and an 80 GB seagate PATA) After some trouble with an Intel gigabit NIC that wouldn't work because of a bug in the e1000-driver (speed went down to a crawl when transferring files from other PC with GB-nic's), I decided I'd try a Debian distro, but same problem with nic and now the RAID was having hickups in that the drives would fail, I thought that it was one of the drives and tried diagnose programs from the vendors but nothing wrong with the disks. I got lots of errors in fsck (inode-err mainly) - I also tried to shuffle the disks between the Promise TX4 and the onboard SATA.
    I then thought I'd give Ubuntu Server 9.04 Beta a go to see if they corrected the e1000 bug (Intel GB nic) but same problem, so I use another nic. And there where still errors and dropouts from the RAID-set. So I decided to drop the RAID project and use the three drives separately. After some trial and errors of deleting a software RAID, I managed to set up the drives ready for samba, I started a big file transfer from my laptop/WD MyBook over night and the next morning I realized that the transfer had stopped after about an hour. Checked the server and got a input/output error when doing 'ls /mnt/sda1' tried fsck and got an error that explained that the superblock was corrupt - after a reboot the fsck automatically fixed the journal and so I did a fsck with no other errors. I tried a new big file transfer this night, and after an hour or so - same problem.

    I think it's either a heat problem (since the drive fails after a while under a big file-transfer) or maybe a conflict between the Promise TX4 and the internal SATA-controller. I think my next move is moving all the SATA disks over on the Promise-controller and disable the internal sata-controller, next step after that is gluing a heatsink on to the chip(s) on the controller, and maybe a slot-cooler beside it..

    PS: My former server was a desktop-chassis, so the Promise-card was standing upright. No it's a tower-chassis and the card is laying on "its head"

    Any comments / inputs?


    Update: I moved all the sata disks over to the promise-card, and disabled the onboard-controller. Result: After about 20 minutes of file transfer, it stoped. Now I got the same error as before: Input/output error.
    I'll see if I have a small fan I can mount temporarily adjacent to the card to see if that helps..
    Last edited by JrRRr; 04-13-2009, 01:56 AM.