No announcement yet.

OCZ Vertex 2 SSD, So fast it can time-travel?

  • Filter
  • Time
  • Show
Clear All
new posts

  • OCZ Vertex 2 SSD, So fast it can time-travel?

    Dear Phoronix,
    This issue is so strange I have absolutely no idea what's causing it and how it's happening.
    I recently bought a vertex 2 SSD. I installed ubuntu 10.04 on it, after installation I configured a wifi network and installed chrome, the disk is lightning fast!
    But the downside is that these are the only changes to the disk that I have been able to make that lasted. Every time I install something or make a file, its gone after I shut the laptop down and power it on again. It's like the disk traveled back in time.
    To make this even weirder, if I just reboot it doesn't happen. It only happens if I turn the laptop completely off (but keep the battery in) and then turn in on again.

    I even completely reinstalled ubuntu, rebooted into the freshly installed ubuntu just fine, but when I turned my laptop off and started it again I was welcomed by my old ubuntu installation with chrome and the configured wifi network. Baffled I was

    My laptop is a dell 1555. After installing the ssd I once near completely took it apart to install a hard drive in the optical drive slot, halway I gave up though. I can't imagine this being the cause of my problems(and I strongly hope it's not) but you never know...

  • #2
    Man, that's weird.


    • #3
      Obviously, something isn't syncing right.

      One thing that confuses me about the problem... you say that REBOOTING keeps data, but powering off loses it. How about rebooting and THEN powering off?

      How about syncing the filesystem and then powering off?

      How are you powering off? Clean shutdown? Or by force (i.e. holding power button for 5 seconds, pulling wire and battery, etc.)? Reason I ask is that a clean shutdown SHOULD sync the filesystem.

      Could be an issue with laptop-mode, might not be syncing the buffer to disk as required, maybe a bad interaction with the SSD....

      Have you tried a different distro? Or just Ubuntu? Could be a problem with that distro.


      • #4
        By powering off I mean a clean shutdown. The weird thing is that it always goes back to the same state(where I have only chrome installed and one wireless network configured).

        Rebooting and then powering off doesn't change anything. I didn't try another distro. I did try installing ubuntu 10.10 alpha 3. After a reboot it was still there, but after a clean power off my system was back at ubuntu 10.04.

        I can't imagine an entire OS would be stored in some kind of cache and removed after a power off, but still this is what seems to be happening.

        Either I'm being stupid and overlooking something obvious, or this is a very weird problem.


        • #5
          I appear to be having the same problem with a new ThinkPad Edge. I bought an OCZ Vertex 2 60GB SSD. I have, twice now, installed Ubuntu 10 on it via USB which goes perfectly, except when I do any kind of restart nothing is saved. No updates, no wifi settings, and back to default desktop background.

          I initially also had some boot hangs and issues which appear to have mysteriously disappeared, although I haven't actually updated the BIOS yet or anything. If I run the hdd diagnostics program from the BIOS on the SSD it fails- but I can still boot from it!

          If I plug it in to the USB through an enclosure it doesn't show up on Ubuntu 10 as a drive (nor does the light appear on the enclosure).

          Although the two queries are slightly different, I'm thinking it is something to do with the actual drive, rather than the way Ubuntu is using it.

          The next step I plan to take is to try a different distro on the SSD and chuck it back inside the laptop.


          • #6
            Definitely try a different distro!
            This is of crucial importance.

            As I suggested, laptop mode could be screwing you.

            Please note that you could DEFINITELY and EASILY be running the whole thing out of cache! In LINUX, your entire MAIN MEMORY can be used as a disk cache for improved performance. As memory is needed for normal operations, disk cache is dumped to make room.

            Obviously there is no synchronization going on, and LAPTOP MODE is one of a few things that could be to blame.

            You *MUST* try a different distro in case it is a ubuntu-specific problem that is attacking you, i.e. if you have laptop mode set to spin the disk down and never sync, then the filesystem could be ENTIRELY in main memory!

            Also make sure that you have the latest firmware installed to the SSD.


            • #7
              I guess you are trapped int time-space singularity. May the force be with you


              • #8
                I have exactly the same problem.

                And I am using Arch Linux...

                I even installed it new, with new partitions, new file systems.

                Then I rebooted... into my brand new repartitioned system.

                I turned the laptop (!) off, on... and then I was at the same position with a fully installed system which i had before repartitioning! Oo

                Notebook Model: HP 6555b

                SSD: OCZ Vertex 2 50GB

                Damn it.. I can send it back within one week. When there is no solution here, i'll do so.


                • #9
                  Noone has mentioned the most important detail here.

                  What filesystem are you using on the system experiencing this?


                  • #10
                    I was using the ext4 filesystem.

                    I let this issue rest for a while since I was too lazy to try anything like flashing my bios and upgrading the firmware required a windows machine(OCZ is working on a linux flasher).

                    Anyway, it seems the issue is related to the drive and also happens to people using windows 7. I found this thread on the OCZ forums, OCZ apparently is looking at the issue right now, I think I'll return my drive when they've responded.