No announcement yet.

Intel SSD Ez-Upgrade kit: Beware.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Intel SSD Ez-Upgrade kit: Beware.

    So I've recently purchased an Intel SSD upgrade kit that is very popular with the Intel 40GB SSD being sold out there. The Intel drive is good and works great, but I've had lots of problems with the 'upgrade kit' sold as a bundle with the drive. That's a EZ-UPGRADE SATA/PATA to USB HDD enclosure, using the JMicron JM20337 chip.

    First, the enclosure needs several seconds to be initialized and recognized. What it means to need several seconds is, it is not fast enough for my BIOS to recognize it during POST, thus making it unable to boot up. It's annoying, but as I have several USB drives laying around, it's not a big hassle.

    Second, and most important thing is it just randomly disconnects. It happens every 10 minutes or so, and I can observe the problem on both my Ubuntu 10.04 with kernel 2.6.34 and my SheevaPlug which uses Debian Squeeze stock kernel. I did not recognize it until today when the problem becomes apparent -- so yesterday I've made a mistake: using gparted to resize the partitions in my old hard drive (which is connected to the computer via the enclosure).

    I've lost all of my recent data that I haven't backed up on that drive. I've tried several tools such as testDisk but there was no luck. Also, now I'm stuck with an enclosure that doesn't work reliably. I've tried to see if there is new firmware for that device-- none. I've inspected the PCB to see if there is anything I could do (including removing the R15 resistor -- it is already removed). There is no cure for the enclosure.

    So beware, don't waste your money buying the bundle.

  • #2
    I've tried with an IDE hard drive, strangely the enclosure works just fine with it.

    The SATA doesn't -- it just crashes once in a while.

    dmesg would spit out something like this:
    [ 8943.120000] usb 1-1: reset high speed USB device using orion-ehci and address 2