Announcement

Collapse
No announcement yet.

Finally, A Creative X-Fi Driver Going Into ALSA

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix
    started a topic Finally, A Creative X-Fi Driver Going Into ALSA

    Finally, A Creative X-Fi Driver Going Into ALSA

    Phoronix: Finally, A Creative X-Fi Driver Going Into ALSA

    Support for the Creative X-Fi sound cards on Linux has been a mess to say the least. These high-end audio processors were released by Creative Labs about four years ago and there still isn't pleasant support for the X-Fi series on Linux...

    http://www.phoronix.com/vr.php?view=NzI3MA

  • kUrb1a
    replied
    Those are isolated cases.Trust me buy yourself another card.I don't have creative card so I don't know but my friend has it and it's pain in the ass,especially in kubuntu.But maybe you will be few of those that actually fckin works.

    Leave a comment:


  • harl
    replied
    My Audigy passed away a few days ago,
    and I'm thinking on buy a pcie soundcard

    Is the X-Fi Titanium pci working fine?
    I just want 5.1 analog output and maybe hwmix, and reading this post it seems that works just fine with current drivers (at least on pci versions)

    Leave a comment:


  • tronath
    replied
    My Xtreme Music worked out of the box with 9.10 too. tball, The changelog shows that the driver now supports PCI-E cards, but i'm not sure whether that means notebook cards too.

    Leave a comment:


  • tball
    replied
    Anyone tried Creative Sound Blaster X-Fi Notebook with alsa?
    Its and pciexpress extention card for notebooks. I wonder if anyone have tried that card for linux?

    Leave a comment:


  • rv65
    replied
    I did a Ubuntu 9.10 install to replace 9.04 on this machine and my x-fi works right out of the box. I'm so glad that all my hardware works without having to install drivers save for nVidia, build-essentials, and proprietary codecs.

    Leave a comment:


  • rv65
    replied
    I'm using the X-Fi Xtreme Gamer Super Mega Duper Fatality edition. Mine is really the x-treme gamer Fatality card. It doesn't have the front panel though.

    I just installed ALSA v1.0.21. There is a tutorial on how to do it.

    http://monespaceperso.org/blog-en/20...u-jaunty-9-04/

    Follow the tutorial and you should be fine. Keep in mind that Mint 8 will have native support as Ubuntu 9.10 already has the driver backported to 1.0.20.

    Leave a comment:


  • nbdwt73
    replied
    Which x-fi card are you using and where did you get the driver?

    Leave a comment:


  • rv65
    replied
    ALSA v1.0.21-4 seems to work fine on Mint Linux 7 x64.

    Leave a comment:


  • chabo
    replied
    Thanks, with that driver AC3/DTS pass-through works for me(x-fi xtrememusic)

    Leave a comment:

Working...
X