<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>OpenChrome DRM Still Being Ported To Newer Kernel, Lengthy Process - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2016">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
		<script type="text/javascript">

		  var _gaq = _gaq || [];
		  _gaq.push(['_setAccount', 'UA-1978569-1']);
		  _gaq.push(['_trackPageview']);

		  (function() {
		    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
		  })();


		    Shadowbox.init({
		       skipSetup: true
		   });
		</script>
			</head>
	<body>
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="http://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://www.google.com/+phoronix" class="icon-gplus"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
						<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("c2a9").style.display = 'block';
}
 }, 1000);  
  };
</script>
<strong id="c2a9" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">We Rely On Your Support:</strong>  This site is primarily supported by advertisements. <span style="font-weight: 600;">Ads are what have allowed this site to be maintained for the past 13 years.</span> We do our best to ensure only clean, relevant ads are shown, when any nasty ads are detected, we work to remove them ASAP. If you would like to view the site without ads while still supporting our work, <span style="font-weight: 600;">please consider <a href="http://www.phoronix.com/scan.php?page=phoronix_premium">our ad-free Phoronix Premium</a></span>. You can also consider <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">a tip via PayPal</a>.</strong>
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
							<script type="text/javascript" language="javascript" src="//c.amazon-adsystem.com/aax2/getads.js"></script>
<script type="text/javascript" language="javascript">
//<![CDATA[
aax_getad_mpb({
  "slot_uuid":"93d4eb99-5024-4d4f-b415-404f0c77b4eb"
});
//]]>
</script>
<noscript></noscript>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<header>OpenChrome DRM Still Being Ported To Newer Kernel, Lengthy Process</header>
<div class="author">Written by <a href="http://www.michaellarabel.com/">Michael Larabel</a> in <a href="?page=news_topic&amp;q=VIA">VIA</a> on 25 August 2017 at 06:10 AM EDT. <a href="/forums/node/971966">1 Comment</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="VIA -- " src="assets/categories/via.jpg" width="100" height="100" /></div>
Self-appointed OpenChrome project maintainer Kevin Brace who for the past <a href="http://www.phoronix.com/scan.php?page=news_item&px=OpenChrome-Maintainer-Hope">year or so</a> has been single-handedly managing the open-source VIA "OpenChrome" graphics driver code-base, is still working towards getting the work-in-progress Direct Rendering Manager (DRM) driver working on newer builds of the Linux kernel.<br /><br />Brace has been working on getting the OpenChrome DRM driver working off the drm-next 4.13 kernel. He's worked through some compiler issues, but the code itself is still broken and the X.Org Server cannot start due to GEM/TTM memory management issues but at least a frame-buffer console will work.<br /><br />Meanwhile, he's also still maintaining a Linux 3.19 based branch for the OpenChrome driver for now, but intends to abandon that at some point in the future in order to favor the newer kernel cycles.<br /><br />At this stage he has no firm timetable for when he thinks the OpenChrome DRM code would be ready for merging into the mainline Linux kernel. He does also acknowledge the situation is getting tougher for VIA x86 Linux users with more distributions trying to weed out non-PAE 32-bit support or even doing away with their i686 kernel support entirely.<br /><br />Those curious about the state of this unofficial VIA x86 Linux graphics driver can find the newest details via <a href="https://lists.freedesktop.org/archives/openchrome-devel/2017-August/003458.html">the OpenChrome mailing list</a>.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script type="text/javascript">
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
     var gads = document.createElement("script");
     gads.async = true;
     gads.type = "text/javascript";
     var useSSL = "https:" == document.location.protocol;
     gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
     var node =document.getElementsByTagName("script")[0];
     node.parentNode.insertBefore(gads, node);
 })();
</script>

<div id='div-pg-ad-1472399861-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1472399861-3'); });
  </script>
</div>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/971966">1 Comment</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;"><div style="float: left; overflow: hidden;"><div class="g-plus" data-action="share" data-annotation="bubble" data-height="15" data-href="http://www.phoronix.com/scan.php?page=news_item&amp;px=OpenChrome-DRM-Still-Porting"></div><script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="OpenChrome DRM Still Being Ported To Newer Kernel, Lengthy Process" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=OpenChrome-DRM-Still-Porting" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DOpenChrome-DRM-Still-Porting&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
						<div class="after-article">
								<script type="text/javascript" language="javascript" src="//c.amazon-adsystem.com/aax2/getads.js"></script>
<script type="text/javascript" language="javascript">
//<![CDATA[
aax_getad_mpb({
  "slot_uuid":"93d4eb99-5024-4d4f-b415-404f0c77b4eb"
});
//]]>
</script>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 10,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="http://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Related VIA News</header>
								<div class="node"><a href="?page=news_item&amp;px=OpenChrome-DRM-Rebase">OpenChrome Still Pushing For DRM Kernel Driver, Updated DDX</a></div><div class="node"><a href="?page=news_item&amp;px=OpenChrome-DRM-Some-Progress">OpenChrome Maintainer Making Some Progress On VIA DRM Driver</a></div><div class="node"><a href="?page=news_item&amp;px=OpenChrome-0.6-Coming">OpenChrome Driver Continues To Get Fixed Up, New Version Next Month</a></div><div class="node"><a href="?page=news_item&amp;px=OpenChrome-0.5-Released">OpenChrome 0.5 Has Working Support For Multiple Monitors</a></div><div class="node"><a href="?page=news_item&amp;px=OpenChrome-One-Dev-Roadmap">VIA OpenChrome Driver Has A Roadmap, But Only One Developer</a></div><div class="node"><a href="?page=news_item&amp;px=OpenChrome-0.4-Released">OpenChrome 0.4.0 DDX Driver Revives VIA Open-Source x86 Graphics</a></div>
	                             
							</div>
							<div class="article-box">
								<header>Popular News</header>
								<div class="node"><a href="?page=news_item&amp;px=Ubuntu-Dock-In-17.10">Ubuntu Dock Now Present By Default In Ubuntu 17.10's GNOME Session</a></div><div class="node"><a href="?page=news_item&amp;px=Redox-OS-GSoC-Self-Hosting">Rust-Written Redox OS Closer To Self-Hosting</a></div><div class="node"><a href="?page=news_item&amp;px=KDE-Applications-17.08">KDE Applications 17.08 Released, More Apps Ported To KF5</a></div><div class="node"><a href="?page=news_item&amp;px=Tyan-Thunder-GT24EB7106">Hands On With The Tyan Thunder GT24EB7106; Building The Kernel In Under 30 Seconds</a></div><div class="node"><a href="?page=news_item&amp;px=NVIDIA-Vulkan-381.26.13">NVIDIA Releases Vulkan 381.26.13 Beta Linux Driver</a></div><div class="node"><a href="?page=news_item&amp;px=Ardour-5.11-Released">Ardour Digital Audio Workstation 5.11 Released</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=SDL-KHR_no_error">SDL Lands Initial Support For OpenGL KHR_no_error</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=OpenChrome-DRM-Still-Porting">OpenChrome DRM Still Being Ported To Newer Kernel, Lengthy Process</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Go-1.9-Released">Go 1.9 Adds Type Aliases, Parallel Compilation</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-Turns-26">Linux Turns 26 Years Old</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=GIMP-2.9.6-Released">GIMP 2.9.6 Released With GEGL Multi-Threading &amp; Better HiDPI Support</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=No-More-Xeon-Phi-7200-Cards">Intel Quietly Drops Xeon Phi 7200 Coprocessors</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=16-bit-ANV-TGSI">16-bit Support Being Worked On For Intel ANV, Gallium3D TGSI</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=LLVM-ARC-Backend">ARC Backend Merged In LLVM</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=GNOME-Settings-3.26">GNOME Control Center Switches To Its New Settings Layout</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=SUSE-Sticks-With-Btrfs">SUSE Remains Committed To The Btrfs File-System</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          	<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,600]]).display();
	</script>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=25097">New Ryzen Is Running Solid Under Linux, No Compiler Segmentation Fault Issue</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25082">A GNU/Linux Smartphone Running GNOME &amp; HTML5 Web Apps? Priced At $599, Ships In 2019 If The Stars Align</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25091">A Look At The Xeon Gold 6138 + Tyan GT24E-B7106 1U Linux Server Performance</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25079">ASRock AB350 Pro4: A Decent, Linux-Friendly Ryzen Motherboard For As Low As $69 USD</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25076">Ryzen 3 Linux Gaming Benchmarks: NVIDIA vs. AMD Radeon</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[160,600]]).display();
	</script>
                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also use our <a href="http://www.amazon.com/gp/redirect.html?ie=UTF8&location=http%3A%2F%2Fwww.amazon.com%2F&tag=phoronix-20&linkCode=ur2&camp=1789&creative=390957">Amazon.com</a> or <a href="http://www.tkqlhce.com/click-3677526-10515887-1435708588000">NewEgg.com</a> shopping links when making online purchases or contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="http://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="http://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="http://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                    <li><a href="https://www.google.com/+phoronix">Google Plus</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="http://www.phoronix-media.com/?k=legal">Legal Disclaimer</a> | <a href="http://www.phoronix-media.com/?k=contact">Contact</a> | <a href="?page=cookies">Cookie Policy</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2017 by <a href="http://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
				<script type="text/javascript">
		    var googletag = googletag || {};
		    googletag.cmd = googletag.cmd || [];
		    (function() {
		      var gads = document.createElement("script");
		      gads.async = true;
		      gads.type = "text/javascript";
		      var useSSL = "https:" == document.location.protocol;
		      gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
		      var node =document.getElementsByTagName("script")[0];
		      node.parentNode.insertBefore(gads, node);
		     })();
		</script>


		<div id="div-gpt-ad-1363287890054-0-oop">
		    <script type='text/javascript'>
		       googletag.cmd.push(function() {
			 googletag.defineOutOfPageSlot('/8456/IDG.Phoronix.com_Homepage','div-gpt-ad-1363287890054-0-oop').addService(googletag.pubads())
			 googletag.enableServices();
			 googletag.display('div-gpt-ad-1363287890054-0-oop');
		       });
		    </script>
		</div>

		<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
		<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
		<script type="text/javascript">
		bk_ignore_outside_iframe = false;
		bk_doJSTag(17294, 10);
		</script>
			</body>
</html>
