<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>VP9 Added To VA-API's Encode Capabilities For FFmpeg - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2016">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-10 (phoronix.com) -->
		<script type="text/javascript">

		  var _gaq = _gaq || [];
		  _gaq.push(['_setAccount', 'UA-1978569-1']);
		  _gaq.push(['_trackPageview']);

		  (function() {
		    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
		  })();


		    Shadowbox.init({
		       skipSetup: true
		   });
		</script>
			</head>
	<body>
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="http://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://www.google.com/+phoronix" class="icon-gplus"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
						<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("2676c7b").style.display = 'block';
}
 }, 1000);  
  };
</script>
<strong id="2676c7b" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">Phoronix Turns 13:</strong>  Phoronix celebrateed <a href="http://www.phoronix.com/scan.php?page=news_item&px=Phoronix-13-Birthday">its 13th birthday of continuous Linux coverage on June 5</a>. Each year it unfortunately becomes increasingly difficult to operate due to ad-blockers. We rely upon advertisements to continue. If you continue blocking ads, consider <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">a tip via PayPal</a> to help support our work. Or you can get on our ad-free premium service that offers additional benefits with <a href="http://www.phoronix.com/scan.php?page=phoronix_premium">Phoronix Premium</a>. Thanks!</strong>
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
							<script type="text/javascript" language="javascript" src="//c.amazon-adsystem.com/aax2/getads.js"></script>
<script type="text/javascript" language="javascript">
//<![CDATA[
aax_getad_mpb({
  "slot_uuid":"93d4eb99-5024-4d4f-b415-404f0c77b4eb"
});
//]]>
</script>
<noscript></noscript>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<header>VP9 Added To VA-API's Encode Capabilities For FFmpeg</header>
<div class="author">Written by <a href="http://www.michaellarabel.com/">Michael Larabel</a> in <a href="?page=news_topic&amp;q=Multimedia">Multimedia</a> on 25 June 2017 at 07:21 AM EDT. <a href="/forums/node/959390">10 Comments</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="MULTIMEDIA -- " src="assets/categories/multimedia.jpg" width="100" height="100" /></div>
The latest Git code for FFmpeg now supports VA-API accelerated VP9 encoding.<br /><br />VA-API VP9 encode capabilities were <a href="http://www.phoronix.com/scan.php?page=news_item&px=VP9-Hardware-VAAPI-Encode">introduced last year</a> to this Video Acceleration API to complement the existing VP9 decode support. GStreamer was quick to enable <a href="http://www.phoronix.com/scan.php?page=news_item&px=VA-API-VP9-Encode-KBL-GST">the VP9 encode support</a> while now FFmpeg has finally supported it too.<br /><br />On the hardware side, Intel's Kabylake graphics support accelerated VP9 encoding.<br /><br />The VP9 support was added to FFmpeg's vaapi_encode code with <a href="https://github.com/FFmpeg/FFmpeg/commit/bde04604065db565373c315ad13d9c3c5db4d7c9">this commit</a>. VA-API encoders supported by FFmpeg include H.264, HEVC, MJPEG, MPEG2, VP8, and VP9.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script type="text/javascript">
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
     var gads = document.createElement("script");
     gads.async = true;
     gads.type = "text/javascript";
     var useSSL = "https:" == document.location.protocol;
     gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
     var node =document.getElementsByTagName("script")[0];
     node.parentNode.insertBefore(gads, node);
 })();
</script>

<div id='div-pg-ad-1473178251-1'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6874.4_phoronix.com_tier1', [300, 250], 'div-pg-ad-1473178251-1'); });
  </script>
</div>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/959390">10 Comments</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;"><div style="float: left; overflow: hidden;"><div class="g-plus" data-action="share" data-annotation="bubble" data-height="15" data-href="http://www.phoronix.com/scan.php?page=news_item&amp;px=FFmpeg-VP9-Encode"></div><script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="VP9 Added To VA-API's Encode Capabilities For FFmpeg" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=FFmpeg-VP9-Encode" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DFFmpeg-VP9-Encode&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
						<div class="after-article">
								<script type="text/javascript" language="javascript" src="//c.amazon-adsystem.com/aax2/getads.js"></script>
<script type="text/javascript" language="javascript">
//<![CDATA[
aax_getad_mpb({
  "slot_uuid":"93d4eb99-5024-4d4f-b415-404f0c77b4eb"
});
//]]>
</script>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 10,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="http://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Related Multimedia News</header>
								<div class="node"><a href="?page=news_item&amp;px=Opus-1.2-Released">Opus 1.2 Audio Codec Officially Released</a></div><div class="node"><a href="?page=news_item&amp;px=Opus-1.2-Beta">Opus 1.2 Audio Codec Enters Beta</a></div><div class="node"><a href="?page=news_item&amp;px=Kodi-17.2-Released">Kodi 17.2 Released To Fix Security Issue, Bugs</a></div><div class="node"><a href="?page=news_item&amp;px=OpenShot-2.3.3-Released">OpenShot 2.3.3 Fixes Many Stability Issues</a></div><div class="node"><a href="?page=news_item&amp;px=GStreamer-1.12.0-Released">GStreamer 1.12 Makes Its Stable Debut</a></div><div class="node"><a href="?page=news_item&amp;px=SRT-Open-Sourced">SRT Video Transport Protocol Open-Sourced</a></div>
	                             
							</div>
							<div class="article-box">
								<header>Popular News</header>
								<div class="node"><a href="?page=news_item&amp;px=Lennart-casync">Lennart Poettering Announces New Project: casync</a></div><div class="node"><a href="?page=news_item&amp;px=2017-Linux-Laptop-Survey">2017 Linux Laptop Survey</a></div><div class="node"><a href="?page=news_item&amp;px=Ubuntu-17.10-Netplan">Ubuntu 17.10 To Fully Use Netplan By Default For Network Configuration</a></div><div class="node"><a href="?page=news_item&amp;px=Flatpak-Steam-Flathub">Steam Is Now Available In Flatpak Form</a></div><div class="node"><a href="?page=news_item&amp;px=openSUSE-Tumbleweed-PIE">OpenSUSE Tumbleweed Is Now Built With PIE</a></div><div class="node"><a href="?page=news_item&amp;px=NVMe-4.12-Faster-Virtual">With Linux 4.12, Clouds/VMs Backed By NVMe Storage Should Be Much Faster</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           				<script type="text/javascript" language="javascript" src="//c.amazon-adsystem.com/aax2/getads.js"></script>
<script type="text/javascript" language="javascript">
//<![CDATA[
aax_getad_mpb({
  "slot_uuid":"cda00c15-f54b-4a9d-bcda-5cea64eba8b1"
});
//]]>
</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=Intel-HT-Bug-KBL095">Debian Warns Of Hyper Threading Issue With Intel Sky/Kaby Lake CPUs</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=2017-Linux-Laptop-Survey-Early"><span style="font-weight: 600;">An Early Look At Our 2017 Linux Laptop Survey Results So Far</span></a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Early-HID-Input-Linux-4.13">XPad Updates, Google Rose Touchpad Support Heading To Linux 4.13</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=EXT4-Linux-4.13-Work">EXT4 Is Working On A &quot;Large Directory&quot; Option, Parallel Discards</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=FFmpeg-VP9-Encode">VP9 Added To VA-API's Encode Capabilities For FFmpeg</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Latte-Dock-0.7-Features">Latte Dock Is Working On Wayland Support, New Features</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=AMDGPU-VRAM-D-Games">AMDGPU VRAM Improvements Could Help DiRT Rally, Dying Light</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Purism-Librem-GA-Target">Purism Librem 13 / 15 Laptops Hit GA Status</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Ubuntu-17.10-VA-API-Progress">Ubuntu 17.10 Video Acceleration Progress, New Unity-Session Package</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=GNOME-Music-Sluggish-Fix">GNOME Music Should No Longer Be So Sluggish</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script type="text/javascript" language="javascript" src="//c.amazon-adsystem.com/aax2/getads.js"></script>
<script type="text/javascript" language="javascript">
//<![CDATA[
aax_getad_mpb({
  "slot_uuid":"d8bad08d-0ef7-4ddc-ab58-39f4a281a052"
});
//]]>
</script>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=24824">ADATA SU800 128GB SSD On Linux</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=24817">Linux 4.12 Ubuntu Benchmarks With AMD Ryzen, Intel Kabylake - 12 Systems</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=24816">Debian 6.0 Through Debian 9.0 Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=24807">Vulkan vs. OpenGL On Linux With Core i5, Core i7, Ryzen 7</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=24800">AMDGPU-PRO 17.10-429170 vs. Linux 4.12 + Mesa 17.2-dev: Open-Source Continues Strong</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[160,600]]).display();
	</script>
                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also use our <a href="http://www.amazon.com/gp/redirect.html?ie=UTF8&location=http%3A%2F%2Fwww.amazon.com%2F&tag=phoronix-20&linkCode=ur2&camp=1789&creative=390957">Amazon.com</a> or <a href="http://www.tkqlhce.com/click-3677526-10515887-1435708588000">NewEgg.com</a> shopping links when making online purchases or contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="http://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="http://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="http://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                    <li><a href="https://www.google.com/+phoronix">Google Plus</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="http://www.phoronix-media.com/?k=legal">Legal Disclaimer</a> | <a href="http://www.phoronix-media.com/?k=contact">Contact</a> | <a href="?page=cookies">Cookie Policy</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2017 by <a href="http://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
			</body>
</html>
