<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>Radeon's ROCm 1.5 OpenCL Support Is Working Out Better - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2016">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-10 (phoronix.com) -->
		<script type="text/javascript">

		  var _gaq = _gaq || [];
		  _gaq.push(['_setAccount', 'UA-1978569-1']);
		  _gaq.push(['_trackPageview']);

		  (function() {
		    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
		  })();


		    Shadowbox.init({
		       skipSetup: true
		   });
		</script>
			</head>
	<body>
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="http://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://www.google.com/+phoronix" class="icon-gplus"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
						<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("51bac3").style.display = 'block';
}
 }, 1000);  
  };
</script>
<strong id="51bac3" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">Help Make A Great 2017:</strong>  This site is primarily supported by advertisements. <span style="font-weight: 600;">Ads are what have allowed this site to be maintained for the past 12 years.</span> We do our best to ensure only clean, relevant ads are shown, when any nasty ads are detected, we work to remove them ASAP. If you would like to view the site without ads while still supporting our work, <span style="font-weight: 600;">please consider <a href="http://www.phoronix.com/scan.php?page=phoronix_premium">our ad-free Phoronix Premium</a></span>. You can also consider <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">a tip via PayPal</a>.</strong>
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
							<script type="text/javascript" language="javascript" src="//c.amazon-adsystem.com/aax2/getads.js"></script>
<script type="text/javascript" language="javascript">
//<![CDATA[
aax_getad_mpb({
  "slot_uuid":"93d4eb99-5024-4d4f-b415-404f0c77b4eb"
});
//]]>
</script>
<noscript></noscript>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<header>Radeon's ROCm 1.5 OpenCL Support Is Working Out Better</header>
<div class="author">Written by <a href="http://www.michaellarabel.com/">Michael Larabel</a> in <a href="?page=category&item=Display Drivers">Display Drivers</a> on 18 May 2017. <strong>Page 1 of 2</strong>. <a href="/forums/node/952396">5 Comments</a></div>
<div class="content">
<p>With the recent release of <a href="http://www.phoronix.com/scan.php?page=news_item&px=ROCm-1.5-Released">ROCm 1.5</a> followed by <a href="http://www.phoronix.com/scan.php?page=news_item&px=Radeon-ROCm-OpenCL-Opened">the ROCm OpenCL runtime finally being open-sourced</a>, here are some fresh OpenCL benchmarks of this newer Radeon graphics compute stack.</p>
<p>Back when <a href="http://www.phoronix.com/vr.php?view=24028">testing ROCm 1.4 OpenCL</a> back in January, its performance was in some instances coming up slower than the older OpenCL stack bundled within the AMDGPU-PRO driver. Fortunately, with the testing of the latest ROCm OpenCL binary packages, the OpenCL support appears much better as about to be shown in our fresh CL benchmark results.</p>
<p align="center"><a href="http://www.phoronix.com/image-viewer.php?id=rocm-15-opencl&image=rocm_new_opencl_lrg" target="_blank"><img src="http://www.phoronix.net/image.php?id=rocm-15-opencl&image=rocm_new_opencl_med" /></a></p>
<p>As of writing, ROCm still only has complete OpenCL 1.2 run-time and compiler support but some elements of OpenCL 2.0+ including a compatible kernel language implementation. Hopefully in the not too distant future will be complete OpenCL 2.0~2.2 support. At least though this OpenCL stack is much better off than the Clover OpenCL Gallium3D state tracker that hasn't received much attention from AMD in quite a while.</p>
<p>For this testing I was using Ubuntu 16.04.2 LTS, one of the supported platforms for ROCm and where binary packages are available.</p>
<p>While ROCm OpenCL is now open-source, it's not yet in a desirable state for wide adoption on the Linux desktop or servers. ROCm still depends upon unmerged kernel changes, so the ROCm Ubuntu packages in AMD's repository ship with its own 4.9-based kernel. Additionally, it has its own fork of LLVM/Clang/LLD. Hopefully the remaining items will be merged soon and other issues cleaned up so it will be easier to deploy and make use of ROCm across a spectrum of Linux systems.</p>
<div style="text-align: center; overflow: auto;"><script src="//openbenchmarking.org/embed.php?i=1705180-TR-ROCMOPENC40&sha=54e2720&p=0" type="text/javascript"></script><noscript><a href="http://openbenchmarking.org/result/1705180-TR-ROCMOPENC40"><img src="//openbenchmarking.org/embed.php?i=1705180-TR-ROCMOPENC40&sha=54e2720&p=1" /></a></noscript></div>
<p>Just for clarification, the ROCm OpenCL stack is independent of Mesa and does not tie into it or Gallium3D. Disappointing some will be that this ROCm OpenCL stack currently only supports Fiji / Polaris graphics processors and newer.</p>
<p>For some fresh ROCm OpenCL benchmarking I compared the performance of its latest 1.5 packages to that of AMDGPU-PRO 17.10. These tests happened from the Intel Xeon E3-1280 v5 + Sapphire Radeon RX 470 OC system. These OpenCL tests were run via the <a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a>.</p>
</div>
<div id="sharebar"><div style="float: left; overflow: hidden;"><div class="g-plus" data-action="share" data-annotation="bubble" data-height="15" data-href="http://www.phoronix.com/scan.php?page=article&item=rocm-15-opencl&num=1"></div><script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="Radeon's ROCm 1.5 OpenCL Support Is Working Out Better" data-url="http://www.phoronix.com/scan.php?page=article&item=rocm-15-opencl&num=1" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Darticle%26item%3Drocm-15-opencl%26num%3D1&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div>							<div style="text-align: center; overflow: hidden; margin: 10px auto 30px;">
								<script type="text/javascript">
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
     var gads = document.createElement("script");
     gads.async = true;
     gads.type = "text/javascript";
     var useSSL = "https:" == document.location.protocol;
     gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
     var node =document.getElementsByTagName("script")[0];
     node.parentNode.insertBefore(gads, node);
 })();
</script>

<div id='div-pg-ad-1472399861-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1472399861-3'); });
  </script>
</div>
<br />							</div>


					<div class="foot">
								<div class="pagination">
Page: <span>1</span><a href="?page=article&amp;item=rocm-15-opencl&amp;num=2">2</a><a href="?page=article&amp;item=rocm-15-opencl&amp;num=2" title="Go To Next Page">Next Page</a>								</div>
								<div class="comments-label">
									<a href="/forums/node/952396">5 Comments</a>								</div>
							</div>
						</article>
						<div class="after-article">
<div style="text-align: center; overflow: hidden; margin-bottom: 20px;"><script type="text/javascript">
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
     var gads = document.createElement("script");
     gads.async = true;
     gads.type = "text/javascript";
     var useSSL = "https:" == document.location.protocol;
     gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
     var node =document.getElementsByTagName("script")[0];
     node.parentNode.insertBefore(gads, node);
 })();
</script>

<div id='div-pg-ad-1472399861-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1472399861-3'); });
  </script>
</div>
</div><br /><div class="article-box">
								<header>Related Articles</header>
								<div class="node"><a href="/vr.php?view=24649">Linux 4.12 + Mesa 17.2-dev Yields Noticeable Advantages For Radeon Gamers On Ubuntu 17.04</a></div><div class="node"><a href="/vr.php?view=24629">RADV vs. AMDGPU-PRO Vulkan Performance vs. OpenGL In May 2017</a></div><div class="node"><a href="/vr.php?view=24625">Benchmarking The New RadeonSI/Gallium3D Threaded Support</a></div><div class="node"><a href="/vr.php?view=24613">Radeon RX 550: AMDGPU-PRO vs. DRM-Next + Mesa 17.2-dev</a></div><div class="node"><a href="/vr.php?view=24590">Nouveau Re-Clocked With DRM-Next Linux 4.12 + Mesa 17.2-dev vs. NVIDIA 381 Driver</a></div>
	                             
							</div>
							<div class="article-box"><header>Trending Linux News</header><div class="node"><a href="?page=news_item&amp;px=AMD-AOCC-1.0-Released">AMD Releases Optimizing C/C++ Compiler For Ryzen</a></div><div class="node"><a href="?page=news_item&amp;px=Intel-Radeon-Licensing-2017">It's Come Back Up That Intel Is Reportedly Licensing Radeon Graphics IP</a></div><div class="node"><a href="?page=news_item&amp;px=FreeBSD-Q1-2017-Status">FreeBSD Made Progress In Q1'2017 On Linuxulator, Nearly 30k Ports</a></div><div class="node"><a href="?page=news_item&amp;px=Linux-4.12-MIA-Features">The Features You Won't Find In The Linux 4.12 Kernel</a></div><div class="node"><a href="?page=news_item&amp;px=KDE-Plasma-5.10-Beta">KDE Plasma 5.10 Beta Ships With Folder View Default, Improved Wayland</a></div></div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           				<script type="text/javascript" language="javascript" src="//c.amazon-adsystem.com/aax2/getads.js"></script>
<script type="text/javascript" language="javascript">
//<![CDATA[
aax_getad_mpb({
  "slot_uuid":"cda00c15-f54b-4a9d-bcda-5cea64eba8b1"
});
//]]>
</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=GLAMOR-GLES2-Fallback">GLAMOR Updates Land In The X.Org Server, OpenGL ES Fallback</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=PostgreSQL-10-Beta">PostgreSQL 10 Enters Beta</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=UBports-May-13">UBports Continues Plotting To Keep Ubuntu Touch Alive</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=LLVM-NVIDIA-Fortran-Flang">FLANG: NVIDIA Brings Fortran To LLVM</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=KWin-Wayland-HiDPI-Misses-5.10">Better KWin Wayland HiDPI Support Still Baking</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=LibreOffice-5.4-Beta-Tag">LibreOffice 5.4 Beta 1 Tagged, LibreOffice 5.5 On Main</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=AMD-15-More-RADV-Patches">AMD Developer Posts More Patches For RADV</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=openSUSE-Tumbleweed-4.11">OpenSUSE Tumbleweed Rolls In Linux 4.11, KDE Applications 17.04</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Android-Studio-3.0-Canary-1">Android Studio 3.0 Preview Release: Kotlin, Java 8 Features</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Android-O-DP-2">Android O Developer Preview 2 Released, Android Go Announced</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script type="text/javascript" language="javascript" src="//c.amazon-adsystem.com/aax2/getads.js"></script>
<script type="text/javascript" language="javascript">
//<![CDATA[
aax_getad_mpb({
  "slot_uuid":"d8bad08d-0ef7-4ddc-ab58-39f4a281a052"
});
//]]>
</script>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=24651">Radeon's ROCm 1.5 OpenCL Support Is Working Out Better</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=24650">Core i7 7700K vs. Ryzen 7 1800X With Ubuntu 17.04 + Linux 4.12</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=24649">Linux 4.12 + Mesa 17.2-dev Yields Noticeable Advantages For Radeon Gamers On Ubuntu 17.04</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=24641">Trying Out Ballistic Overkill On Linux With Vulkan</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=24636">Trying Out Intel Optane Memory On Linux</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[160,600]]).display();
	</script>
                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also use our <a href="http://www.amazon.com/gp/redirect.html?ie=UTF8&location=http%3A%2F%2Fwww.amazon.com%2F&tag=phoronix-20&linkCode=ur2&camp=1789&creative=390957">Amazon.com</a> or <a href="http://www.tkqlhce.com/click-3677526-10515887-1435708588000">NewEgg.com</a> shopping links when making online purchases or contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="http://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="http://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="http://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                    <li><a href="https://www.google.com/+phoronix">Google Plus</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="http://www.phoronix-media.com/?k=legal">Legal Disclaimer</a> | <a href="http://www.phoronix-media.com/?k=contact">Contact</a> | <a href="?page=cookies">Cookie Policy</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2017 by <a href="http://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
			</body>
</html>
