AMD Linux Graphics: The Latest Open-Source RadeonSI Driver Moves On To Smacking Catalyst
Written by Michael Larabel in Display Drivers on 1 September 2015. Page 1 of 4. 77 Comments

Following this weekend's Radeon R9 Fury open-source Linux driver tests with the DRM-Next code to be merged into Linux 4.3, the latest Mesa 11.1-devel Git code, and LLVM 3.8 SVN for the AMDGPU compiler back-end, I proceeded to run some bleeding-edge open-source Radeon Gallium3D graphics versus AMD Catalyst Linux benchmarks on Ubuntu.

This Linux 4.3 DRM / Mesa 11.1-devel (Git master) / LLVM 3.8 SVN open-source stack was compared to the Catalyst proprietary driver. Originally I was going to use the latest Catalyst 15.7 driver release, but its kernel module was running into issues on this Intel Skylake-based system used for testing on Ubuntu 15.04. Thus I resorted to using the packaged fglrx 15.20.2 / OpenGL 4.4.13374 OpenGL driver as packaged in Ubuntu Vivid that would play fine with the Skylake system running Ubuntu with the Xfce desktop.

The same Intel Core i5 6600K system with the Xfce-based Ubuntu 15.04 was used for all testing. The graphics cards tested for this newest open vs. closed-source driver comparison were the Radeon HD 7950, Radeon R9 285, Radeon R9 290, and Radeon R7 370. The Radeon R9 Fury had to be left out from this comparison due to reverting to the older driver that pre-dates the Fury/Fiji hardware support. All of the benchmarks were carried out using the open-source Phoronix Test Suite benchmarking software with OpenGL games/tests that are able to run on both the open and closed-source drivers. With Mesa 11.1-devel and LLVM 3.8, the RadeonSI Gallium3D driver exposes OpenGL 4.1 compliance compared to Catalyst's OpenGL 4.4 (or now 4.5 with the latest).



Related Articles
Trending Linux News