Results 1 to 10 of 10

Thread: Updated graphics drivers for Ubuntu 12.04 Precise LTS

  1. #1
    Join Date
    Aug 2011
    Posts
    75

    Default Updated graphics drivers for Ubuntu 12.04 Precise LTS

    Hello,

    my launchpad PPA graphics-drivers provides daily updated xorg DDX, dri, glamor, firmwares & mesa packages for Ubuntu 12.04 and 12.04.4. Packages are compiled automatically from launchpad cloned git repos via launchpad build recies. Process is fully automatic and packages are built every day. My PPA should provide similar what oibaf's graphics-drivers. So for those who still using supported 12.04 LTS version of Ubuntu there is easy way how to update & boost graphics support.

    https://launchpad.net/~pali/+archive/graphics-drivers/

    If you have some suggestion or if in my PPA something missing let me know.

  2. #2
    Join Date
    Apr 2014
    Posts
    2

    Default

    Thank you for still supporting 12.04 that i'm still currently using(elementary OS) great to have the latest mesa and open source drivers now when oibaf has dropped the support for 12.04

  3. #3
    Join Date
    May 2014
    Posts
    4

    Default

    I can't start steam, i get dependency errors for libgl1-mesa-dri:i386 and libgl1-mesa-glx:i386

  4. #4
    Join Date
    Aug 2011
    Posts
    75

    Default

    Both packages are for Ubuntu 12.04.0. For updated HW stack in Ubuntu 12.04.4 you need to install libgl1-mesa-glx-lts-saucy:i386 and libgl1-mesa-dri-lts-saucy:i386

  5. #5
    Join Date
    May 2014
    Posts
    4

    Default

    I'm actually on elementary os and it was a fresh install, so i installed steam after adding your ppa.
    Then i tried to ppa-purge the ppa but there were some errors about "luna", i guess it expected "precise" or something.
    Anyway i reinstalled elementary os, installed steam and then added the ppa and all works fine now.

  6. #6
    Join Date
    Feb 2013
    Posts
    63

    Default

    Pali, thank You for support of 12.04 LTS, many people still using that Ubuntu release.

  7. #7
    Join Date
    Sep 2011
    Posts
    28

    Default issues

    If anyone is having issues with not 3D at all after installing Pali PPA: You need to have Ubuntu 12.04.4 - saucy packages.

    First you need to purge Pali's packages.
    Install saucy "LTS Enablement Stacks" via command (this will install newer kernel, xorg, mesa):
    Code:
    sudo apt-get install --install-recommends linux-generic-lts-saucy xserver-xorg-lts-saucy libgl1-mesa-glx-lts-saucy
    more info:https://wiki.ubuntu.com/Kernel/LTSEnablementStack

    Add Pali's PPA.

    Warining: You might have some issues with different versions. Use aptitude to upgrade. In my case it was "mesa-common-dev" and "libgl1-mesa-dev". Use command:
    Code:
    sudo aptitude install mesa-common-dev-lts-saucy mesa-common-dev-
    sudo aptitude install libgl1-mesa-dev-lts-saucy libgl1-mesa-dev-
    (see "minus" in the end - means remove package)

  8. #8

    Default More updates

    Oops, wrong thread...

    Post deleted.
    Last edited by oibaf; 08-01-2014 at 04:30 AM.

  9. #9
    Join Date
    Aug 2011
    Posts
    75

    Exclamation

    Update:

    * original mesa packages (libgl1-mesa-dri, libgl1-mesa-glx) are fixed and glamor should work again ( mesa patch: http://cgit.freedesktop.org/mesa/mes...a5045200f76c25 )
    * in PPA are new -trusty packages (Hardware Enablement Stack for Precise 12.04.5) so upgrade from 12.04.4 to 12.04.5 is possible
    * mesa is recompiled against llvm-3.5 so radeonsi has support for opengl 3.3
    * mesa-demos is updated too, so glxinfo report both opengl and core opengl version (also opengl es)
    * vpdau package is also updated and mesa has enabled radeon and nouveau drivers

    Next steps:
    * update intel vaapi driver for haswell support
    * add opencl support for mesa and intel beignet
    * create new PPA for stable packages (not daily builds -- but stable release versions)

    Note that process of creating source packages and compilation is automated by launchpad servers which compiles everything from upstream git repositories or ubuntu bzr repositories. It working automatically without my (any) interaction. Normally launchpad recompile packages once per day if upstream git/bzr repository contains new commits.

  10. #10
    Join Date
    Aug 2011
    Posts
    75

    Default

    Now my PPA contains new daily builds of:
    * intel vaapi driver
    * intel beignet opencl driver
    * libclc and mesa opencl driver for radeon cards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •