Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: Mplayer builds do not complete in suite tests

  1. #11

    Default

    Quote Originally Posted by deanjo View Post
    Made the changes requested

    Code:
    sleep 3
    CFLAGS=""
    /usr/bin/time -f \"MPlayer Build Time: %e Seconds\" make -s -j \$NUM_CPU_JOBS 2>&1 | grep Seconds" > time-compile-mplayer
    and then running

    ./phoronix-test-suite run universe-cli

    still results in this

    Code:
    ======================================
    Timed MPlayer Compilation (Run 1 of 1)
    ======================================
    
    MPlayer Build Time: 11.03 Seconds
    
    ====================================
    Timed MPlayer Compilation:
    Time To Compile
    
    11.03 Seconds
    
    Average: 11.03 Seconds
    ====================================
    Still no joy.
    What about trying:

    Code:
    #!/bin/sh
    
    cd $1
    
    echo "#!/bin/sh
    
    if [ ! -f MPlayer-1.0rc2.tar.bz2 ]
      then
        echo \"MPlayer Not Installed... Build Failed.\"
        exit
    fi
    
    rm -rf MPlayer-1.0rc2/
    tar -xjf MPlayer-1.0rc2.tar.bz2
    cd MPlayer-1.0rc2/
    ./configure > /dev/null
    sleep 3
    /usr/bin/time -f \"MPlayer Build Time: %e Seconds\" make -s -j \$NUM_CPU_JOBS 2>&1 | grep Seconds
    
    if [ \$? = 2 ]
        then
    /usr/bin/time -f \"MPlayer Build Time: %e Seconds\" make -s 2>&1 | grep Seconds
        exit
    fi" > time-compile-mplayer
    
    chmod +x time-compile-mplayer

  2. #12
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,583

    Default

    Quote Originally Posted by Michael View Post
    What about trying:

    Code:
    #!/bin/sh
    
    cd $1
    
    echo "#!/bin/sh
    
    if [ ! -f MPlayer-1.0rc2.tar.bz2 ]
      then
        echo \"MPlayer Not Installed... Build Failed.\"
        exit
    fi
    
    rm -rf MPlayer-1.0rc2/
    tar -xjf MPlayer-1.0rc2.tar.bz2
    cd MPlayer-1.0rc2/
    ./configure > /dev/null
    sleep 3
    /usr/bin/time -f \"MPlayer Build Time: %e Seconds\" make -s -j \$NUM_CPU_JOBS 2>&1 | grep Seconds
    
    if [ \$? = 2 ]
        then
    /usr/bin/time -f \"MPlayer Build Time: %e Seconds\" make -s 2>&1 | grep Seconds
        exit
    fi" > time-compile-mplayer
    
    chmod +x time-compile-mplayer
    Nope, issue remains
    Code:
    ======================================
    Timed MPlayer Compilation (Run 1 of 1)
    ======================================
    
    MPlayer Build Time: 12.19 Seconds
    
    ====================================
    Timed MPlayer Compilation:
    Time To Compile
    
    12.19 Seconds
    
    Average: 12.19 Seconds
    ====================================
    
    ^C
    dean@linux:~/phoronix-test-suite>

  3. #13
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    I would guess that some build-deps are missing.

  4. #14
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,583

    Default

    Quote Originally Posted by Kano View Post
    I would guess that some build-deps are missing.
    Like I mentioned earlier, if the mplayer test is the first test in a suite then it builds fine everytime.

    BTW, Michael the latest git doesn't resolve it.
    Last edited by deanjo; 05-18-2008 at 11:29 AM.

  5. #15
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    For testing I would remove the |grep Seconds, then you see more. Also I don't get what errorlevel 2 should be for the fallback.

  6. #16
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,583

    Default

    Quote Originally Posted by Kano View Post
    For testing I would remove the |grep Seconds, then you see more. Also I don't get what errorlevel 2 should be for the fallback.
    Where would I see more?

  7. #17
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,583

    Default

    Quote Originally Posted by deanjo View Post
    Where would I see more?
    Going through the results on PTS Global I can see many cases where mplayer chokes..

    http://global.phoronix-test-suite.co...25-20598-18993
    http://global.phoronix-test-suite.co...82-31553-10291
    http://global.phoronix-test-suite.co...303-1646-12021
    http://global.phoronix-test-suite.co...365-9330-18416

    In fact some don't even report a mplayer run

    http://global.phoronix-test-suite.co...13-15700-15081


    Maybe dumping mplayer in favor of something else like compiling the kernel would be a better option (or do I dare say xine-lib )

  8. #18
    Join Date
    Apr 2008
    Posts
    126

    Default

    Or dare I say, Firefox 3!

  9. #19
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,583

    Default

    Quote Originally Posted by apaige View Post
    Or dare I say, Firefox 3!
    lol, why not just openoffice then, that should kill an hour or two.

  10. #20

    Default

    The Linux kernel profile is already in there... Hmm I don't think many users would run the test though if it took in excess of 30 minutes for a compilation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •