Results 1 to 4 of 4

Thread: Need help on Ubuntu 14.04 3-way SLI triple monitor config

  1. #1
    Join Date
    Jun 2011
    Posts
    4

    Default Need help on Ubuntu 14.04 3-way SLI triple monitor config

    I spent last night trying to get a working xorg.conf for my triple monitor setup. I have 3 cards in SLI, and one monitor is attached to the same DVI output of each card. The connection must be correct as I follow the driver guide under Windows and it has been working for roughly a year.

    I am using nvidia-331 driver, but so far, I still can't get it to work. Previously I always used nvidia-settings GUI to configure my two monitors (attached to a single card).

    Apparently the official guide is a bit too old. I don't see those menus at all. Or do I have to enable something in order to see them?
    http://www.nvidia.com/docs/IO/40049/...ode_UG_v20.pdf

    This is what nvidia-settings generated when I selected baseMosaic (that's the only option showed up) in Advanced mode, and enabled all three monitors. It doesn't even put in my other two graphics card, and of course it doesn't work...

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 331.20  (buildd@roseapple)  Mon Feb  3 15:07:22 UTC 2014
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Ancor Communications Inc ASUS VG23A"
        HorizSync       28.0 - 83.0
        VertRefresh     50.0 - 85.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 780"
        BusID          "PCI:3:0:0"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-3"
        Option         "metamodes" "GPU-b11aaba5-35b5-34d1-7f7b-ef1a725dd295.DVI-D-0: nvidia-auto-select +0+0, GPU-9be24007-1ce7-d5ef-5200-f79d58eae5cf.DVI-D-0: nvidia-auto-select +1920+0, GPU-0379d301-0e03-4c1d-1499-e1e405dc6113.DVI-D-0: nvidia-auto-select +3840+0"
        Option         "MultiGPU" "Off"
        Option         "SLI" "off"
        Option         "BaseMosaic" "on"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    I tried several options according to Arch Linux wiki, but no matter what I do, I got a failsafe config after I reboot.
    https://wiki.archlinux.org/index.php/NVIDIA

    Code:
    Section "Device"
        Identifier "Default Card 1"
        BusID "PCI:3@0:0:0"
    EndSection
    
    Section "Device"
        Identifier "Default Card 2"
        BusID "PCI:4@0:0:0"
    EndSection
    
    Section "Device"
        Identifier "Default Card 3"
        BusID "PCI:5@0:0:0"
    EndSection
    Another problem is that if I log out, I got no display any more and have to reboot. Lock screen still works.

    Honestly I am not familiar with xorg config at all. So any documents/pointers/instructions will be greatly appreciated. Thank you.

  2. #2
    Join Date
    Mar 2014
    Posts
    10

    Default

    I have GTX670 SLi setup with triple monitor "Mosaic". I have two monitors plugged into the first card and one plugged into the second one, it's the only way it'll let me set it up. If I were you I'd just nuke your xorg config and just configure it through the nvidia control panel. My main gripe is it won't provide surround resolutions to programs like games and you'll only really be able to run things on one screen at a time. You'll still get a spanned desktop but it still misses that functionality.

  3. #3
    Join Date
    Jun 2011
    Posts
    4

    Default

    Quote Originally Posted by laykun View Post
    I have GTX670 SLi setup with triple monitor "Mosaic". I have two monitors plugged into the first card and one plugged into the second one, it's the only way it'll let me set it up. If I were you I'd just nuke your xorg config and just configure it through the nvidia control panel. My main gripe is it won't provide surround resolutions to programs like games and you'll only really be able to run things on one screen at a time. You'll still get a spanned desktop but it still misses that functionality.
    That's the first thing I did, and both nvidia control panel and nvidia-xorg refuses to give me a triple monitor setup no matter what options I select. The first xorg.conf I pasted is exactly what control panel gives me when I enable Mosaic and all three monitors... Nvidia control panel used to handle all these for me, but it failed quite hard this time.

    Connection-wise, there is official guides on what ports will work together, and as I said, the ones I am using is verified by the guide and Windows settings. I will give it another try this weekend, and see if at least, I can change the enabled monitor from the right one to the middle one...

    I wonder could you share your xorg.conf generated by nvidia control panel? That could help me identify what I might missed in my config. I am not looking for surround gaming. I actually want them to be treated as 3 monitors for workstation purpose.

  4. #4
    Join Date
    Mar 2014
    Posts
    10

    Default

    Sure thing.

    Here you go :

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 334.21  (buildmeister@swio-display-x64-rhel04-16)  Thu Feb 27 14:37:03 PST 2014
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection                                                                                                                                                                                                                                       
                                                                                                                                                                                                                                                        
    Section "Monitor"                                                                                                                                                                                                                                   
        Identifier     "Monitor0"                                                                                                                                                                                                                       
        VendorName     "Unknown"                                                                                                                                                                                                                        
        ModelName      "Samsung SyncMaster"                                                                                                                                                                                                             
        HorizSync       30.0 - 81.0                                                                                                                                                                                                                     
        VertRefresh     56.0 - 75.0                                                                                                                                                                                                                     
        Option         "DPMS"                                                                                                                                                                                                                           
    EndSection                                                                                                                                                                                                                                          
                                                                                                                                                                                                                                                        
    Section "Monitor"                                                                                                                                                                                                                                   
        Identifier     "Monitor1"                                                                                                                                                                                                                       
        VendorName     "Unknown"                                                                                                                                                                                                                        
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 670"
    EndSection
    
    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 670"
        BusID          "PCI:4:0:0"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "metamodes" "DVI-I-1: 1920x1200 +0+0, DVI-D-0: nvidia-auto-select +3840+0, DP-1: 1920x1200 +1920+0" 
        Option         "MetaModeOrientation" "RightOf"
        Option         "SLI" "AFR"
        Option         "TripleBuffer" "true" 
        Option         "BaseMosaic" "on"
        SubSection     "Display"
            Virtual     5760 1200
            Depth       24
        EndSubSection
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •