Results 1 to 2 of 2

Thread: help with nouveau on ubuntu powerpc, GeForce4MX (NV17)

  1. #1
    Join Date
    May 2014
    Location
    Chicago
    Posts
    3

    Default help with nouveau on ubuntu powerpc, GeForce4MX (NV17)

    PowerMac G4 MDD/867 GForce4MX (NV17)
    I have never been able to successfully boot to X with any distro that uses nouveau instead of nv driver.
    The only reasonably-current distro I can get to work right now is Debian 6.0.9 with nv.

    At X startup I get errors:
    Nouveau: Invalid ROM contents
    Nouveau returns -22

    I get a black screen with mouse pointer. After moving mouse I find a text input location and type my password, and that gives me a basic X desktop (using lubuntu so it's OpenBox) with 4 bit depth. I'm pretty sure it's not using nouveau at that point.

    sudo xrandr gives "Can't open Display."

    Some info from Xorg log (trimmed):

    ~/Documents/ubuntu_PPC$ egrep 'EE|WW' Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 57.187] (EE) [drm] failed to open device
    [ 57.187] (EE) No devices detected.
    [ 57.189] (WW) Warning, couldn't open module nvidia
    [ 57.189] (EE) Failed to load module "nvidia" (module does not exist, 0)
    [ 57.193] (WW) Warning, couldn't open module modesetting
    [ 57.193] (EE) Failed to load module "modesetting" (module does not exist, 0)
    [ 57.215] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
    [ 57.215] (WW) xf86OpenConsole: setsid failed: Operation not permitted
    [ 57.296] (EE) [drm] failed to open device
    [ 57.842] (EE) AIGLX: reverting to software rendering

    I think the nouveau developers didn't have access to a Mac-version GeForce4MX, so their probe doesn't recognize the NV17 card.
    Any ideas for troubleshooting further or how to overcome this?

  2. #2
    Join Date
    May 2014
    Location
    Chicago
    Posts
    3

    Default

    More info:
    killed lightdm and sudo'd to su.
    ran Xorg -configure
    Here's the output:

    X.Org X Server 1.15.1
    Release Date: 2014-04-13
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.2.0-53-powerpc64-smp ppc Ubuntu
    Current Operating System: Linux schooner2 3.13.0-24-powerpc-smp #47-Ubuntu SMP Sat May 3 02:03:13 UTC 2014 ppc
    Kernel command line: root=UUID=219c8b58-7e5b-49f3-a715-9c552f70df25 ro quiet splash video=1280x1024:60
    Build Date: 16 April 2014 01:45:07PM
    xorg-server 2:1.15.1-0ubuntu2 (For technical support please see http://www.ubuntu.com/support)
    Current version of pixman: 0.30.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Tue May 13 22:42:45 2014
    List of video drivers:
    s3
    sisusb
    ati
    r128
    mach64
    sis
    nouveau
    trident
    tdfx
    savage
    radeon
    mga
    fbdev
    (++) Using config file: "/root/xorg.conf.new"
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    Number of created screens does not match number of detected devices.
    Configuration failed.
    (EE) Server terminated with error (2). Closing log file.
    Last edited by gsahli; 05-14-2014 at 07:31 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •