Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Linux 3.14 Isn't Going To Make It Into Ubuntu 14.04 LTS

  1. #1
    Join Date
    Jan 2007
    Posts
    15,112

    Default Linux 3.14 Isn't Going To Make It Into Ubuntu 14.04 LTS

    Phoronix: Linux 3.14 Isn't Going To Make It Into Ubuntu 14.04 LTS

    The Ubuntu 14.04 LTS kernel freeze is less than one week and it looks like by all indications are that the Linux 3.14 kernel will not make it for the next Ubuntu LTS release...

    http://www.phoronix.com/vr.php?view=MTY0NTc

  2. #2
    Join Date
    Mar 2014
    Posts
    3

    Default

    It's a pitty, that 3.14 did not make it. I really need the 3.14 btrfs patches.

    Did it ever happen, that ubuntu was upgrading the kernel during a yy.mm.x x=service_release ?
    I thought they pack everything together for a new installer cd?

  3. #3
    Join Date
    Mar 2010
    Posts
    30

    Default

    there never were any plans to use 3.14, the unstable branch is used for preparing the next release

    that said, 3.13.0-20.41 uploaded last night includes a separate i915_bdw driver for Broadwell, based on v3.14-rc8 + backports..

  4. #4
    Join Date
    Mar 2010
    Posts
    30

    Default

    Quote Originally Posted by da.haensch View Post
    It's a pitty, that 3.14 did not make it. I really need the 3.14 btrfs patches.

    Did it ever happen, that ubuntu was upgrading the kernel during a yy.mm.x x=service_release ?
    I thought they pack everything together for a new installer cd?
    The LTS dot releases where x > 1 use a backport stack from LTS+N. So 12.04.2 image used the kernel+X from 12.10, 12.04.3 from 13.04, 12.04.4 from 13.10 and the final one 12.04.5 (Aug '14) will use the stack from 14.04.

    The same scheme will be used for 14.04.x. 14.04.1 will be released roughly the same time as 12.04.5 by August or so, and will carry additional SRU's accumulated during the three months after 14.04 release.

  5. #5
    Join Date
    Dec 2012
    Posts
    459

    Default

    I don't understand the fuzz about not using 3.14. LTS refreshes were introduced for this specific reason: to enable hardware that was introduced after the release. I think it's a good thing Ubuntu is not rushing to the latest kernel. For all I know, that could destabilize the total release if this kernel is plagued by new bugs.

  6. #6
    Join Date
    Apr 2011
    Location
    Sofia, Bulgaria
    Posts
    75

    Default

    Does anyone here thinks that even LTS releases see production deployment the next day after release? It will take months if not years. So there should be no big harm in using the latest kernel if it brings tangible benefits. OTOH if Cannonical are wiling to maintain backports - all power to them. But is a backport more stable than the native kernel where it's taken from?

  7. #7
    Join Date
    Aug 2008
    Location
    Netherlands
    Posts
    285

    Default

    Quote Originally Posted by kobblestown View Post
    Does anyone here thinks that even LTS releases see production deployment the next day after release? It will take months if not years. So there should be no big harm in using the latest kernel if it brings tangible benefits. OTOH if Cannonical are wiling to maintain backports - all power to them. But is a backport more stable than the native kernel where it's taken from?
    I was thinking the same thing. I can't picture any serious mainaner thats willing to install a freshly delivered OS. Doesn't matter if its Linux, Windows or IOS. In our organisation there are still roughly 60.000 windows xp users, to clarify my point.

    Maybe its about SLA's with manufacturers or something, the whole timetables of bug discovery shifts when they introduce such a big change this late.

    I'll probably just download the latest mainline kernel files and do a sudodpkg -i *.deb (yes i'm that lazy... all good programmers are).

  8. #8
    Join Date
    Jun 2012
    Posts
    29

    Post IT will test 14.04 as is to decide if Trusty is a reliable/compliant OS

    Sure nobody in his right mind would deploy a fresh OS on dozens of workstations - and frankly there is never a rush to do so. XP? End of support has been announced years back, and the XP machines are most probably out of steam, so it takes a very clumsy guy in charge to specifically target Trusty.

    The importance of getting kernel 3.14 is about benchmarks that IT departments will do when they consider deploying this LTS or other OSes. Broadwell support might be a very important point - I am thinking of financial services where they will get the most of the latest hardware, including using graphical processors to deal with complex equations. Benchmarks performed in June should get a very stable kernel and maybe some requisites which are in 3.14. A franken kernel sounds good, yet it requires lots of additional work to eventually reach the same level of stability as with the original kernel.

    Even if they only plan to deploy in 2015 they will test 14.04, or 14.04.1 (around August 15th) but not 14.04.2 (late January 2015) which is the one coming with the following Hardware Enablement Stack (kernel polished for 14.10; will they choose to sync with a longterm kernel for that one?).
    Last edited by vk512; 03-28-2014 at 06:03 AM.

  9. #9
    Join Date
    Sep 2011
    Posts
    703

    Default

    Quote Originally Posted by Rexilion View Post
    I don't understand the fuzz about not using 3.14. LTS refreshes were introduced for this specific reason: to enable hardware that was introduced after the release. I think it's a good thing Ubuntu is not rushing to the latest kernel. For all I know, that could destabilize the total release if this kernel is plagued by new bugs.
    Theres radion powermanagment by default in 3.14 for cards that where released quite some time ago

  10. #10
    Join Date
    Sep 2010
    Posts
    55

    Default

    Eventhough I really like Ubuntu, since their move to Unity it became clear to me that it wasn't the distribution that fitted my need. So I took the curve and learned Arch. Quite frankly I've been please with it for all my workstation. And I've moved my servers to Debian instead.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •