Just tried to install the latest nexuiz client and pts doesn't recognize that the newer version is available.
I had 2.4 installed and the only way to get 2.4.2 is to use force-install.

Using the latest git code.