Results 1 to 10 of 11

Thread: Radeon HD 2400 Pro Terrible? Or just something I'm missing?

Hybrid View

  1. #1
    Join Date
    Sep 2013
    Posts
    150

    Default Radeon HD 2400 Pro Terrible? Or just something I'm missing?

    I recently got a Radeon HD 2400 Pro, and tried it on the latest daily of Ubuntu 14.04 (as of maybe two days ago). The game I tried on it (StepMania) ran pretty badly seemingly (not going above 60; randomly staying at 30 FPS at times).

    This happened on both Ubuntu with Unity, and Xubuntu with and without desktop compositing. I've even tried running StepMania with vblank_mode=0 to no avail, and vsync was disabled in-game. I've tried it with the included 3.13 kernel, and latest daily kernel too, and with radeon.dpm=1 (although if I checked the logs correctly, it would seem all the clock states are the same, making dpm useless?).

    Under Windows, StepMania gets about 100 FPS with both the OpenGL and Direct3D renderer. I believe glxgears had a framerate of around 1500 (if that means anything).

    I'd rather have Linux on the computer, but I need StepMania to have the best performance possible. Is there anything I could do or maybe overlooked to have better performance with StepMania?

  2. #2
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    480

    Default

    You could add
    Code:
    SwapBuffersWait "false"
    to your xorg.conf in the device section.

  3. #3
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,994

    Default

    You also need to disable swapbufferswait in xorg.conf in order to enable tearing (or going over display rate in fullscreen apps).

    That said, it's an extremely low-end card, a $10 6450 would beat it silly.

  4. #4
    Join Date
    Sep 2013
    Posts
    150

    Default

    Quote Originally Posted by curaga View Post
    You also need to disable swapbufferswait in xorg.conf in order to enable tearing (or going over display rate in fullscreen apps).
    I did this (Xorg's log also says it's disabled; also disabled Pageflipping and EAXVsync), but StepMania still refuses to go over 60 FPS. Vsync still disabled in-game. glxgears on desktop doesn't go past 60 FPS on it's own either, yet dragging a window on the desktop shows tearing (with and without compositing on Xubuntu).

  5. #5
    Join Date
    Dec 2007
    Posts
    2,329

    Default

    Quote Originally Posted by Espionage724 View Post
    I did this (Xorg's log also says it's disabled; also disabled Pageflipping and EAXVsync), but StepMania still refuses to go over 60 FPS. Vsync still disabled in-game. glxgears on desktop doesn't go past 60 FPS on it's own either, yet dragging a window on the desktop shows tearing (with and without compositing on Xubuntu).
    Set env var vblank_mode=0 and try running the game.

  6. #6
    Join Date
    Sep 2013
    Posts
    150

    Default

    I was attaching vblank_mode=0 to it as well but it still didn't work.

    Due to some permissions thing, I was running StepMania as root, so I ran it like vblank_mode=0 sudo '/opt/sm-ssc/stepmania'; not too sure if the env variable gets ignored when using sudo or what. After taking ownership of the folder however and using that env var, StepMania's framerate was fine (above 60)

  7. #7
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,994

    Default

    sudo clears the env.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •