Results 1 to 3 of 3

Thread: Triple head with radeon and nouveau (clone issue)

  1. #1
    Join Date
    Dec 2008
    Location
    Syros, Greece
    Posts
    29

    Default Triple head with radeon and nouveau (clone issue)

    Hello to all.

    After struggling for some days, I have finally managed to drive three monitors on my system by using one AMD (with radeon) card and one Nvidia (with nouveau) card. One monitor (the center and primary one) is on the AMD and the other two (suppose to be left and right of the primary) on the Nvidia one.

    Although all monitors are activated, the two connected on the Nvidia card are cloned and not independent.

    Here is my xorg.conf:

    Code:
    Section "Device"
        Identifier             "HD8670"
        Driver                 "radeon"
        BusID                  "PCI:1:0:0"
        Option                 "Monitor-VGA-0" "VGA-0"
    EndSection
    
    Section "Device"
        Identifier             "NVS290"
        Driver                 "nouveau"
        BusID                  "PCI:2:0:0"
        Option                 "Monitor-DVI-I-1" "DVI-I-1"
        Option                 "Monitor-DVI-I-2" "DVI-I-2"
    EndSection
    
    Section "Monitor"
        Identifier             "DVI-I-1"
        Option                 "PreferredMode" "1280x1024"
    EndSection
    
    Section "Monitor"
        Identifier             "VGA-0"
        Option                 "PreferredMode" "1680x1050"
    EndSection
    
    Section "Monitor"
        Identifier             "DVI-I-2"
        Option                 "PreferredMode" "1280x1024"
    EndSection
    
    Section "Screen"
        Identifier             "Screen0"
        Device                 "HD8670"
        Monitor                "VGA-0"
    EndSection
    
    Section "Screen"
       Identifier              "Screen1"                                                                                                                         
       Device                  "NVS290"                                                                                                                          
       Monitor                 "DVI-I-1"                                                                                                                         
    EndSection                                                                                                                                                   
                                                                                                                                                                 
    Section "Screen"                                                                                                                                             
       Identifier              "Screen2"                                                                                                                         
       Device                  "NVS290"                                                                                                                          
       Monitor                 "DVI-I-2"                                                                                                                         
    EndSection                                                                                                                                                   
                                                                                                                                                                 
    Section "ServerLayout"                                                                                                                                       
        Identifier      "Main Layout"                                                                                                                            
        Option          "Xinerama" "on"                                                                                                                          
        Option          "Clone" "off"                                                                                                                            
        Screen          0 "Screen0"                                                                                                                              
        Screen          1 "Screen1" RightOf "Screen0"                                                                                                            
        Screen          2 "Screen2" LeftOf "Screen0"                                                                                                             
    EndSection
    And here you can find my Xorg.0.log: http://paste.opensuse.org/95137931

    Am I missing something to make the two Nvidia connected monitors (left and right) to work independently and not cloned to each other?

    Any help is appreciated. Thanks.

  2. #2
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    515

    Default

    I think you need something like this:

    Code:
    Section "Device"
        Identifier             "HD8670"
        Driver                 "radeon"
        BusID                  "PCI:1:0:0"
        Screen                0
        Option                 "Monitor-VGA-0" "VGA-0"
    EndSection
    
    Section "Device"
        Identifier             "NVS290a"
        Driver                 "nouveau"
        BusID                  "PCI:2:0:0"
        Screen                0
        Option                 "Monitor-DVI-I-1" "DVI-I-1"
    EndSection
    
    Section "Device"
        Identifier             "NVS290b"
        Driver                 "nouveau"
        BusID                  "PCI:2:0:0"
        Screen                1
        Option                 "Monitor-DVI-I-2" "DVI-I-2"
    EndSection
    
    Section "Monitor"
        Identifier             "DVI-I-1"
        Option                 "PreferredMode" "1280x1024"
    EndSection
    
    Section "Monitor"
        Identifier             "VGA-0"
        Option                 "PreferredMode" "1680x1050"
    EndSection
    
    Section "Monitor"
        Identifier             "DVI-I-2"
        Option                 "PreferredMode" "1280x1024"
    EndSection
    
    Section "Screen"
        Identifier             "Screen0"
        Device                 "HD8670"
        Monitor                "VGA-0"
    EndSection
    
    Section "Screen"
       Identifier              "Screen1"                                                                                                                         
       Device                  "NVS290a"                                                                                                                          
       Monitor                 "DVI-I-1"                                                                                                                         
    EndSection                                                                                                                                                   
                                                                                                                                                                 
    Section "Screen"                                                                                                                                             
       Identifier              "Screen2"                                                                                                                         
       Device                  "NVS290b"                                                                                                                          
       Monitor                 "DVI-I-2"                                                                                                                         
    EndSection                                                                                                                                                   
                                                                                                                                                                 
    Section "ServerLayout"                                                                                                                                       
        Identifier      "Main Layout"                                                                                                                            
        Option          "Xinerama" "on"                                                                                                                          
        Option          "Clone" "off"                                                                                                                            
        Screen          0 "Screen0"                                                                                                                              
        Screen          1 "Screen1" RightOf "Screen0"                                                                                                            
        Screen          2 "Screen2" LeftOf "Screen0"                                                                                                             
    EndSection
    A device section per head and the "Screen x" option to number the heads per card.

    /edit:
    The important thing from the xorg.conf man page:
    Screen number
    This option is mandatory for cards where a single PCI entity can drive more than one display (i.e., multiple CRTCs
    sharing a single graphics accelerator and video memory). One Device section is required for each head, and this
    parameter determines which head each of the Device sections applies to. The legal values of number range from 0 to
    one less than the total number of heads per entity. Most drivers require that the primary screen (0) be present.
    Last edited by droste; 03-12-2014 at 06:34 PM.

  3. #3
    Join Date
    Dec 2008
    Location
    Syros, Greece
    Posts
    29

    Default

    Thanks for the reply. I have tried that but the second display on the nvidia adapter is not activated with this xorg.conf (even on clone status).

    I have dropped the xinerama approach and revert again on a pure xrandr solution where the problem is described on the following links:

    http://www.phoronix.com/forums/showt...u-works!/page2
    https://forums.opensuse.org/showthre...TI-Cards/page2 (from post #16)
    https://bugzilla.novell.com/show_bug.cgi?id=867499

    Thanks again, for your time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •