Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: GLAMOR Patch Bomb Can Boost Some Operations By 700~800%

  1. #11
    Join Date
    Mar 2008
    Posts
    209

    Default

    I hope it fixes the grief I have with windowmaker and the radeon r7 240 I have...that's sitting on the desk.

  2. #12
    Join Date
    Oct 2007
    Posts
    1,283

    Default

    This patch bomb offers ... overflow errors
    Hopefully, you meant fixes for theose errors. ;P

  3. #13
    Join Date
    Dec 2007
    Posts
    2,395

    Default

    I've already ported most of these improvements to standalone glamor:
    http://lists.freedesktop.org/archive...ry/000567.html

  4. #14
    Join Date
    Mar 2008
    Posts
    209

    Default

    Just stuck the card back in with 3.13.6 and archlinux and now the radeonsi driver is definitely usable. With 3.12 it was really ugly. Good to see meaningful improvements happening!

  5. #15
    Join Date
    Nov 2008
    Posts
    776

    Default

    Quote Originally Posted by agd5f View Post
    I've already ported most of these improvements to standalone glamor:
    thanks a lot for that. I copied gentoo's git-ebuild (from x11 overlay), targeted it at your git, compiled, and voila! I can finally use urxvt again without it hogging all the CPU or dropping to 1 fps!

    Awesome.

  6. #16
    Join Date
    Oct 2008
    Posts
    3,173

    Default Just to clarify

    These are the same patches Michael already reported a few days ago. They're just being submitted for upstream integration now.

    I've noticed several times lately that Michael has double reported something, with no real indication given to his readers. First when he hears about patches, then a 2nd article when they get committed a few days later.

  7. #17
    Join Date
    Jun 2012
    Posts
    16

    Default

    Quote Originally Posted by smitty3268 View Post
    I've noticed several times lately that Michael has double reported something, with no real indication given to his readers. First when he hears about patches, then a 2nd article when they get committed a few days later.
    I agree but in this case it's justified. The news here is the massive improvement (almost an order of magnitude). Nitpick: the patches are still under review.

  8. #18
    Join Date
    Oct 2008
    Posts
    3,173

    Default

    Quote Originally Posted by jrdls View Post
    I agree but in this case it's justified. The news here is the massive improvement (almost an order of magnitude). Nitpick: the patches are still under review.
    I don't mind the fact that a 2nd article exists, so much as that it makes it sound like there is a major speed boost here on top of what came a few days ago. When the reality is that there is no speed boost, he's just re-reporting the same speed boost.

    It's not clear to me if Michael even realized these patches were the same as before or not.

  9. #19

    Default

    Quote Originally Posted by schmidtbag View Post
    Maybe check your xorg.conf?
    xorg.conf is fine (according to Xorg.log GLAMOR is enabled and working) but in result after login there is only coloured squares on the screen (disabling desktop effect, as expected, doesn't help). With same xorg.conf, this issue is not reproducible with Compiz and Mutter.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •