Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: GLAMOR Can Now Be Enabled For AMD R300/R500 GPUs

  1. #11
    Join Date
    Jan 2007
    Posts
    418

    Default

    I have an R300 based 9600 in my laptop; I wonder if glamor will be faster then EXA on that one ... I guess I should run a benchmark on ancient hardware like that

  2. #12
    Join Date
    Jan 2009
    Posts
    621

    Default

    Quote Originally Posted by oliver View Post
    I have an R300 based 9600 in my laptop; I wonder if glamor will be faster then EXA on that one ... I guess I should run a benchmark on ancient hardware like that
    The fact Glamor can be enabled for R300 doesn't mean it will work. R300 has dedicated 2D hardware, which might not be that bad. Who knows.

  3. #13
    Join Date
    Mar 2014
    Posts
    7

    Default

    Glamor in general isn't fast nor slow. The XRender backend seems to be implemented well (still slower than SNA, but still very usable). The older X11 calls on the other hand are a pain in the ass Just try to benchmark xterm or openttd...

  4. #14
    Join Date
    Dec 2007
    Posts
    2,360

    Default

    Quote Originally Posted by degasus View Post
    Glamor in general isn't fast nor slow. The XRender backend seems to be implemented well (still slower than SNA, but still very usable). The older X11 calls on the other hand are a pain in the ass Just try to benchmark xterm or openttd...
    Legacy core font support should be much faster with the recent glamor changes Eric has been working on. I've ported some of them to the standalone glamor tree:
    http://cgit.freedesktop.org/~agd5f/g...h=eric-xserver

  5. #15
    Join Date
    Mar 2014
    Posts
    7

    Default

    agd5f: For faster fonts, you should also check out keithp's two commits: http://cgit.freedesktop.org/~keithp/...=glamor-server

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •