Results 1 to 7 of 7

Thread: FGLRX still pants with Source games on Linux/Ubuntu?

Hybrid View

  1. #1
    Join Date
    Sep 2013
    Posts
    2

    Default FGLRX still pants with Source games on Linux/Ubuntu?

    I'm trying to play L4D2 on Ubuntu 12.04.4 with the FGLRX Post-Release Updates driver installed through System Settings -> Additional Drivers, but it's stuttering like a bitch, and is having input latency issues too. Last time I tried playing a Source game (Half Life 2: Lost Coast) on Ubuntu 12.04.(3 I think) with my old Radeon 3450, it had major input lag with FGLRX, and the open drivers were just far too slow to use. My current Radeon 7850 is a rock solid 60 FPS with maxed settings on Windows 7 x64, but sadly my attempt to move back to my preferred OS is yet again being hampered with gaming issues.

    Here is a video of the issue. YouTube's video processing has made the game look likes it's running smoother than it actually does. And sorry I couldn't record fullscreen, but the screen recorder I used didn't work unless I used windowed mode. Anyway, the link: https://www.youtube.com/watch?v=kpx8wRXvaoM

    Thanks!

  2. #2
    Join Date
    Feb 2014
    Posts
    27

    Default

    Quote Originally Posted by XingHua31 View Post
    I'm trying to play L4D2 on Ubuntu 12.04.4 with the FGLRX Post-Release Updates driver installed through System Settings -> Additional Drivers, but it's stuttering like a bitch, and is having input latency issues too. Last time I tried playing a Source game (Half Life 2: Lost Coast) on Ubuntu 12.04.(3 I think) with my old Radeon 3450, it had major input lag with FGLRX, and the open drivers were just far too slow to use. My current Radeon 7850 is a rock solid 60 FPS with maxed settings on Windows 7 x64, but sadly my attempt to move back to my preferred OS is yet again being hampered with gaming issues.

    Here is a video of the issue. YouTube's video processing has made the game look likes it's running smoother than it actually does. And sorry I couldn't record fullscreen, but the screen recorder I used didn't work unless I used windowed mode. Anyway, the link: https://www.youtube.com/watch?v=kpx8wRXvaoM

    Thanks!

    I know this isn't particularly helpful but I struggled with exactly the same issue with Portal (first one, not the recently released Portal 2 beta) on my HD5870. The FPS was solid 60fps but would stutter and suffer awful input lag. Same issue, although I hadn't tried L4D2. There's a post with some information here: https://github.com/ValveSoftware/Sou...mes/issues/765 there's a gl_finish cvar suggestion there but it made zero difference for me when I tried it.

    Oddly, turning off anti-aliasing seemed to reduce the input lag despite making zero difference to the framerate as vsync was fixing it to 60.

  3. #3
    Join Date
    Feb 2014
    Posts
    27

    Default

    I know this isn't particularly helpful but I struggled with exactly the same issue with Portal (first one, not the recently released Portal 2 beta) on my HD5870. The FPS was solid 60fps but would stutter and suffer awful input lag. Same issue, although I hadn't tried L4D2. There's a post with some information here: https://github.com/ValveSoftware/Sou...mes/issues/765 there's a gl_finish cvar suggestion there but it made zero difference for me when I tried it.

    Oddly, turning off anti-aliasing seemed to reduce the input lag despite making zero difference to the framerate as vsync was fixing it to 60.

  4. #4
    Join Date
    Feb 2014
    Posts
    27

    Default

    I know this isn't particularly helpful but I struggled with exactly the same issue with Portal (first one, not the recently released Portal 2 beta) on my HD5870. The FPS was solid 60fps but would stutter and suffer awful input lag. Same issue, although I hadn't tried L4D2. There's a post with some information here: github.com/ValveSoftware/Source-1-Games/issues/765 there's a gl_finish cvar suggestion there but it made zero difference for me when I tried it

    Oddly, turning off anti-aliasing seemed to reduce the input lag despite making zero difference to the framerate as vsync was fixing it to 60. I recently just gave up and replaced the 5870 with a cheap GTX 750ti

    edit: I can't post links as my account is too new
    Last edited by Tom B; 03-07-2014 at 12:15 PM.

  5. #5
    Join Date
    Jul 2013
    Posts
    15

    Default

    I've never had this problem with Source games. They work flawlessly for me, and always have.

    Catalyst drivers, Ubuntu 12.04, HD7870

  6. #6
    Join Date
    Mar 2014
    Posts
    19

    Default

    I have a serious performance boost in L4D2 when I switch off V-Sync in the game settings. Also disabling multicore seems to help a little. Some minor stuttering is still there though; but only for a short time after loading a game.

    Probably switching off compositor (XFCE) will help. At least I have better fps in unigine valley since I did that.

  7. #7

    Default

    for L4D2 turn off v-sync. it remove input lag for me. also install latest catalyst as it improve performance and reduce shuttering.

    http://wiki.cchtml.com/index.php/Ubu...TI.27s_site.29

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •